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j. Phase - Phase values range from 0 to 31 and will wrap around. 
Stop at the phase value that produces the best video image for 
the active target server. 

k. Horizontal Offset - Controls the horizontal positioning of the 
target server display on your monitor. 

l. Vertical Offset - Controls the vertical positioning of the target 
server display on your monitor. 

3. Select Auto Color Calibration to enable this feature. 

4. Select the video sensing mode: 

 Best possible video mode 

The  device will perform the full Auto Sense process when 
switching targets or target resolutions. Selecting this option 
calibrates the video for the best image quality. 

 Quick sense video mode 

With this option, the  device will use a quick video Auto Sense in 
order to show the target's video sooner. This option is especially 
useful for entering a target server's BIOS configuration right after 
a reboot. 

5. Click OK to apply the settings and close the dialog. Click Apply to 
apply the settings without closing the dialog. 
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Note: Some Sun background screens, such as screens with very dark 
borders, may not center precisely on certain Sun servers. Use a different 
background or place a lighter colored icon in the upper left corner of the 
screen. 

 
 

Using Screenshot from Target 

You are able to take a screenshot of a target server using the 
Screenshot from Target server command. You save this screenshot to a 
file location of your choosing and can save it as either a bitmap, JPEG, 
or PNG file. 

 To take a screenshot of the target server:  
1. Select Video > Screenshot from Target or click the Screenshot from 

Target button  on the toolbar. 

2. In the Save dialog, choose the location to save the file, name the file, 
and select a file format from the 'Files of type' drop-down. 
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3. Click Save to save the screenshot. 

 
 

Mouse Options 

When controlling a target server, the  Remote Console displays two 
mouse cursors: one belonging to your client workstation and the other 
belonging to the target server.  

You can operate in either single mouse mode or dual mouse mode. 
When in dual mouse mode, and provided the option is properly 
configured, the mouse cursors will align. 

When there are two mouse cursors, the  device offers several mouse 
modes: 

• Absolute (Mouse Synchronization) 
• Intelligent (Mouse Mode) 
• Standard (Mouse Mode) 
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Mouse Pointer Synchronization 

When remotely viewing a target server that uses a mouse, you will see 
two mouse cursors: one belonging to your remote client workstation and 
the other belonging to the target server. When the mouse pointer lies 
within the Virtual KVM Client target server window, mouse movements 
and clicks are directly transmitted to the connected target server. While 
in motion, the client mouse pointer slightly leads the target mouse pointer 
due to mouse acceleration settings. 

On fast LAN connections, you may want to disable the Virtual KVM 
Client mouse pointer and view only the target server's pointer. You can 
toggle between these two modes (single mouse and dual mouse). 

Mouse Synchronization Tips 

Be sure to follow these steps when configuring mouse synchronization: 

1. Verify that the selected video resolution and refresh rate are among 
those supported by the  device. The Virtual KVM Client Connection 
Info dialog displays the actual values that the  is seeing. 

2. Verify that the cable length is within the specified limits for the 
selected video resolution.  

3. Verify that the mouse and video have been properly configured 
during the installation process.  

4. Force an auto-sense by clicking the Virtual KVM Client auto-sense 
button. 

5. If that does not improve the mouse synchronization (for Linux, UNIX, 
and Solaris KVM target servers): 

a. Open a terminal window. 

b. Enter the xset mouse 1 1 command. 

c. Close the terminal window. 

6. Click the "Virtual KVM Client mouse synchronization" button . 
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Additional Notes for Intelligent Mouse Mode 

• Be sure that there are no icons or applications in the upper left 
section of the screen since that is where the synchronization routine 
takes place. 

• Do not use an animated mouse. 
• Disable active desktop on KVM target servers. 

Synchronize Mouse 

In dual mouse mode, the Synchronize Mouse command forces 
realignment of the target server mouse pointer with Virtual KVM Client 
mouse pointer. 

 To synchronize the mouse, do one of the following: 
• Choose Mouse > Synchronize Mouse or click the Synchronize 

Mouse button  in the toolbar. 
 

Standard Mouse Mode 

Standard Mouse mode uses a standard mouse synchronization 
algorithm using relative mouse positions. Standard Mouse mode requires 
that mouse acceleration is disabled and other mouse parameters are set 
correctly in order for the client and server mouse to stay synchronized. 
Standard Mouse mode is the default. 

 To enter standard mouse mode: 
• Choose Mouse > Standard. 
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Intelligent Mouse Mode 

In Intelligent Mouse mode, the  device can detect the target mouse 
settings and synchronize the mouse cursors accordingly, allowing mouse 
acceleration on the target. In this mode, the mouse cursor does a 
“dance” in the top left corner of the screen and calculates the 
acceleration. For this mode to work properly, certain conditions must be 
met. 

 To enter intelligent mouse mode: 
• Choose Mouse > Intelligent. 
Intelligent Mouse Synchronization Conditions 

The Intelligent Mouse Synchronization command, available on the 
Mouse menu, automatically synchronizes mouse cursors during 
moments of inactivity. For this to work properly, however, the following 
conditions must be met: 

• The active desktop should be disabled on the target. 
• No windows should appear in the top left corner of the target page. 
• There should not be an animated background in the top left corner of 

the target page. 
• The target mouse cursor shape should be normal and not animated. 
• The target mouse speeds should not be set to very slow or very high 

values. 
• Advanced mouse properties such as “Enhanced pointer precision" or 

“Snap mouse to default button in dialogs”  should be disabled. 
• Choose “Best Possible Video Mode” in the Video Settings window. 
• The edges of the target video should be clearly visible (that is, a 

black border should be visible between the target desktop and the 
remote KVM console window when you scroll to an edge of the 
target video image). 

• When using the intelligent mouse synchronization function, having a 
file icon or folder icon located in the upper left corner of your desktop 
may cause the function not to work properly. To be sure to avoid any 
problems with this function, Raritan recommends you do not have file 
icons or folder icons in the upper left corner of your desktop.  

After autosensing the target video, manually initiate mouse 
synchronization by clicking the Synchronize Mouse button on the toolbar. 
This also applies when the resolution of the target changes if the mouse 
cursors start to desync from each other. 

If intelligent mouse synchronization fails, this mode will revert to standard 
mouse synchronization behavior. 
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Please note that mouse configurations will vary on different target 
operating systems. Consult your OS guidelines for further details. Also 
note that intelligent mouse synchronization does not work with UNIX 
targets. 
 

Absolute Mouse Mode 

In this mode, absolute coordinates are used to keep the client and target 
cursors in sync, even when the target mouse is set to a different 
acceleration or speed. This mode is supported on servers with USB 
ports.  

 To enter absolute mouse mode: 
• Choose Mouse > Absolute. 

Note: The absolute mouse setting requires a USB target system and is 
the recommended mouse setting for KX II-101. 

Note: Absolute Mouse Synchronization is available for use with the 
virtual media-enabled USB CIM (D2CIM-VUSB and D2CIM-DVUSB) 
only. 
 

Single Mouse Cursor 

Single Mouse mode uses only the target server mouse cursor and the 
local mouse pointer no longer appears onscreen. While in single mouse 
mode, the Synchronize Mouse command is not available (there is no 
need to synchronize a single mouse cursor). 

 To enter single mouse mode, do the following: 
1. Choose Mouse > Single Mouse Cursor. 

2. Click the Single/Double Mouse Cursor button  in the toolbar. 
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 To exit single mouse mode: 
1. Press Ctrl+Alt+O on your keyboard to exit single mouse mode. 
 

Tool Options 

From the Tools menu, you can specify certain options for use with the 
Virtual KVM Client, including logging, setting the keyboard type, and 
defining hot keys for exiting Full Screen mode and Single Cursor mode. 

 To set the tools options: 
1. Choose Tools > Options. The Options dialog appears. 

2. Select the Enable Logging checkbox only if directed to by Technical 
Support. This option creates a log file in your home directory. 

3. Choose the Keyboard Type from the drop-down list (if necessary). 
The options include: 

 US/International 

 French (France) 

 German (Germany) 

 Japanese 

 United Kingdom 

 Korean (Korea) 

 Belgian (Belgium) 

 Norwegian (Norway) 

 Danish (Denmark) 

 Swedish (Sweden) 

 German (Switzerland) 

 Hungarian (Hungary) 

 Spanish (Spain) 

 Italian (Italy) 

 Slovenian  

4. Exit Full Screen Mode - Hotkey. When you enter Full Screen mode, 
the display of the target server becomes full screen and acquires the 
same resolution as the target server. This is the hot key used for 
exiting this mode. 

5. Exit Single Cursor Mode - Hotkey. When you enter single cursor 
mode, only the target server mouse cursor is visible. This is the hot 
key used to exit single cursor mode and bring back the client mouse 
cursor. 
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6. Click OK. 

Keyboard Limitations 

Slovenian Keyboards 

The < key does not work on Slovenian keyboards due to a JRE 
limitation. 

Language Configuration on Linux 

Because the Sun JRE on Linux has problems generating the correct Key 
Events for foreign-language keyboards configured using System 
Preferences, Raritan recommends that you configure foreign keyboards 
using the methods described in the following table. 
 

Language Configuration method 
US Intl Default 

French Keyboard Indicator 

German System Settings (Control Center) 

Japanese System Settings (Control Center) 

UK System Settings (Control Center) 

Korean System Settings (Control Center) 

Belgian Keyboard Indicator 

Norwegian Keyboard Indicator 

Danish Keyboard Indicator 

Swedish Keyboard Indicator 

Hungarian System Settings (Control Center)  

Spanish System Settings (Control Center)  

Italian System Settings (Control Center)  

Slovenian System Settings (Control Center)  

Note: The Keyboard Indicator should be used on Linux systems using 
Gnome as a desktop environment. 
 



Chapter 2: Virtual KVM Client (VKC) 
 

24
 

 

View Options 

View Toolbar 

You can use the Virtual KVM client with or without the toolbar display. 

 To toggle the display of the toolbar (on and off): 
• Choose View > View Toolbar. 

Scaling 

Scaling your target window allows you to view the entire contents of the 
target server window. This feature increases or reduces the size of the 
target video to fit the Virtual KVM Client window size, and maintains the 
aspect ratio so that you see the entire target server desktop without 
using the scroll bar. 

 To toggle scaling (on and off): 
• Choose View > Scaling. 

Target Screen Resolution 

When you enter Full Screen mode, the display of the target server 
becomes full screen and acquires the same resolution as the target 
server. The hot key used for exiting this mode is specified in the Options 
dialog (the default is Ctrl+Alt+M). 

 To enter full screen mode: 
• Choose View > Full Screen. 

 To exit full screen mode: 

Press the hot key configured in the Tools Options dialog. The default is 
Ctrl+Alt+M. 
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5. Use the slider to select the desired level of video Smoothing (15-bit 
mode only). The level determines how aggressively to blend page 
regions with small color variation into a single, smooth color. 
Smoothing improves the appearance of the target video by reducing 
the video noise that is displayed. 

 

Security Tab 
1. Enter the private security key in the Private Key field if your device is 

configured to use a private security key. Entering a security key 
allows you to gain the authorization required to initiate a connection 
to that device. 

2. Retype the private security key in the Confirm Private Key field to 
ensure no typographical errors were made. 
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3. Click OK to create the connection profile. 
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Establishing a New Connection 

Note: Depending on your version of the JRE, you might receive a 
certificate message when using the standalone application to access a 
Dominion device. You have to accept the certificate in order to establish 
the connection. 

To connect to a device, double-click the device's icon in the Navigator, 
then type your user name and password to connect. You can also 
right-click the device name in the Navigator and select New Connection. 

Note: The default device login user name is admin and the default 
password is raritan. You have administrative privileges using these login 
credentials.  

If you do not see an icon for your device in the Navigator, follow the 
instructions on creating new profiles, which is available in this section. 

If you are having problems connecting to a device, be sure to check the 
following: 

• User name -  Raritan usernames are not case-sensitive. 
• Password -  Raritan passwords are case-sensitive. 
• TCP Port -  If you have configured your device to use a non-default 

TCP Port, this information must be entered into its connection profile. 
• Firewall Settings -  If you are accessing a device through a firewall, 

that firewall must be configured to allow two-way communication on 
TCP Port 5000 (or the custom TCP Port to which your device has 
been configured). 

• Security Key -  If you have configured your device to require a 
group security key, that key must be entered into the device's 
connection profile. 

Note: If you are running MPC on Internet Explorer with both a Microsoft 
firewall and a non-Microsoft firewall utility installed, IE will display a 
message telling you that MPC is already running (even if it is not in fact 
running). To avoid this, deactivate one of your firewalls, or use a browser 
such as Mozilla or Firefox. 
 

Connection Information 

 To obtain information about your connection: 
• Choose Connection > Connection Info. The Connection Info dialog 

appears. 
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Generation 1 Devices 

The following information is displayed about a current connection to 
Generation 1 devices: 
 

Connection 
information 

Description 

Device name The name of your device. 

IP address The IP address of your device. 

Port The KVM Communication TCP/IP Port used to 
access the target device. 

Data in/second Data rate in. 

Data out/second Data rate out. 

FPS The frames per second transmitted for video. 

Connect time The duration of the connect time. 

Horizontal resolution The page resolution horizontally. 

Vertical resolution The page resolution vertically. 

Refresh rate How often the page is refreshed. 

Protocol version The RFB Protocol version. 

Oldest supported 
version 

The oldest supported version of the client 
software. 

Hardware version 0 - Obsolete 

Software version 3 (Software version) 

Post code Power on self-test error code. 0 = no error. 

Network flags A list of the various network options that have 
been enabled or disabled such as DHCP, 
dial-in, autodetection, and so on. 

Security flags A list of the various security options that have 
been enabled or disabled such as SSL 
encryption, SNMP, and so on. 

Options RFP and TR support enabled or disabled. 

Frame grabber info 0 - not used 

KME info KME version number for systems that use the 
KME. 

Serial Info  Serial devices 

Video devices count Number of video devices detected. 
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Connection 
information 

Description 

Serial devices count Number of serial devices detected. 

Reserved 0 - not used 

FPS* Frames per second 

* Available only in MPC. 

 To copy this information: 
• Click Copy to Clipboard in the Connection Info dialog. The 

information is now available to be pasted into the program of your 
choice. 

 

Generation 2 Devices 

The following information is displayed about a current connection to 
Generation 2 devices: 
 

Connection 
information 

Description 

Device name The name of your device. 

IP address The IP address of your device. 

Port The KVM Communication TCP/IP Port used to 
access the target device. 

Data in/second Data rate in. 

Data out/second Data rate out. 

FPS The frames per second transmitted for video. 

Connect time The duration of the connect time. 

Horizontal resolution The page resolution horizontally. 

Vertical resolution The page resolution vertically. 

Refresh rate How often the page is refreshed. 

Protocol version The RFB Protocol version. 

 To copy this information: 
• Click Copy to Clipboard in the Connection Info dialog. The 

information is now available to be pasted into the program of your 
choice. 
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Connecting to a Remote KVM Console 

Once you establish a connection with a Raritan device, that device's icon 
in the Navigator can be expanded to display all ports enabled for remote 
access. 

 

Choose one of the following options to establish a remote KVM console 
connection: 

• Double-click the KVM port. This method closes any previous 
connection before connecting to the new port. 

• Right-click the port and choose Switch from the shortcut menu. This 
method closes any previous connection before connecting to the 
new port. 

• Right-click the port and choose New Connection from the shortcut 
menu. This method allows you to connect to the selected port 
without closing any previous connections and creates a new 
connection if the device supports multiple concurrent connections. 

Once connected, Raritan KVM over IP devices display real-time video 
output of the target server (this video is compressed and encrypted 
according to the configuration settings specified by the administrator). 
You now have complete, low-level control of the KVM console as if you 
were physically located next to the server. 

• To close a connection, right-click the connected device and choose 
Disconnect. 

• To exit completely, choose Connection > Exit. 
 

Closing a Remote Connection 

 To close the connection: 
1. Select the device in the Navigator and right-click it.  

2. Choose Disconnect from the shortcut menu. 
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3. To exit completely, click Exit on the Connection menu 
 

Shortcut Menu 

To access the shortcut menu, use either the default keyboard 
combination of Ctrl+Left Alt+M or the keyboard combination you assign. 
See Changing the Shortcut Menu Keyboard Combination (on page 
92) for more information.  

TIP: If at some point you forget the keyboard combination used to open 
the shortcut menu, press Ctrl+Left Alt at the same time. The keyboard 
combination will be displayed across the bottom of the page for five 
seconds.  
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Shortcut Menu Key Options 

Execute any of the commands on the shortcut menu by either choosing 
the command in the menu or using a key combination. If you are using a 
key combination to execute a command, you will press Ctrl+Left Alt+M 
and then press the key on your keyboard that corresponds to the 
underlined letter in the shortcut menu. For example, press Ctrl+Left 
Alt+M+F to enter Full Screen mode. See the table below for information 
on invoking commands from the shortcut menu using keyboard 
combinations. 

Note: You must use the Left Alt key on your keyboard when using the 
Ctrl+Left Alt combination. 
 

To Press Ctrl+Left Alt+M+ 

Toggle between Full/Normal screen 
mode* 

F 

Display connection information* I 

Display or set connection properties* P 

Display or set video settings* V 

Refresh the page R 

Synchronize mouse Y 

Change to/from single/double cursor 
mode 

S 

Send Ctrl+Alt+Del to the target 
system 

D 

Connect Drive T 

Connect CD-ROM/ISO Image E 

Send Ctrl+Alt+M to the target system N 

Exit a dialog or menu without altering 
the keyboard state 

Esc 

* If Full Screen mode is active, executing this command will automatically 
end Full Screen mode. 
 

Changing the Shortcut Menu Keyboard Combination 

 To change the keyboard combination, do the following: 
1. Choose Tools > Options to open the Options dialog. 

2. From the Keyboard Shortcut Menu HotKey drop-down, select the 
keyboard combination you want to use to open the shortcut menu. 
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3. Click OK or Apply. 

Once a new keyboard combination is assigned, the new combination will 
be displayed in the shortcut menu and in the onscreen message that 
displays when the combination is used.  
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Keyboard Macros 

A hot key combination is a set of keystrokes that performs an action 
when pressed. For example, the hot key combination Ctrl+Alt+0 might be 
created to minimize all windows.  

A keyboard macro is a shortcut that sends a hot key combination to a 
target server. Using keyboard macros ensures that hot key combinations 
intended to be used on the target server are sent to and interpreted only 
by the target server, and not by the computer on which the client is 
running. 

Raritan strongly suggests the use of keyboard macros instead of hot key 
combinations since certain hot key combinations have been found not to 
work properly, depending on the platform and behavioral difference 
between the application and web browser version. Specifically, using hot 
keys can result in your own client PC intercepting the command and 
performing the action instead of sending the command to the target 
server as intended. 

Note: In MPC, foreign keyboard layouts are not supported when using 
keyboard macros, except for those keys listed in the Add Keyboard 
Macro dialog for Japanese and Korean. 

 
 

Building a Keyboard Macro 

 To build a macro: 
1. Click Keyboard > Keyboard Macros. The Keyboard Macros dialog 

appears. 

2. Click Add. The Add Keyboard Macro dialog appears. 

3. Type a name for the macro in the Keyboard Macro Name field. This 
name will appear in the Keyboard menu after it is created.  

4. From the Hot-Key Combination field, select a keyboard combination 
from the drop-down list. This allows you to execute the macro with a 
predefined keystroke. Optional 

5. In the Keys to Press drop-down list, select each key you would like to 
use to emulate the keystrokes that will be used to perform the 
command. Select the keys in the order by which they are to be 
pressed. After each selection, select Add Key. As each key is 
selected, it will appear in the Macro Sequence field and a Release 
Key command will automatically be added after each selection.  

6. For example, create a macro to close a window by selecting Left Ctrl 
+ Esc. This will appear as the following in the Macro Sequence box:  

Press Left Ctrl 
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Release Left Ctrl 

Press Esc 

Release Esc 

7. Review the Macro Sequence field to be sure the macro sequence is 
defined correctly.  

a. To remove a step in the sequence, select it and click Remove.  

b. To change the order of steps in the sequence, click the step and 
then click the up or down arrow buttons to reorder them as 
needed. 

8. Click OK to save the macro. Click Clear to clear all field and start 
over. When you click OK, the Keyboard Macros dialog appears and 
lists the new keyboard macro. 
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9. Click Close to close the Keyboard Macros dialog. The macro will now 
appear on the Keyboard menu in the application. Select the new 
macro on the menu to run it or use the keystrokes you assigned to 
the macro. 

 
 

Running a Keyboard Macro 

Once you have created a keyboard macro, execute it using the keyboard 
macro you assigned to it or by choosing it from the Keyboard menu. 

Run a Macro from the Menu Bar 

When you create a macro, it appears under the Keyboard menu. 
Execute the keyboard macro by clicking on it in the Keyboard menu. 

 
Run a Macro Using a Keyboard Combination 

If you assigned a keyboard combination to a macro when building it, you 
can execute the macro by pressing its assigned keystrokes. For 
example, press the keys Ctrl+Alt+0 simultaneously to minimize all 
windows on a Windows target server. 
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Modifying and Removing Keyboard Macros 

 To modify a macro: 
1. Choose Keyboard > Keyboard Macros. The Keyboard Macros dialog 

appears. 

2. Choose the macro from among those listed. 

3. Click Modify. The Add/Edit Macro dialog appears. 

4. Make your changes. 

5. Click OK. 

 To remove a macro: 
1. Choose Keyboard > Keyboard Macros. The Keyboard Macros dialog 

appears. 

2. Choose the macro from among those listed. 

3. Click Remove. The macro is deleted. 
 

Ctrl+Alt+Del Macro 

Due to its frequent use, a Ctrl+Alt+Delete macro, used to reboot the 
target computer, has been preprogrammed. Clicking on the 

Ctrl+Alt+Delete button  in the toolbar sends this key sequence to 
the server or to the KVM switch to which you are currently connected.  

In contrast, if you were to physically press the Ctrl+Alt+Del keys, the 
command would first be intercepted by your own PC due to the structure 
of the Windows operating system, instead of sending the key sequence 
to the target server as intended. 
 

Common Hot Key Exceptions for MPC 

The following common hot key combinations are not sent to the target 
system: 
 

Hot Key 
Combination 

Description  

Ctrl+Alt+Delete Reboots the computer. The sequence is sent to the 
local system and the Windows Security (Task 
Manager, Shutdown, and so on) dialog is displayed. 

Ctrl+Left Alt+M Brings up the shortcut menu (on page 91).  

Print Scrn Treated locally and copies the page to the clipboard.

Following are limitations to specific keyboards and hot key combinations: 
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Hot Key 
Combination 

Description 

Alt Gr Because of a limitation in the Java Runtime 
Environment (JRE), Fedora, Linux, and Solaris 
clients receive an invalid response from Alt Gr on 
United Kingdom and US International language 
keyboards.  

Fedora, Linux, and Solaris do not pick up events 
for the Alt Gr key combination for Java 1.5. Java 
1.6 appears to improve on this, although the 
keyPressed and keyReleased events for Alt Gr still 
identify it as an “unknown key code”.   

Further, a key pressed in combination with Alt Gr 
(such as on the UK keyboard Alt Gr-4, which is the 
Euro symbol), will only generate a keyTyped 
followed by a keyReleased event for that value 
without a keyPressed event. Java 1.6 improves 
upon this by filling in the keyPressed event as well.

Alt+SysRq+[key] Since the SysRq keyboard stroke is used by some 
operating systems as a print shortcut, the Alt + 
SysRq + [key] combination is supported only as a 
macro when using  with RRC and MPC to a Linux 
target.   

 
 

Common Hot Key Combinations for RRC 

The following common hot key combinations are not sent to the target 
system: 

Hot Key 
Combination 

Description  

Ctrl+Alt+Delete Reboots the computer. The sequence is sent to the 
local system and the Windows Security (Task 
Manager, Shutdown, and so on) dialog is displayed. 

Ctrl+Num Lock This toggles the state of the Num Lock light if the 
Num Lock state on the local system is not the same 
as the target system.  

Ctrl+Caps Lock This toggles the state of the Caps Lock light if the 
Caps Lock state of the local system is not the same 
as the target system.  

Ctrl+Scroll Lock This toggles the state of the Scroll Lock light if the 
Scroll Lock state of the local system is not the same 
as the target system.  
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Hot Key 
Combination 

Description  

Ctrl+Left Alt+M Brings up the shortcut menu (on page 91).  

Print Scrn Treated locally and copies the page to the clipboard.

Following are limitations to specific keyboards and hot key combinations: 

Hot Key 
Combination 

Description 

Alt+SysRq+[key] Since the SysRq keyboard stroke is used by 
some operating systems as a print shortcut, the 
Alt + SysRq + [key] combination is supported 
only as a macro when using  with RRC and 
MPC to a Linux target.  

 
 

Windows Key in MPC 

When running MPC on a Windows JRE 1.5.0_x platform, if you press the 
Windows key   to display the Start menu, the Start menu will only 
appear on the client machine. The key is not sent to the target device.  

When running MPC on a Windows JRE 1.5.0_x platform, if you press the 
Windows key, the Start menu appears on both the client and the target 
devices. Use your mouse to manually close the Start menu if you do not 
want to use. 

Note that if you do not close the target device's Start menu properly, any 
key that you touch on your keyboard (that has a Windows key 
combination function) will send that command to the target device. For 
example, if you press E, the target device will open a new Explorer 
window. If you press D, all target windows will be minimized so you can 
view the desktop. To close the Start menu on the target device, click the 
Start button or click off of the Start menu. 
 

Keyboard Type 

Specifying a Keyboard Type in MPC 

MPC will not autodetect the type of keyboard you use, so you must 
specify your keyboard type to ensure accurate keyboard mapping.  

 To specify a keyboard type: 
1. Choose Tools > Options. The Options dialog will appear. 

2. Click the Keyboard Type drop-down and select your keyboard type 
from the list. 
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 US/International 

 French (France) 

 German (Germany) 

 Japanese 

 United Kingdom 

 Korean (Korea) 

 Belgian (Belgium) 

 Norwegian (Norway) 

 Danish (Denmark) 

 Swedish (Sweden) 

 German (Switzerland) 

 Hungarian (Hungary) 

 Spanish (Spain) 

 Italian (Italy) 

 Slovenian 
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3. Click OK. 

 
 

Keyboard Limitations 

Japanese Kanji Keyboards 

For Kanji keyboards, when using DCIM-USBs and MPC, the remote 
client cannot enter EISU mode by pressing the Caps Lock key (key#30). 
Local port access is not affected. You can access the DCIM-USBs using 
RRC or using the keyboard macro Shift + Caps Lock in MPC. 

Slovenian Keyboards 

The < key does not work on Slovenian keyboards due to a JRE 
limitation. 

Language Configuration on Linux 

Because the Sun JRE on Linux has problems generating the correct Key 
Events for foreign-language keyboards configured using System 
Preferences, Raritan recommends that you configure foreign keyboards 
using the methods described in the following table. 
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Language Configuration method 
US Intl Default 

French Keyboard Indicator 

German System Settings (Control Center) 

Japanese System Settings (Control Center) 

UK System Settings (Control Center) 

Korean System Settings (Control Center) 

Belgian Keyboard Indicator 

Norwegian Keyboard Indicator 

Danish Keyboard Indicator 

Swedish Keyboard Indicator 

Hungarian System Settings (Control Center)  

Spanish System Settings (Control Center)  

Italian System Settings (Control Center)  

Slovenian System Settings (Control Center)  

Note: The Keyboard Indicator should be used on Linux systems using 
Gnome as a desktop environment. 
 

Video Properties 

Refresh Screen 

The Refresh Screen command forces a refresh of the video screen. 
Video settings can be refreshed automatically in several ways: 

• The Refresh Screen command forces a refresh of the video screen. 
• The Auto-sense Video Settings command automatically detects the 

target server's video settings. 
• The Calibrate Color command calibrates the video to enhance the 

colors being displayed. 

In addition, you can manually adjust the settings using the Video Settings 
command. 

 To refresh the video settings, do one of the following: 
• Choose Video > Refresh Screen or click the Refresh Screen button 

 in the toolbar. 
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Auto-Sense Video Settings 

The Auto-sense Video Settings command forces a re-sensing of the 
video settings (resolution, refresh rate) and redraws the video screen. 

 To automatically detect the video settings, do the following: 
• Choose Video > Auto-sense Video Settings or click the Auto-Sense 

Video Settings button  in the toolbar. A message stating that the 
auto adjustment is in progress appears. 

 

Calibrate Color 

Use the Calibrate Color command to optimize the color levels (hue, 
brightness, saturation) of the transmitted video images. The  color 
settings are on a target server-basis. 

Note: The Calibrate Color command applies to the current connection 
only. 

 To calibrate the color, do the following: 
• Choose Video > Calibrate Color or click the Calibrate Color button 

 in the toolbar. The target device screen updates its color 
calibration. 

 

Video Settings 

Use the Video Settings command to manually adjust the video settings. 

 To change the video settings: 
1. Choose Video > Video Settings or click the Video Settings button 

 in the toolbar to open the Video Settings dialog.  

2. Adjust the following settings as required. As you adjust the settings 
the effects are immediately visible:  

a. Noise Filter 

The  device can filter out the electrical interference of video 
output from graphics cards. This feature optimizes picture quality 
and reduces bandwidth. Higher settings transmit variant pixels 
only if a large color variation exists in comparison to the 
neighboring pixels. However, setting the threshold too high can 
result in the unintentional filtering of desired screen changes. 
Lower settings transmit most pixel changes. Setting this 
threshold too low can result in higher bandwidth use. 
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b. Brightness: Use this setting to adjust the brightness of the target 
server display. 

c. Brightness Red - Controls the brightness of the target server 
display for the red signal. 

d. Brightness Green - Controls the brightness of the green signal. 

e. Brightness Blue - Controls the brightness of the blue signal. 

f. Contrast Red - Controls the red signal contrast. 

g. Contrast Green - Controls the green signal. 

h. Contrast Blue - Controls the blue signal. 

If the video image looks extremely blurry or unfocused, the 
settings for clock and phase can be adjusted until a better image 
appears on the active target server. 

Warning: Exercise caution when changing the Clock and Phase 
settings. Doing so may result in lost or distorted video and you may 
not be able to return to the previous state. Contact Raritan Technical 
Support before making any changes. 

i. Clock - Controls how quickly video pixels are displayed across 
the video screen. Changes made to clock settings cause the 
video image to stretch or shrink horizontally. Odd number 
settings are recommended. Under most circumstances this 
setting should not be changed because the autodetect is usually 
quite accurate. 

j. Phase - Phase values range from 0 to 31 and will wrap around. 
Stop at the phase value that produces the best video image for 
the active target server. 

k. Horizontal Offset - Controls the horizontal positioning of the 
target server display on your monitor. 

l. Vertical Offset - Controls the vertical positioning of the target 
server display on your monitor. 

3. Select Auto Color Calibration to enable this feature. 

4. Select the video sensing mode: 

 Best possible video mode 

The  device will perform the full Auto Sense process when 
switching targets or target resolutions. Selecting this option 
calibrates the video for the best image quality. 

 Quick sense video mode 

With this option, the  device will use a quick video Auto Sense in 
order to show the target's video sooner. This option is especially 
useful for entering a target server's BIOS configuration right after 
a reboot. 
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5. Click OK to apply the settings and close the dialog. Click Apply to 
apply the settings without closing the dialog. 

Note: Some Sun background screens, such as screens with very dark 
borders, may not center precisely on certain Sun servers. Use a different 
background or place a lighter colored icon in the upper left corner of the 
screen. 

 
 

Using Screenshot from Target 

You are able to take a screenshot of a target server using the 
Screenshot from Target server command. You save this screenshot to a 
file location of your choosing and can save it as either a bitmap, JPEG, 
or PNG file. 

 To take a screenshot of the target server:  
1. Select Video > Screenshot from Target or click the Screenshot from 

Target button  on the toolbar. 

2. In the Save dialog, choose the location to save the file, name the file, 
and select a file format from the 'Files of type' drop-down. 
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3. Click Save to save the screenshot. 
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Mouse Options 

Single Cursor Mode/Dual Cursor Mode 

When remotely viewing a target server that uses a mouse, you will see 
two mouse cursors on the remote desktop. When your mouse pointer 
lies within the remote desktop area, mouse movements and clicks are 
directly transmitted to the connected target server. The pointer, 
generated by the operating system, slightly leads the target server's 
mouse pointer during movement. This is a result of digital delay. 

On fast LAN connections, you may want to disable the mouse pointer 
and view only the target server's pointer. To toggle between these two 
modes, choose Single/Double Cursor on the shortcut menu. 

Alternatively, click the Single Mouse Pointer button  in the toolbar or 
choose Mouse > Single Cursor Mode. 

 

When in Dual Cursor mode, press Ctrl+Left Alt+M and execute the 
Synchronize Mouse shortcut to force realignment of the mouse cursors. 
If the mouse cursors still remain out of sync, click the Auto-Sense Video 

Settings button  on the toolbar. 

Note: When in Dual Cursor mode, if the dual mouse cursors are 
synchronized but left idle for five minutes or longer, the target mouse 
pointer will automatically align itself with the upper left corner of the 
target window. Execute the Synchronize Mouse command to ensure 
local and target mouse pointer alignment. 

Single Mouse Cursor mode for Apple Mac target servers is supported for 
MPC. Select Single Mouse Cursor on the Mouse menu in MPC to enter 
this mode.  While in this mode, the cursor will remain in the video 
window for the Mac Server.  To exit, open the shortcut menu and press 
S on the keyboard. 
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Mouse Synchronization Options 

In addition to synchronizing mouse cursors or toggling between single 
and dual cursor mode, the Mouse menu provides three options for 
synching cursors when in dual cursor mode: 
 

Menu option Description 
Absolute When connected to selected Dominion devices and 

targets with USB ports, the application will use 
absolute coordinates to keep the cursors in sync. 
See Absolute Mouse Mode for more information. 

Intelligent Under certain conditions, the application can detect 
the target mouse settings and synchronize the 
mouse cursors accordingly, accelerating the mouse 
on the target device. See Intelligent Mouse Mode 
(on page 20) for more details. 

Standard This is the standard mouse synchronization 
algorithm. See Standard Mouse Mode (on page 19) 
for more information. 

Note: The Intelligent and Standard Mouse modes are available to all  
targets. Absolute Mouse mode are only available to Mac and Windows 
USB targets. 
 

Automatic Mouse Synchronization 

For Generation 1, devices When in Dual Cursor mode, the system will 
automatically align the mouse cursors when the cursor is inactive for 15 
seconds. Enable this feature by clicking the Synchronize Mouse button 

 in the toolbar or selecting Tools > Options and selecting the 
"Auto-Sync mouse in two-cursor mode" checkbox. 

Automatic Mouse Synchronization is available for Generation 2 devices 
when: 

• A new connection is established 
• Auto-sense is enabled 
• Color calibration is enabled 

Enable this feature in Generation 2 devices by clicking the Synchronize 

Mouse button  in the toolbar or selecting Mouse > Synchronize 
Mouse. 
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Absolute Mouse Mode 

In this mode, absolute coordinates are used to keep the client and target 
cursors in sync, even when the target mouse is set to a different 
acceleration or speed. This mode is supported on servers with USB 
ports.  

 To enter absolute mouse mode: 
• Choose Mouse > Absolute. 

Note: The absolute mouse setting requires a USB target system and is 
the recommended mouse setting for KX II-101. 

Note: Absolute Mouse Synchronization is available for use with the 
virtual media-enabled USB CIM (D2CIM-VUSB and D2CIM-DVUSB) 
only. 
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Intelligent Mouse Mode 

In Intelligent Mouse mode, the  device can detect the target mouse 
settings and synchronize the mouse cursors accordingly, allowing mouse 
acceleration on the target. In this mode, the mouse cursor does a 
“dance” in the top left corner of the screen and calculates the 
acceleration. For this mode to work properly, certain conditions must be 
met. 

 To enter intelligent mouse mode: 
• Choose Mouse > Intelligent. 
Intelligent Mouse Synchronization Conditions 

The Intelligent Mouse Synchronization command, available on the 
Mouse menu, automatically synchronizes mouse cursors during 
moments of inactivity. For this to work properly, however, the following 
conditions must be met: 

• The active desktop should be disabled on the target. 
• No windows should appear in the top left corner of the target page. 
• There should not be an animated background in the top left corner of 

the target page. 
• The target mouse cursor shape should be normal and not animated. 
• The target mouse speeds should not be set to very slow or very high 

values. 
• Advanced mouse properties such as “Enhanced pointer precision" or 

“Snap mouse to default button in dialogs”  should be disabled. 
• Choose “Best Possible Video Mode” in the Video Settings window. 
• The edges of the target video should be clearly visible (that is, a 

black border should be visible between the target desktop and the 
remote KVM console window when you scroll to an edge of the 
target video image). 

• When using the intelligent mouse synchronization function, having a 
file icon or folder icon located in the upper left corner of your desktop 
may cause the function not to work properly. To be sure to avoid any 
problems with this function, Raritan recommends you do not have file 
icons or folder icons in the upper left corner of your desktop.  

After autosensing the target video, manually initiate mouse 
synchronization by clicking the Synchronize Mouse button on the toolbar. 
This also applies when the resolution of the target changes if the mouse 
cursors start to desync from each other. 

If intelligent mouse synchronization fails, this mode will revert to standard 
mouse synchronization behavior. 
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Please note that mouse configurations will vary on different target 
operating systems. Consult your OS guidelines for further details. Also 
note that intelligent mouse synchronization does not work with UNIX 
targets. 
 

Standard Mouse Mode 

Standard Mouse mode uses a standard mouse synchronization 
algorithm using relative mouse positions. Standard Mouse mode requires 
that mouse acceleration is disabled and other mouse parameters are set 
correctly in order for the client and server mouse to stay synchronized. 
Standard Mouse mode is the default. 

 To enter standard mouse mode: 
• Choose Mouse > Standard. 
 

Connection and Video Properties 

Dynamic video compression algorithms maintain KVM console usability 
under varying bandwidth constraints. The  device optimizes KVM output 
not only for LAN use but also for WAN and dial-up use. These devices 
can also control color depth and limit video output, offering an optimal 
balance between video quality and system responsiveness for any 
bandwidth constraint. 

The parameters discussed in this section can be optimized in the 
Connection Properties dialog and Video Settings dialog. The properties 
that you apply to a connection are retained between connections, they 
do not reset to their defaults. 
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MPC Connection Properties - Generation 1 Devices 

 To adjust connection properties: 
1. Choose Connection > Properties or click the Connection Properties 

button  in the toolbar. Update the settings in the Compression 
tab. 

 
2. Set the Connection Speed. 

Use this setting to manually adjust the connection speed to 
accommodate bandwidth constraints. Devices can automatically 
detect available bandwidth and not limit bandwidth use. However, 
you can also adjust this usage according to your needs. Depending 
on the Raritan device in use, different options may be available: 

 Auto Detect 

 1G Ethernet 

 100mb Ethernet 

 10mb Ethernet 

 1.5mb (Max DSL/T1) 

 1mb (Fast DSL/T1) 

 512 kb (Medium DSL/T1) 
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 384 kb (Slow DSL/T1) 

 256 kb (Cable) 

 128 kb (Dual ISDN) 

 56 kb (ISP Modem) 

 33 kb (Fast Modem) 

 24 kb (Slow Modem) 

3. Set the Color Depth. 

Devices can dynamically adapt the color depth transmitted to remote 
users in order to maximize usability in all bandwidths. Select from 
among the options in the drop-down list. Depending on the Raritan 
device in use, different options may be available: 

 15-bit RGB Color 

 8-bit RGB Color 

 4-bit Color 

 4-bit Gray 

 3-bit Gray 

 2-bit Gray 

 Black and White 

Important: For most administrative tasks (server monitoring, 
reconfiguring, and so forth), administrators do not require the full 
24-bit or 32-bit color spectrum made available by most video 
graphics cards. Attempting to transmit such high color depths wastes 
network bandwidth. 

4. Selecting the Internet Flow Control checkbox ensures that packets 
transmitted by the device are received and reconstructed by the 
client application in the correct order. This is useful when using a 
device over an unpredictable public WAN (particularly in international 
scenarios). 

5. Use the slider to select the desired level of video Smoothing (15-bit 
mode only). The level determines how aggressively to blend page 
regions with small color variation into a single, smooth color. 
Smoothing improves the appearance of the target video by reducing 
the video noise that is displayed. 

6. Select "Frames per second". This setting instructs MPC on how often 
to redraw the video display of the target. This only affects the client 
display behavior and has no bearing on the data rate of the video 
being sent to the client. Setting this option higher makes the video 
appear smoother but also requires more processing power. 

7. Click OK to create the connection profile. 
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MPC Connection Properties - Generation 2 Devices 

 To adjust connection properties: 
1. Choose Connection > Properties or click the Connection Properties 

button  in the toolbar. Update the settings in the Compression 
tab. 

2. Set the Connection Speed. 

Use this setting to manually adjust the connection speed to 
accommodate bandwidth constraints. Devices can automatically 
detect available bandwidth and not limit bandwidth use. However, 
you can also adjust this usage according to your needs. Depending 
on the Raritan device in use, different options may be available: 

 Auto Detect 

 1G Ethernet 

 100mb Ethernet 

 10mb Ethernet 

 1.5mb (Max DSL/T1) 

 1mb (Fast DSL/T1) 

 512 kb (Medium DSL/T1) 

 384 kb (Slow DSL/T1) 

 256 kb (Cable) 

 128 kb (Dual ISDN) 

 56 kb (ISP Modem) 

 33 kb (Fast Modem) 

 24 kb (Slow Modem) 

Note: KX II-101 does not support 1G Ethernet. 

3. Set the Color Depth. 

Devices can dynamically adapt the color depth transmitted to remote 
users in order to maximize usability in all bandwidths. Select from 
among the options in the drop-down list. Depending on the Raritan 
device in use, different options may be available: 

 15-bit RGB Color 

 8-bit RGB Color 

 4-bit Color 

 4-bit Gray 

 3-bit Gray 
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 2-bit Gray 

 Black and White 

Important: For most administrative tasks (server monitoring, 
reconfiguring, and so forth), administrators do not require the full 
24-bit or 32-bit color spectrum made available by most video 
graphics cards. Attempting to transmit such high color depths wastes 
network bandwidth. 

4. Use the slider to select the desired level of video Smoothing (15-bit 
mode only). The level determines how aggressively to blend page 
regions with small color variation into a single, smooth color. 
Smoothing improves the appearance of the target video by reducing 
the video noise that is displayed. 

5. Click OK to create the connection profile. 
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RRC Connection Properties 

 To adjust connection properties: 
1. Choose Connection > Properties or click the Connection Properties 

button  in the toolbar. Update the settings in the Compression 
tab. 

 
2. Set the Connection Speed. 

Use this setting to manually adjust the connection speed to 
accommodate bandwidth constraints. Devices can automatically 
detect available bandwidth and not limit bandwidth use. However, 
you can also adjust this usage according to your needs. Depending 
on the Raritan device in use, different options may be available: 

 Auto Detect 

 1G Ethernet 

 100mb Ethernet 

 10mb Ethernet 

 1.5mb (Max DSL/T1) 

 1mb (Fast DSL/T1) 

 512 kb (Medium DSL/T1) 

 384 kb (Slow DSL/T1) 
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 256 kb (Cable) 

 128 kb (Dual ISDN) 

 56 kb (ISP Modem) 

 33 kb (Fast Modem) 

 24 kb (Slow Modem) 

3. Set the Color Depth. 

Devices can dynamically adapt the color depth transmitted to remote 
users in order to maximize usability in all bandwidths. Select from 
among the options in the drop-down list. Depending on the Raritan 
device in use, different options may be available: 

 15-bit RGB Color 

 8-bit RGB Color 

 4-bit Color 

 4-bit Gray 

 3-bit Gray 

 2-bit Gray 

 Black and White 

Important: For most administrative tasks (server monitoring, 
reconfiguring, and so forth), administrators do not require the full 
24-bit or 32-bit color spectrum made available by most video 
graphics cards. Attempting to transmit such high color depths wastes 
network bandwidth. 

4. Select Progressive Update to increase the usability in constrained 
bandwidth environments. When Progressive Update is enabled, the 
device initially sends an image of the remote desktop at lower color 
depths. Higher color depth images are provided as the bandwidth 
allows. 

Note: When Color Depth is set to Auto Select Color (default), 
Progressive Update is automatic. The device will enable/disable 
Progressive Update as required, disabling it for fast connections and 
enabling it for slow connections. 

5. Selecting the Internet Flow Control checkbox ensures that packets 
transmitted by the device are received and reconstructed by the 
client application in the correct order. This is useful when using a 
device over an unpredictable public WAN (particularly in international 
scenarios). 
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6. Use the slider to select the desired level of video Smoothing (15-bit 
mode only). The level determines how aggressively to blend page 
regions with small color variation into a single, smooth color. 
Smoothing improves the appearance of the target video by reducing 
the video noise that is displayed. 

7. Click OK to create the connection profile. 
 

Video Settings 

Video Settings - Generation 1 Devices 

Following are instructions on configuring video settings for Generation 1 
devices. These settings can be refreshed using the Color Calibration 
command by manually forcing a device to autodetect the video settings 
(on the Video menu, click Auto-sense Video Settings) or by changing the 
settings in this page. After you change a value, click Apply to test the 
setting. See Color Calibration (on page 123). 

 To configure Generation 1 devices: 
1. Choose Video > Video Settings or click the Video Settings button 

 in the toolbar to open the Settings dialog.  

2. Adjust the following settings as required: 

a. Noise Filter 

Devices can filter out the electrical interference of video output 
from graphics cards. This feature optimizes picture quality and 
reduces bandwidth. Higher settings transmit variant pixels only if 
a large color variation exists in comparison to the neighboring 
pixels. However, setting the threshold too high can result in the 
unintentional filtering of desired page changes. Lower settings 
transmit most pixel changes. Setting this threshold too low can 
result in higher bandwidth use. 

Note: The default Noise Filter is 4. Raritan recommends that you 
lower this value to 0 (zero). Although higher settings will stop the 
needless transmission of false color variations, true and intentional 
small changes to a video image may not be transmitted. 

b. PLL Settings 

If the video image looks extremely blurry or unfocused, the PLL 
settings for clock and phase can be adjusted until a better image 
appears on the active target server. 

Warning: Exercise caution when changing the clock and phase 
settings since doing so may result in lost or distorted video and you 
may not be able to return to the previous state. Contact Raritan 
Technical Support before making any changes. 
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 Clock -  Controls how quickly video pixels are displayed across 
the video page. Changes made to clock settings cause the video 
image to stretch or shrink horizontally. Odd number settings are 
recommended. Under most circumstances this setting should not 
be changed because the autodetect is usually quite accurate. 

 Phase -  Phase values range from 0 to 31 and will wrap around. 
Stop at the phase value that produces the best video image for 
the active target server. 

a. Color Settings -  Gain control can be thought of as contrast 
adjustment. Offset control can be thought of as brightness 
adjustment. 

Select the Link Color Controls checkbox to make all slide 
adjusters move in unison when any one option is moved. 

 Red Gain -  Controls the amplification of the red signal. 

 Red Offset -  Controls the bias of the red signal. 

 Green Gain -  Controls the amplification of the green signal. 

 Green Offset -  Controls the bias of the green signal. 

 Blue Gain -  Controls the amplification of the blue signal. 

 Blue Offset -  Controls the bias of the blue signal. 

3. Select the video sensing mode: 

 Best possible video mode -  Devices will perform the full Auto 
Sense process when switching targets or target resolutions. 
Selecting this option calibrates the video for the best image 
quality. 

 Quick sense video mode -  Selecting this option will cause the 
device to use a quick video Auto Sense in order to show the 
target's video sooner. This option is especially useful for entering 
a target server's BIOS configuration right after a reboot. 

4. Click OK to apply the settings and close the dialog. Click Apply to 
apply the settings without closing the dialog. 
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Note: Some Sun background screens, such as screens with very dark 
borders, may not center precisely on certain Sun servers. Use a different 
background or place a lighter colored icon in the upper left corner of the 
page. 

 
 

Video Settings - Generation 2 Devices 

 To configure Generation 1 devices: 
1. Choose Video > Video Settings or click the Video Settings button 

 in the toolbar to open the Settings dialog.  

2. Adjust the following settings as required: 

a. Noise Filter 

Devices can filter out the electrical interference of video output 
from graphics cards. This feature optimizes picture quality and 
reduces bandwidth. Higher settings transmit variant pixels only if 
a large color variation exists in comparison to the neighboring 
pixels. However, setting the threshold too high can result in the 
unintentional filtering of desired page changes. Lower settings 
transmit most pixel changes. Setting this threshold too low can 
result in higher bandwidth use. 
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Note: The default Noise Filter is 4. Raritan recommends that you 
lower this value to 0 (zero). Although higher settings will stop the 
needless transmission of false color variations, true and intentional 
small changes to a video image may not be transmitted. 

b. PLL Settings 

If the video image looks extremely blurry or unfocused, the PLL 
settings for clock and phase can be adjusted until a better image 
appears on the active target server. 

Warning: Exercise caution when changing the clock and phase 
settings since doing so may result in lost or distorted video and you 
may not be able to return to the previous state. Contact Raritan 
Technical Support before making any changes. 

 Clock -  Controls how quickly video pixels are displayed across 
the video page. Changes made to clock settings cause the video 
image to stretch or shrink horizontally. Odd number settings are 
recommended. Under most circumstances this setting should not 
be changed because the autodetect is usually quite accurate. 

 Phase -  Phase values range from 0 to 31 and will wrap around. 
Stop at the phase value that produces the best video image for 
the active target server. 

a. Color Settings 

These settings control the brightness, contrast, and positioning of 
the target server display. Select the Link Color Controls checkbox 
to make all slide adjusters move in unison when any one option 
is moved. 

 Brightness Red -  Controls the brightness of the red signal; 
range is 0 - 127. 

 Brightness Green -  Controls the brightness of the green signal; 
range is 0 - 127. 

 Brightness Blue -  Controls the brightness of the blue signal; 
range is 0 - 127. 

 Contrast Red -  Controls the red signal contrast; range is 0 - 
255. 

 Contrast Green -  Controls the green signal contrast; range is 0 - 
255. 

 Contrast Blue -  Controls the blue signal contrast; range is 0 - 
255. 

 Horizontal Offset -  Controls the horizontal positioning of the 
target server display on your monitor; range is 0 - 512. 

 Vertical Offset -  Controls the vertical positioning of the target 
server display on your monitor; range is 0 - 128. 
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3. To preview the change prior to making the selection, check the 
Preview checkbox. 

4. Check the Automatic Color Calibration checkbox to enable this 
feature. 

5. Select the video sensing mode: 

 Best possible video mode -  Devices will perform the full Auto 
Sense process when switching targets or target resolutions. 
Selecting this option calibrates the video for the best image 
quality. 

 Quick sense video mode -  Selecting this option will cause the 
device to use a quick video Auto Sense in order to show the 
target's video sooner. This option is especially useful for entering 
a target server's BIOS configuration right after a reboot. 

6. Click OK to apply the settings and close the dialog. Click Apply to 
apply the settings without closing the dialog. 
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Port Access Page Sort 

 To change the display sort order: 
• Click the column heading by which you want to sort. The list of KVM 

target servers is sorted by that column. 
 

Color Calibration 

Use the Color Calibration command if the color levels (hue, brightness, 
and saturation) of the transmitted video images do not seem accurate. 
The device color settings remain the same when switching from one 
target KVM server to another, so you can perform color calibration once 
to affect all connected target servers. 

1. Open a remote KVM connection to any server running a graphical 
user interface. 

2. Ensure that a solid white color covers approximately 15% or more of 
the target server's desktop. 

TIP: Open Microsoft Notepad and maximize the window. 

 
3. On the Video menu, choose Calibrate Color or click the Color 

Calibration button  on the toolbar. The target device page will 
update its calibration. 

Tip: You can also specify automatic color calibration using Tools > 
Options. See General Options in MPC  (on page 125)for more 
information. 
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Help Options 

This menu command provides version information about the Virtual KVM 
Client, in case you require assistance from Raritan Technical Support. 

 To obtain version information: 
• Choose Help > About Raritan Multi-Platform Client. 

Use the Copy to Clipboard button to copy the information contained in 
the dialog to a clipboard file so it can be accessed later (if needed). 

 
 

Administrative Functions 

Although your device provides a remote interface to administrative 
functions through the device manager, the client provides an interface to 
frequently-used administrative functions directly from its own interface. 
When logged into a device as an administrator, you can perform the 
administrative tasks discussed here. 

Note: Most of the commands discussed here are available in both the 
Tools menu and in the shortcut menu that appears when you right-click 
the device in the Navigator panel. 
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Note to MPC Users 

MPC users must belong to the Administrator group in order to receive 
administrative permissions. MPC uses one permission: either 
Administrator or Normal User. It is only when the user belongs to the 
Administrator group that they have access to backup, restore, and restart 
functions. This is true regardless of any device user group settings that 
may be applied to the user. 
 

General Options 

General Options in MPC 

The Options available in the Tools menu provide options that allow you 
to customize scroll borders, mouse mode settings, Single Cursor mode, 
auto color calibration, hot key configuration, keyboard type, broadcast 
port, and logging.  

 To configure the general options in MPC: 
1. Choose Tools > Options. The Options dialog appears and displays 

the General tab by default. 

 
2. Select the "Show scroll borders" checkbox to view the thin scroll 

borders designating the autoscroll area. 

3. Select the "Auto-Sync mouse in two-cursor mode" checkbox to 
enable automatic mouse synchronization. 
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4. If you select the "Display single cursor mode instructions" checkbox, 
the Single Cursor Mode dialog will appear each time Single Cursor is 
enabled in the application. See Mouse Options (on page 107) for 
more information. 

5. Select the Automatic Color Calibration checkbox to enable automatic 
color calibration. This option is available for KX generation 1 (G1) 
only. 

6. Select the Keyboard Type from the drop-down list (depending on the 
Raritan device in use, different options may be available): 

 US/International 

 French (France) 

 German (Germany) 

 Japanese 

 United Kingdom 

 Korean (Korea) 

 Belgian (Belgium) 

 Norwegian (Norway) 

 Danish (Denmark) 

 Swedish (Sweden) 

 German (Switzerland) 

 Hungarian (Hungary) 

 Spanish (Spain) 

 Italian (Italy) 

 Slovenian 

7. From the Keyboard Shortcut Menu HotKey drop-down, select the key 
combination you would like to use to invoke the Shortcut Menu (on 
page 91).  
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8. For advanced options, open the Advanced tab. 

 
9. From the KVM Switch OSUI Hot Key section, select the hot key to 

use when switching between target server displays. 

10. For the Broadcast Port, type the broadcast port number in the Port 
field if you want to use a port other then 5000. 

11. Select the Enable IPv6 Networking checkbox for IPv6 to enable IPv4 
and IPv6 dual-stack operation. 

Note: KSX II and KX II-101 devices are not IPv6 enabled, so this 
section will not apply to those devices. 

12. Select the Enable Logging checkbox only if directed to by Technical 
Support. This option creates a log file in your home directory. 

13. Click OK when finished. Click Apply any time while making 
selections to apply it. 
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General Options in RRC 

The Options available in the Tools menu provide options that allow you 
to customize scroll borders, mouse mode settings, single cursor mode, 
auto color calibration, hot key configuration, keyboard type, broadcast 
port, and logging. 

 To configure the general options in RRC: 
1. In RRC, choose Tools > Options to open the Options dialog.  

 
2. Select the "Show scroll borders" checkbox to view the thin scroll 

borders that show the Auto-Scroll area. 

3. Select the "Auto-Sync mouse in two cursor mode" checkbox to 
enable Automatic Mouse Synchronization. 
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4. If you select the "Display single cursor mode instructions" checkbox 
the Single Cursor Mode dialog will open each time Single Cursor is 
enabled in the application (see Mouse Options (on page 107) for 
more information).  

5. Select Auto-Color Calibration to enable it. 

6. In the KVM Switch OSUI Hot Key panel, select the radio button next 
to the hot key combination you would like to use. 

7. In the Keyboard Type panel, click on the drop-down arrow and click 
on your keyboard choice. 

8. In the Broadcast Port panel, type the broadcast port number in the 
Port field. 

9. Click OK when finished. Click Apply any time during your selection to 
apply an option you have chosen. 

 
 

Upgrading Device Firmware 

 To update a device's firmware: 
1. Connect to the device by highlighting the device's icon in the 

Navigator. 

2. Click Tools > Update > Update Device to perform firmware 
upgrades. 

3. You will be prompted to locate a Raritan firmware distribution file 
(*.RFP format), which can be found on the Raritan website 
(www.raritan.com) on the Firmware Upgrades page.  

Ensure that you read all instructions included in Firmware Upgrade 
Guide carefully before upgrading a device. 

Note: Copy the firmware update file on the Raritan website to a local 
machine before uploading. Do not load the file from a network drive. 
 

Clearing ActiveX Controls 

After upgrading the  to a newer firmware version, if you still see the 
previous RRC version, please use the steps below to clear the ActiveX 
cache. 

 To remove TeleControl class files: 
1. In Internet Explorer 7, click Tools > Manage Addons > Enable or 

Disable Addons. 

2. Select "Download ActiveX control 32 bit" from the Show drop down. 
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3. Select TeleControl class and then click Delete. 

4. Close any open sessions of IE7.  

5. Open a new IE7 session and go to Raritan's website to download the 
newest version of RRC. 

 

Changing a Password 

 To update your password 
1. Connect to a target by selecting it in the Navigator.  

2. Highlight the target's icon in the Navigator and then choose Tools > 
Update > User Password. The Change Password dialog appears. 

 
3. Type your current password in the Old Password field. 

4. Type the new password in the New Password field.  

5. Retype the password in the Confirm New Password field. 

6. When finished, click OK. 
 

Restarting a Device 

 To restart a device: 
1. Select the device in the Navigator.  

2. On the Tools menu, choose Restart Device. 
 

Backup and Restore Functions 

In addition to using backup and restore for business continuity purposes, 
you can use this feature as a time-saving mechanism. For instance, you 
can quickly provide access from another Dominion device to your team 
by backing up the user configuration settings from the device in use and 
restoring those configurations to the new Dominion device. 
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Backup and Restore (Dominion KX II only) 

 To backup the entire system (both user and device 
configuration): 

1. Choose Tools > Backup All. The Backup All dialog appears. 

 
2. Navigate to the desired directory and give the backup file a name. 

(Backup files have an extension of .rfp). 

3. Click Save. A message is displayed confirming the successful 
backup. 

4. Click OK. 
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Note: Backups are always complete system backups. Restores can be 
complete or partial depending on your selection. 

 To restore: 
1. Choose Tools > Restore Configuration. The Restore Device 

Configuration dialog appears. 

 
2. Navigate to the appropriate directory and select the backup file. 

3. Click Open. The Restore Packages dialog appears. 

4. Select the type of restore you want to run: 

• Full Restore: A complete restore of the entire system; generally used 
for traditional backup and restore purposes. 

• Protected Restore: Everything is restored except device-specific 
information such as serial number, MAC Address, IP Address, name, 
port names, etc. With this option, you can setup one Dominion 
device and copy the configuration to multiple Dominion devices. 

• Custom Restore: The following options are available: 
 User and Group Restore: This option includes only user and 

group information. Use this option to quickly setup users on a 
different Dominion device. This option restores the certificate and 
the private key file that were currently active when the backup 
occurred. 
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 Device Settings Restore: This option includes only device 
settings such as power associations, USB profiles, blade chassis 
related configuration parameters, and Port Group assignments. 
Use this option to quickly copy the device information. 

1. Click OK. 
 

Backing Up and Restoring a Device Configuration 

 To back up a device: 
1. Download the device configuration to your local computer by 

selecting the device in the Navigator.  

2. Click Tools > Save Device Configuration. 

 To restore a device configuration: 
1. Upload the archived device configuration by selecting the device in 

the Navigator.  

2. Click Tools > Restore Device Configuration. 

Note that device configuration is specific to a particular device and 
should not be restored to another device. 

 

Backing Up and Restoring a User Configuration 

 To back up a device's user configuration: 
1. Select the device in the Navigator.  

2. Click Tools > Save User Configuration. 

 To restore a user configuration: 
1. Upload a device's archived user configuration by selecting the device 

in the Navigator.  

2. Click Tools > Restore User Configuration. 

Note: Use these commands to easily transfer user and group information 
from one device to another. 
 

Log Files 

Activity Log 

 To download a detailed activity log for review or 
troubleshooting: 

1. Select the device in the Navigator.  
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2. On the Tools menu, choose Save Activity Log. 
 

Diagnostic Log (excluding  II) 

 To download a detailed diagnostic log for reporting or analysis: 
1. Select the device in the Navigator.  

2. On the Tools menu, choose Save Diagnostic Log. 
 

Broadcast Port 

By default, all Raritan devices send data through Port 5000. This network 
traffic includes the autodiscovery broadcast. In the case of conflicts or to 
deal with firewall issues, you may want to use a different broadcast port.  
 

MPC Broadcast Port 

 To change the autodiscovery port from the default broadcast 
port of 5000:  

1. Select the device in the Navigator.  

2. Choose Tools > Options. The Options dialog appears. 

3. On the Advanced tab, type the new port number in the Port field of 
the Broadcast Port section and then click OK. 
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Note: If you want the application to autodiscover Raritan devices on the 
new broadcast port you entered in the Options dialog, you must 
configure all Raritan devices to use the new port number. 

 
 

RRC Broadcast Port 

 To change the autodiscovery port from the default broadcast 
port of 5000:  

1. Select the device in the Navigator.  

2. On the Tools menu, choose Options. The Options dialog appears. 

3. In the Broadcast Port field, type the new port number in the Port field 
and then click OK. 
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Note: If you want the application to autodiscover Raritan devices on the 
new broadcast port you entered in the Options window, you must 
configure all Raritan devices to use the new port number. 

 

If you do not want to use the broadcasting function at all, it can be turned 
off. 

 To turn off broadcasting: 
1. In RRC, select View > Show. 

2. Deselect the Discovered Devices checkbox. 
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Broadcasting will be turned off and the devices will not be displayed 
in the navigator. 

 
 

Remote Power Management 

AC power to associated targets can be managed when used with a 
properly configured Raritan Remote Power Control Strip (RPC strip). 
Three options are available when performing remote target power 
management:  

• Power On 
• Power Off 
• Cycle Power 

 To change the power status of a target: 
1. Select the device in the Navigator.  

2. On the Tools menu, choose Power On, Power Off, or Cycle Power. 
 

Import/Export Keyboard Macro Definitions 

The functions contained in this section describe how to exchange 
keyboard macro definitions between users using import and export 
functions. The primary purpose of this function is to exchange data 
between copies of the client application. 
 

Import/Export MPC Keyboard Macros 

 To import MPC macros: 
1. Choose Tools > Import Macros to open the Import Macros dialog. By 

default, the macro will exist on the desktop. 

2. Click on the macro file and click Open to import the macro.  

a. If too many macros are found in the file, an error message will be 
displayed and the import will terminate once OK is selected. 

b. If the import fails, an error dialog will appear and will display a 
message regarding why the import failed. Select OK to continue 
the import without importing the macros that cannot be imported. 
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3. Select the macros to be imported by checking their corresponding 
checkbox or using the Select All or Deselect All options. 

4. Click OK and the import will begin. 

a. If a duplicate macro is found, the Import Macros dialog will 
appear. Do one of the following: 

 Click Yes to replace the existing macro with the imported 
version. 

 Click Yes to All to replace the currently selected and any 
other duplicate macros that are found. 

 Click No to keep the original macro and proceed to the next 
macro 

 Click No to All keep the original macro and proceed to the 
next macro. Any other duplicates that are found will be 
skipped as well. 

 Click Cancel to stop the import.  

 Alternatively, click Rename to rename the macro and import 
it. If Rename is selected, the Rename Macro dialog will 
appear. Enter a new name for the macro in the field and click 
OK. The dialog will close and the process will proceed. If the 
name that is entered is a duplicate of a macro, an alert will 
appear and you will be required to enter another name for 
the macro. 

b. If during the import process the number of allowed, imported 
macros is exceeded, a dialog will appear. Click OK to attempt to 
continue importing macros or click Cancel to stop the import 
process. 
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The macros will then be imported. If a macro is imported that contains a 
hot key that already exists, the hot key for the imported macro will be 
discarded.  

 To export MPC macros: 
1. Choose Tools > Export Macros to open the Select Keyboard Macros 

to Export dialog. 

 
2. Select the macros to be exported by checking their corresponding 

checkbox or using the Select All or Deselect All options.  

3. Click OK. The selected macro file(s) will be moved to your desktop 
(by default). 

A dialog from which you can locate and select the macro file will then 
appear. By default, the macro will exist on your desktop.  
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4. Locate the macro file, click it to select it and then click Save. If the 
macro already exists, you will receive an alert message. Select Yes 
to overwrite the existing macro or No to close the alert without 
overwriting the macro. 

 
 

Import/Export RRC Keyboard Macros 

 To export RRC macros: 
1. Choose Tools > Export Macros to open the Export Macros dialog. 

 
2. Select the macros to be exported by checking their corresponding 

checkbox or using the Select All or Unselect All options.  

3. Click OK. The selected macro file(s) will be moved to your desktop 
(by default). 

A select dialog from which you can locate and select the macro file 
will then appear. By default, the macro will exist on your desktop.  
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4. Locate the macro file, click on it to select it and then click Save. If the 
macro already exists, you will receive an alert message. Select Yes 
to overwrite the existing macro or No to close the alert without 
overwriting the macro. 

 

 To import RRC macros: 
1. Choose Tools > Import Macros to open the Import Macros dialog. By 

default, the macro will exist on the desktop. 

 
2. Click on the macro file and click Open to import the macro.  
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a. If too many macros are found in the file, an error message will be 
displayed and the import will terminate once OK is selected. 

 
b. If the import fails, an error dialog will open and will display a 

message regarding why the import failed. Select OK to continue 
the import without importing the macros that cannot be imported. 

 
3. Select the macros to be imported by checking their corresponding 

checkbox or using the Select All or Unselect All options.  

4. Click OK and the import will begin. 

 
a. If a duplicate macro is found, a dialog will appear. Do one of the 

following: 
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 Click Yes to replace the existing macro with the imported 
version. 

 Click Yes to All to replace the currently selected and any 
other duplicate macros that are found. 

 Click No to keep the original macro and proceed to the next 
macro 

 Click No to All keep the original macro and proceed to the 
next macro. Any other duplicates that are found will be 
skipped as well. 

 Click Cancel to stop the import.  

 
 Alternatively, click Rename to rename the macro and import 

it. If Rename is selected, Raritan Remote Client Rename 
Macro dialog will open. Enter a new name for the macro in 
the field and click OK. The dialog will close and the process 
will proceed. If the name that is entered is a duplicate of a 
macro, an alert will appear and you will be required to enter 
another name for the macro. 
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b. If during the import process the number of allowed, imported 
macros is exceeded, a message will appear.  Click OK to 
attempt to continue importing macros or click Cancel to stop the 
import process. 

 
The macros will then be imported. If a macro is imported that 
contains a hot key that already exists, the hot key for the imported 
macro will be discarded.  
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Accessing the MPC Diagnostic Interface (excluding  II) 

 To access a device's diagnostic console: 
• In the Navigator, scroll through the list of the targets associated with 

the device and then double-click the Diagnostic icon at the bottom of 
the target list. 
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Overview 

Virtual media extends KVM capabilities by enabling KVM target servers 
to remotely access media from a client PC and network file servers. With 
this feature, media mounted on a client PC and network file servers is 
essentially "mounted virtually" by the target server. The target server can 
then read from and written to that media as if it were physically 
connected to the target server itself.  

Virtual media can include internal and USB-mounted CD and DVD 
drives, USB mass storage devices, PC hard drives, and ISO images 
(disk images). 

Note: ISO9660 is the standard supported by Raritan. However, other ISO 
standards can be used. 

Virtual media provides the ability to perform additional tasks remotely, 
such as: 

• Transferring files 
• Running diagnostics 
• Installing or patching applications 
• Complete installation of the operating system 

This expanded KVM control eliminates most trips to the data center, 
saving time and money, thereby making virtual media very powerful. 
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Diagram key 
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Prerequisites for Using Virtual Media 

With the  virtual media feature, you can mount up to two drives (of 
different types) that are supported by the USB profile currently applied to 
the target. These drives are accessible for the duration of the KVM 
session. 

For example, you can mount a specific CD-ROM, use it, and then 
disconnect it when you are done. The CD-ROM virtual media “channel” 
will remain open, however, so that you can virtually mount another 
CD-ROM. These virtual media “channels” remain open until the KVM 
session is closed as long as the USB profile supports it. 

The following conditions must be met in order to use virtual media:  

 
• For users requiring access to virtual media, the  device permissions 

must be set to allow access to the relevant ports, as well as virtual 
media access (VM Access port permission) for those ports. Port 
permissions are set at the group-level. 

• A USB connection must exist between the  device and the target 
server. 

• If you want to use PC-Share, Security Settings must also be enabled 
in the Security Settings page. Optional  

• You must choose the correct USB profile for the KVM target server 
you are connecting to.  

Client PC 
• Certain virtual media options require administrative privileges on the 

client PC (for example, drive redirection of complete drives). 

Note: If you are using Microsoft Vista, turn User Account Control off: 
Control Panel > User Accounts > User Account Control > turn off. 
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If you would prefer not to change Vista account permissions, run 
Internet Explorer as an administrator. To do this, click the Start 
Menu, locate IE, right-click it and select Run as Administrator. 

Target Server 
• KVM target servers must support USB connected drives. 
• KVM target servers running Windows 2000 must have all of the 

recent patches installed. 
• USB 2.0 ports are both faster and preferred. 

 To use virtual media: 
• Connect/attach the media to the client or network file server that you 

want to access from the target server. This need not be the first step, 
but it must be done prior to attempting to access this media. 

 

File Server Setup (File Server ISO Images Only) 

Note: This feature is only required when using virtual media to access file 
server ISO images. 

ISO9660 format is the standard supported by Raritan. However, other 
CD-ROM extensions may also work. 

Use the  Remote Console File Server Setup page to designate the files 
server(s) and image paths that you want to access using  virtual media. 
File server ISO image(s) specified here will become available for 
selection in the Remote Server ISO Image Hostname and Image 
drop-down lists in the Map Virtual Media CD/ISO Image dialog. See 
CD-ROM/DVD-ROM/ISO Images (on page 154). 

 To designate file server ISO images for virtual media access: 
1. Choose Virtual Media from the  Remote Console. The File Server 

Setup page opens. 

2. Check the Selected checkbox for all media that you want accessible 
as virtual media. 

3. Enter information about the file server ISO images that you want to 
access: 

 IP Address/Host Name - Host name or IP address of the file 
server. 

 Image Path - Full path name of the location of the ISO image. 

Note: The host name cannot exceed 232 characters in length. 
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4. Click Save. All media specified here will now be available for 
selection in the Map Virtual Media CD/ISO Image dialog. 

 
 

Using Virtual Media 

With the  virtual media feature, you can mount up to two drives (of 
different types) that are supported by the USB profile currently applied to 
the target. These drives are accessible for the duration of the KVM 
session. 

For example, you can mount a specific CD-ROM, use it, and then 
disconnect it when you are done. The CD-ROM virtual media “channel” 
will remain open, however, so that you can virtually mount another 
CD-ROM. These virtual media “channels” remain open until the KVM 
session is closed as long as the USB profile supports it. 

• The following conditions must be met in order to use virtual media:  
• You must choose the correct USB profile for the KVM target server 

you are connecting to.  

Client PC 
• Certain virtual media options require administrative privileges on the 

client PC (for example, drive redirection of complete drives). 

Note: If you are using Microsoft Vista, turn User Account Control off: 
Control Panel > User Accounts > User Account Control > turn off. 

If you would prefer not to change Vista account permissions, run 
Internet Explorer as an administrator. To do this, click the Start 
Menu, locate IE, right-click it and select Run as Administrator. 
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Target Server 
• KVM target servers must support USB connected drives. 
• KVM target servers running Windows 2000 must have all of the 

recent patches installed. 
• USB 2.0 ports are both faster and preferred.. 
1. If you plan to access file server ISO images, identify those file 

servers and images through the  Remote Console File Server Setup 
page. See File Server Setup (File Server ISO Images Only). 

Note: ISO9660 format is the standard supported by Raritan. 
However, other CD-ROM extensions may also work. 

2. Open a KVM session with the appropriate target server. 

a. Open the Port Access page from the  Remote Console. 

b. Connect to the target server from the Port Access page: 

 Click the Port Name for the appropriate server. 

 Choose the Connect command from the Port Action menu. The 
target server opens in a Virtual KVM Client window. 

3. Connect to the virtual media. 

For: Select this VM option: 
Local drives Local Drives (on page 153) 

Local CD/DVD drives CD-ROM/DVD-ROM/ISO Images 

ISO Images Connect CD-ROM/ISO Image 

File Server ISO Images Connect CD-ROM/ISO Image 

Upon completion of your tasks, disconnect the virtual media. See 
Disconnecting Virtual Media (on page 156). 
 



 Chapter 4: Virtual Media 
 

 
153

 

Connecting to Virtual Media 

Local Drives 

This option mounts an entire drive, which means the entire disk drive is 
mounted virtually onto the target server. Use this option for hard drives 
and external drives only. It does not include network drives, CD-ROM, or 
DVD-ROM drives. This is the only option for which Read/Write is 
available. 

Note: KVM target servers running certain versions of the Windows 
operating system may not accept new mass storage connections after an 
NTFS-formatted partition (for example, the local C drive) has been 
redirected to them.  

If this occurs, close the  Remote Console and reconnect before 
redirecting another virtual media device. If other users are connected to 
the same target server, they must also close their connections to the 
target server. 

 To access a drive on the client computer: 
1. From the Virtual KVM Client, choose Virtual Media > Connect Drive. 

The Map Virtual Media Drive dialog appears. 

 
2. Choose the drive from the Local Drive drop-down list. 

3. If you want Read and Write capabilities, select the Read-Write 
checkbox. This option is disabled for nonremovable drives. See the 
Conditions when Read/Write is Not Available (on page 154) for 
more information. When checked, you will be able to read or write to 
the connected USB disk. 

WARNING: Enabling Read/Write access can be dangerous! 
Simultaneous access to the same drive from more than one entity 
can result in data corruption. If you do not require Write access, 
leave this option unselected. 
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4. Click Connect. The media will be mounted on the target server 
virtually. You can access the media just like any other drive. 

 

Conditions when Read/Write is Not Available 

Virtual media Read/Write is not available in the following situations: 

• For all hard drives. 
• When the drive is write-protected. 
• When the user does not have Read/Write permission: 

 Port Permission Access is set to None or View. 

 Port Permission VM Access is set to Read-Only or Deny. 
 

CD-ROM/DVD-ROM/ISO Images 

This option mounts CD-ROM, DVD-ROM, and ISO images. 

Note: ISO9660 format is the standard supported by Raritan. However, 
other CD-ROM extensions may also work. 

 To access a CD-ROM, DVD-ROM, or ISO image: 
1. From the Virtual KVM Client, choose Virtual Media > Connect 

CD-ROM/ISO Image. The Map Virtual Media CD/ISO Image dialog 
appears. 

 
2. For internal and external CD-ROM or DVD-ROM drives: 

a. Choose the Local CD/DVD Drive option. 
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b. Choose the drive from the Local CD/DVD Drive drop-down list. 
All available internal and external CD and DVD drive names will 
be populated in the drop-down list. 

c. Click Connect. 

3. For ISO images: 

a. Choose the ISO Image option. Use this option when you want to 
access a disk image of a CD, DVD, or hard drive. ISO format is 
the only format supported. 

b. Click the Browse button. 

c. Navigate to the path containing the disk image you want to use 
and click Open. The path is populated in the Image Path field. 

d. Click Connect. 

4. For remote ISO images on a file server: 

a. Choose the Remote Server ISO Image option. 

b. Choose Hostname and Image from the drop-down lists. The file 
servers and image paths available are those that you configured 
using the File Server Setup page. Only items you configured 
using the  File Server Setup page will be in the drop-down list. 
See  for more information. 

c. File Server Username - User name required for access to the file 
server. 

d. File Server Password - Password required for access to the file 
server (field is masked as you type). 

e. Click Connect. 

The media will be mounted on the target server virtually. You can 
access the media just like any other drive. 

Note: If you are working with files on a Linux target, use the Linux Sync 
command after the files are copied using virtual media in order to view 
the copied files. Files may not appear until a sync is performed.  

Note: You cannot access a remote ISO image via virtual media using an 
IPv6 address due to technical limitations of third-party software used by 
the KX2. 
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Disconnecting Virtual Media 

 To disconnect the virtual media drives: 
• For local drives, choose Virtual Media > Disconnect Drive. 
• For CD-ROM, DVD-ROM, and ISO images, choose Virtual Media > 

Disconnect CD-ROM/ISO Image. 

Note: In addition to disconnecting the virtual media using the Disconnect 
command, simply closing the KVM connection closes the virtual media 
as well. 
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The standalone Raritan Serial Console (RSC) is used to make direct 
connections to a serial target without going through the device. The user 
specifies the device address and the port number (target), and is then 
connected. 

In This Chapter 
RSC System Requirements...................................................................157 
Installing RSC on Windows ...................................................................162 
Installing RSC for Sun Solaris and Linux ..............................................164 
Opening RSC from a  Remote Console...............................................165 
Raritan Serial Console Interface ...........................................................167 
 
 

RSC System Requirements 

The following requirements must be met to support the Raritan Serial 
Console: 

• The RSC will function with JRE version 1.4.2_05 or later (except for 
JRE version  1.5.0_02). However, for optimum performance, 
Raritan recommends using JRE 1.5.0 (except for version 1.5.0_02). 

• Your system may require configuration adjustments depending on 
the operating system and browser. The JRE provides configuration 
instructions with the JRE download. Browse to the page at 
http://www.java.com/en/download/help/testvm.xml 
(http://www.java.com/en/download/help/testvm.xml \o 
http://www.java.com/en/download/help/testvm.xml) to determine the 
JRE version currently installed on your system. If you do not have a 
compatible version of the JRE, go to http://www.java.com 
(http://www.java.com)  and click the Download Now button. 

Note: Raritan does not support JRE version 1.5.0_02 for use with the 
RSC. 

• Minimum 1 GHz PC with 512 MB RAM. 

Ensure that Java can be started from the command line. To do this, 
environment variables must be configured. Make a note of the exact path 
where Java was installed. (The path information will be used later.) 

IMPORTANT: When launching RSC from a browser, Raritan highly 
recommends that Java Applet Caching be disabled and that you 
perform the following steps to make sure that Java does not create 
problems for the system's memory. 
 

Chapter 5 Raritan Serial Console 
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Setting Windows OS Variables 
1. Choose Start > Control Panel > System. 

2. Click the Advanced tab and then click Environment Variables. 

 
3. In the System variables section, click New. 
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4. In the New System Variable dialog, add JAVA_HOME to the Variable 
name block and the path you wrote down earlier in the Variable 
value block. 

 
5. Click OK. 

6. Select the PATH variable and click Edit. 

7. Add %JAVA_HOME%\bin to the end of the current Variable value. 
Ensure a semicolon (;) separates the new value from the last value 
in the string. 
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8. Click OK. 

 
9. Select the CLASSPATH variable and click Edit. 

10. Ensure the CLASSPATH Variable value is configured properly; that 
is, its value must have a period (.) in it. If, for any reason, there is no 
CLASSPATH variable defined, create one. 
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Setting Linux OS Variables 

To set Java for a specific user, open and edit the .profile file located in 
the /home/Username folder. 

To set Java for all users, open the .profile file in your /etc folder: 

1. Find the line where you set your path: 

export  

PATH=$PATH:/home/username/somefolder 

2. Before that line you must set your JAVA_HOME and then modify 
your PATH to include it by adding the following lines: 

export  
JAVA_HOME=/home/username/j2sdk1.4.2/ 
export PATH=$PATH:$JAVA_HOME/bin 

3. Save the file. 
 

Setting UNIX OS Variables 

To check the latest JRE version on Sun Solaris: 

1. Launch a terminal window on the Sun Solaris desktop. 

2. Type java -version in the command line and press Enter. The 
currently-installed version of Java Runtime Environment (JRE) 
appears. 

 If your path variable is not set to where the Java binaries have 
been installed, you may not be able to see the JRE version. 

 Assuming JRE 1.4.2_05 is installed in /usr/local/java: you must 
set your PATH variable. 

 To set a path for the bash shell: 

export  

PATH=$PATH:/usr/local/java/j2re1.4.2_05/bin 

 To set path for tcsh or csh: 

set  

PATH = ($PATH /usr/local/java/j2re1.4.2_05/bin) 
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 These commands can either be typed at the terminal each time 
you log in, or you can add them to your .bashrc for bash shell or 
.cshrc for csh and tcsh so that each time you log in, the path is 
already set. See your shell documentation if you encounter 
problems. 

 
3. If the JRE is version 1.4.2_05 or later, proceed with the RSC 

installation. If the JRE is version 1.5.0_02  or is an older version 
than 1.4.2_05, go to the Sun website at 
(http://java.sun.com/products/) to download the latest Runtime 
Environment. 

 

Installing RSC on Windows 

You must have administrative privileges to install RSC. 

 To install RSC on Windows: 
1. Log on to a Windows machine. 

2. Download, or copy from a known location, the RSC-installer.jar 
installation file. 

3. Double-click the executable file to start the installer program. The 
splash page appears. 

4. Click Next. The installation path page appears. 

5. Change the path, if desired. 

6. Click Next. The installation progress page appears. 
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Note: The standalone version of Raritan Serial Console (RSC) is 
available from the Raritan website (www.raritan.com) on the Support 
page. 
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7. Click Next. The Windows shortcut page appears. 

 
8. Specify the desired Program Group for the shortcut. 

9. Click Next. The installation finished page appears. 

10. Click Done. 
 

Installing RSC for Sun Solaris and Linux 

You must have administrative privileges to install RSC. 

1. Log in to your Sun Solaris machine. 

2. Download, or copy from a known location, the RSC-installer.jar 
installation file. 

3. Open a terminal window and change to the directory where the 
installer is saved. 

4. Type java -jar RSC-installer.jar and press Enter to run the installer. 

5. Click Next after the initial page loads. The Set Installation Path page 
opens. 

a. Select the directory where you want to install RSC and click 
Next. 

b. Click Browse to navigate to a non-default directory. 
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c. Click Next when the installation is complete. 

d. Click Next again. The installation is complete. The final page 
indicates where you will find an uninstaller program and provides 
the option to generate an automatic installation script. 

6. Click Done to close the Installation dialog. 
 

Opening RSC from a  Remote Console 

 To open the Raritan Serial Console (RSC) from the Remote 
Console: 

1. Select the Port Access tab. 

 
2. Click the name of the serial port you want to access for the RSC. 

Note: A security pop-up screen appears only if you used https to 
connect to the RSC. 

3. If you're using Dominion DSX: 

 Click Yes. A Warning - Security pop-up screen appears. 

 Click Yes to access the Raritan Serial Console from the Port 
page. 

Note: If you click Always, you will not receive the security page for 
future access. 

 The Raritan Serial Console window appears.  
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If you're using Dominion KSX or KX:  

 Click Connect to start connecting to the target port for RSC, and 
the Raritan Serial Console window appears. 

 The Raritan Serial Console window appears. 

Note: You can download the standalone Raritan Serial Console from the 
Raritan website (www.raritan.com) on the Support page.  

 To open RSC from the Windows desktop: 
1. Double-click the shortcut or use the Start menu to open the 

standalone RSC. The Raritan Serial Console Login connection 
properties window appears. 

2. Enter the device's IP address, account information, and the desired 
target (port). 

3. Click Start. RSC opens with a connection to the port. 

Note: If you experience unrecognized characters or blurry pages in the 
RSC window due to localization support, try changing the font to Courier 
New. Click Emulator > Settings > Display and select Courier New for 
Terminal Font Properties or GUI Font Properties. 

Note: When RSC connects to a serial target, hitting Ctrl + _ or Ctrl + ^ + 
_ does not cause information to be sent. However, hitting the Ctrl + Shift 
+ _ or the Ctrl + Shift + ^ will cause information to be sent.  

 To open RSC on Sun Solaris: 
1. Open a terminal window and change to the directory where you 

installed the RSC. 

2. Type ./start.sh and press Enter to open RSC. 

3. Double-click the desired device to establish a connection. 

4. Type your user name and password. 

5. Click OK to log on. 
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Raritan Serial Console Interface 

Important: The Raritan Serial Console page usually opens in a 
separate window behind the Port page. With some versions of Java 
on Windows, the page opens in front of the Port page. 

 
 

Default RSC Option Values 

The following default values apply to the GUI font properties, colors and 
fonts defined in RSC: 
 

Item Value 
Font properties Lucida Console 

GUI font properties Lucida Console 

Colors Black foreground and white 
background 
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Emulator 
1. Change the default user Idle Timeout setting before launching the 

RSC for the first time or it will timeout in 10 minutes and display a 
host termination message.  

2. Click the Emulator drop-down menu to display a list of topics. 
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Settings 
1. Choose Emulator > Settings. The Settings page displays the General 

tab with the default settings. 

 
2. Accept the Main Menu Shortcut default of None or choose one of the 

following from the Main Menu Shortcut drop-down menu: 

 F10 

 Alt 

3. Accept the Show Confirmation Dialog on Exit default or uncheck it. 

4. Accept the Terminal Size default or choose a size from the Terminal 
Size drop-down menu. 

5. Accept the Backspace Sends default of ASCII DEL or choose 
Control-H from the Backspace Sends drop-down menu. 

6. Accept the History Buffer Size default of 75 or use the arrows to 
change the buffer size. 
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7. Accept the Cursor type default of Block Cursor or select Line Cursor. 

8. Click OK. 

Display Settings 
1. Choose Emulator > Settings, and then click the Display tab. 

 
2. Click Default to accept the Default settings. Then click Ok to close 

the Display Settings dialog. However, if you want to change the 
settings, perform the following steps: 

3. Accept the Terminal Font Properties default of Lucida Console or 
choose a font from the scrolling list of Terminal Font Properties. 

4. If you want to change the size of the font, choose a font size by 
clicking the up or down arrows. The result of selected font and font 
size is displayed in the Preview box. 
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5. Click the GUI Font Properties tab and accept the default of Lucida 
Console or choose a font from the scrolling list of GUI Font 
Properties. 

 

Note: For Simplified Chinese characters, Raritan Serial Console 
supports EUC-CN encoding system.  

6. Choose the following from their drop-down menus: 

 Foreground Color 

 Background Color 

7. Choose one of the following from the Encoding drop-down menu: 

 US-ASCII 

 ISO-8859-1 

 ISO-8859-15 
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 UTF-8 

 Shift-JIS 

 EUC-JP 

 EUC-CN 

 EUC-KR 

8. Choose one of the following from the Language drop-down menu: 

 English 

 Bulgarian 

 Japanese 

 Korean 

 Chinese 

9. Click Ok to close the Display Settings dialog. If you changed the 
Language setting, the RSC changes to that language when the 
Display Settings dialog is closed. 
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Note: If you experience unrecognized characters or blurry pages in the 
RSC window due to localization support, try changing the font to Courier 
New.  

Get History 

History information can be useful when debugging, troubleshooting, or 
administering a target device. The Get History feature allows you to view 
the recent history of console sessions by displaying the console 
messages to and from the target device. 

When the size limit is reached, the text will wrap, overwriting the oldest 
data with the newest. 

Note: The history data is displayed only to the user who requested the 
history. 

• To view the session history, choose Emulator > Get History. 

Clear History 
• To clear the history, choose Emulator > Clear History. 

Get Write Access 

Only administrators and operators can get Write access. The user with 
Write access can send commands to the target device. Write access can 
be transferred among users working in the Raritan Serial Console via the 
Get Write Access command. 

To enable Write access, choose Emulator > Write Access. 

• You now have Write access to the target device. 
• When another user assumes Write access from you, 

 The RSC displays a red block before Write access in the status 
bar. 

 A message alerting the user who currently has Write access 
appears to tell that user that another user has taken over access 
to the console. 
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Get Write Lock 
• Choose Emulator > Get Write Lock. If the Get Write Lock is not 

available, a request rejected message appears. 

Write Unlock 
• Choose Emulator > Write Unlock. 

Send Break 

Some target systems, such as Sun Solaris servers, require the 
transmission of a null character (break) to generate the OK prompt. This 
is equivalent to issuing a STOP-A from the Sun keyboard. 

• Only users with Administrator privileges can send a break. 
• Users who are Operator or Observers cannot send a break. 

 To send an intentional break to a Sun Solaris server: 
1. Verify that you have Write access. If not, follow the instructions in the 

previous section to obtain Write access. 

2. Choose Emulator > Send Break. A Send Break Ack 
(Acknowledgement) pop-up appears. 

3. Click OK. 
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Connected Users 

The Connected Users command allows you to view a list of other users 
who are currently connected on the same port. 

1. Choose Emulator > Connected Users, a Connected Users page is 
displayed. 

 
2. A check mark appears in the Write access column after the name of 

the user who has Write access to the console. 

3. Click Close to close the Connected Users window. 

Exit 
1. Choose Emulator > Exit to close the Raritan Serial Console. The Exit 

Confirmation page appears. 

2. Click Yes. 
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Edit 

Use the Copy, Paste, and Select All text commands to relocate and/or 
re-use important text. 

 

 To copy and paste all text: 
1. Choose Edit > Select All. 

2. Choose Edit > Copy. 

3. Position the cursor at the location where you want to paste the text. 

4. Click once to make that location active. 

5. Choose Edit > Paste. 
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Note: The copy-paste limit of text in Raritan Serial Console is 9999 lines. 

Keyboard shortcuts that you can use to highlight, copy, and paste all or 
partial lines of text: 

• Click and drag your mouse over the text you wish to copy. 
• Use Ctrl+C to copy text. 
• Position the cursor where you want to paste the text and click in that 

location to make it active. 
• Use Ctrl+V to paste text. 
 

Tools 

Click the Tools menu to display a list of topics. 
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Start Logging 

The Start Logging function allows you to collect raw console data from 
the target device and save it to a file on your computer. When you start 
RSC, the Logging indicator on the status bar indicates whether logging is 
on or off. 

1. Choose Tools > Start Logging. 

2. Choose an existing file or provide a new file name in the Save RSC 
Log dialog. 

 When an existing file is selected for logging, data gets appended 
to the contents. 

 If you provide a new file name, a new file is created. 

 
3. Click Save after selecting or creating a file. 
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Stop Logging 

Choose Tools > Stop Logging. The logging stops. 

Send Keystroke 

1. Choose Tools > Send Keystroke. A Send Keystroke dialog appears: 

 
2. Enter the keystroke combinations that you want and select a Key 

Code name from the drop-down menu. 

3. Send the keystroke combinations. 

Send Text File 

1. Choose Tools > Send Text File. A Send Text File screen appears. 

2. Open the directory of the Text file. 

3. Click on or enter the File Name of the Text file. 

4. Click Open. 

 When you click Open, it sends whatever file you selected directly 
to the port. 

 If there is a loopback plug inserted, you will see the file displayed. 

 If there is currently no target connected, then nothing will be 
visible on the screen. 
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Toggle Power 

The Toggle Power function lets you power on or off the device that is 
connected to the associated outlet on a Power Distribution Unit (PDU). 
For example, if a router is connected to one of the outlets on the PDU, 
you can toggle the router’s power on or off.  

You must configure the association of outlets to the target port of the 
device before you can use the Toggle Power feature. Go to the Power 
Control tab on remote console's GUI to configure the outlets. If you have 
not done this, the system displays a message stating that the target is 
not associated with a power outlet. 

Note: If RSC is launched through CC-SG (version 4.x onwards) by users 
without the permission to toggle power, the option Toggle Power will 
appear as disabled. 

 

1. Select Toggle Power to turn the device (router) on or off. A prompt 
appears displaying the current status of the outlet(s). You can turn 
the device on or off depending on its current status. 

2. If you select No, the system returns you to the RSC screen. 

3. If you select Yes, the system sends the power command to either 
turn on or off the outlets associated to the target port of the device. 

If you receive a: 

• Hardware error message: this means that the PDU command failed. 

Software error message: this means that another user is controlling the 
power outlet and the power control command cannot be sent. 
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Chat 

When using browser access over SSL, an interactive chat feature called 
Chat allows you and other users on the same port to communicate. You 
can conduct an online dialog for training or collaborative diagnostic 
activities. The maximum length of a chat message is 300 characters. 

Note: When a chat is initiated, a chat window appears on the monitors of 
all SSL users logged on to the port. If a user is logged into a port multiple 
times, multiple chat messages will not appear to that user. 

 To open chat: 
• Choose Chat > Chat. 

 

 To clear text in a chat text box: 
• Click Clear to delete the typed text. 
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Help 

Help Topics include online assistance for operating the Raritan Serial 
Console and release information about Raritan Serial Console. 

Help Topics 

 To access help topics: 
• Choose Help > Help Topics. 

About Raritan Serial Console 

The About Raritan Serial Console dialog displays the copyright and 
version information (name and revision number) of the console terminal 
emulation software. When contacting Raritan for technical support or 
when performing a software upgrade, you may be asked for this 
information. 

 To access 'About' information: 
• Choose Help > About Raritan Serial Console.  An About Raritan 

Serial Console message appears.  
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