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VKC Toolbar for the KX II-101 

Following is a list and description of the standard toolbar buttons in VKC 
for KX II-101.  

Button Button name Description 

 
Connection 
Properties 

Opens the Modify Connection Properties 
dialog from which you can manually adjust 
bandwidth options (such as connection 
speed, color depth, and so forth).  

 
Video 
Settings 

Opens the Video Settings dialog, allowing 
you to manually adjust video conversion 
parameters.  

 
Synchronize 
Mouse 

In dual-mouse mode, forces realignment of 
the target server mouse pointer with the 
mouse pointer.  

 
Refresh 
Screen Forces a refresh of the video screen.  

 
Auto-sense 
Video 
Settings 

Forces a refresh of the video settings 
(resolution, refresh rate).  

 
Send 
Ctrl+Alt+Del 

Sends a Ctrl+Alt+Del hot key combination to 
the target server.  

 
Single Cursor 
Mode 

Starts Single Cursor mode in which the local 
mouse pointer no longer appears onscreen. 
Alternatively, press Ctrl+Alt+O to exit single 
cursor mode. 

 
Full Screen 
Mode 

Maximizes the screen real estate to view the 
target server desktop. 

 Scaling 
Increases or reduces the target video size so 
you can view the entire contents of the target 
server window without using the scroll bar. 
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Additional Notes for Intelligent Mouse Mode 

• Be sure that there are no icons or applications in the upper left 
section of the screen since that is where the synchronization routine 
takes place. 

• Do not use an animated mouse. 
• Disable active desktop on KVM target servers. 

Synchronize Mouse 

In dual mouse mode, the Synchronize Mouse command forces 
realignment of the target server mouse pointer with Virtual KVM Client 
mouse pointer. 

 To synchronize the mouse, do one of the following: 
• Choose Mouse > Synchronize Mouse or click the Synchronize 

Mouse button  in the toolbar. 
 

Standard Mouse Mode 

Standard Mouse mode uses a standard mouse synchronization 
algorithm using relative mouse positions. Standard Mouse mode requires 
that mouse acceleration is disabled and other mouse parameters are set 
correctly in order for the client and server mouse to stay synchronized. 
Standard Mouse mode is the default. 

 To enter Standard Mouse mode: 
• Choose Mouse > Standard. 
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Intelligent Mouse Mode 

In Intelligent Mouse mode, the device can detect the target mouse 
settings and synchronize the mouse cursors accordingly, allowing mouse 
acceleration on the target. In this mode, the mouse cursor does a 
“dance” in the top left corner of the screen and calculates the 
acceleration. For this mode to work properly, certain conditions must be 
met. 

 To enter intelligent mouse mode: 
• Choose Mouse > Intelligent. 
Intelligent Mouse Synchronization Conditions 

The Intelligent Mouse Synchronization command, available on the 
Mouse menu, automatically synchronizes mouse cursors during 
moments of inactivity. For this to work properly, however, the following 
conditions must be met: 

• The active desktop should be disabled on the target. 
• No windows should appear in the top left corner of the target page. 
• There should not be an animated background in the top left corner of 

the target page. 
• The target mouse cursor shape should be normal and not animated. 
• The target mouse speeds should not be set to very slow or very high 

values. 
• Advanced mouse properties such as “Enhanced pointer precision" or 

“Snap mouse to default button in dialogs” should be disabled. 
• Choose “Best Possible Video Mode” in the Video Settings window. 
• The edges of the target video should be clearly visible (that is, a 

black border should be visible between the target desktop and the 
remote KVM console window when you scroll to an edge of the 
target video image). 

• When using the intelligent mouse synchronization function, having a 
file icon or folder icon located in the upper left corner of your desktop 
may cause the function not to work properly. To be sure to avoid any 
problems with this function, Raritan recommends you do not have file 
icons or folder icons in the upper left corner of your desktop.  

After autosensing the target video, manually initiate mouse 
synchronization by clicking the Synchronize Mouse button on the toolbar. 
This also applies when the resolution of the target changes if the mouse 
cursors start to desync from each other. 

If intelligent mouse synchronization fails, this mode will revert to standard 
mouse synchronization behavior. 
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Please note that mouse configurations will vary on different target 
operating systems. Consult your OS guidelines for further details. Also 
note that intelligent mouse synchronization does not work with UNIX 
targets. 
 

Absolute Mouse Mode 

In this mode, absolute coordinates are used to keep the client and target 
cursors in sync, even when the target mouse is set to a different 
acceleration or speed. This mode is supported on servers with USB 
ports.  

 To enter absolute mouse mode: 
• Choose Mouse > Absolute. 

Note: The absolute mouse setting requires a USB target system and is 
the recommended mouse setting for KX II-101. 

Note: Absolute Mouse Synchronization is available for use with the 
virtual media-enabled USB CIM (D2CIM-VUSB and D2CIM-DVUSB) 
only. 
 

Single Mouse Cursor 

Single Mouse mode uses only the target server mouse cursor and the 
local mouse pointer no longer appears onscreen. While in single mouse 
mode, the Synchronize Mouse command is not available (there is no 
need to synchronize a single mouse cursor). 

Note: VKC for the KX II-101 uses an icon set that differs from the icon 
set used in VKC for other Dominion KX products. See VKC Toolbar for 
the KX II-101 (on page 6) for additional information. 

 To enter single mouse mode, do the following: 
1. Choose Mouse > Single Mouse Cursor. 
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AKC Supported Operating Systems and Browsers 

.NET Framework 

AKC requires Windows .NET® version 3.5, and will work with both 3.5 
and 4.0 installed. 

Operating Systems 

When launched from Internet Explorer®, AKC allows you to reach target 
servers via the KX II 2.2 (or later). AKC is compatible with the following 
platforms running .NET Framework 3.5: 

 Windows XP® operating system 
 Windows Vista® operating system (up to 64 bit) 
 Windows 7® operating system  (up to 64 bit) 

Note: You must be using Windows 7 if WINDOWS PC FIPs is turned 
on and you are accessing a target using AKC and a smartcard. 

Since .NET is required to run AKC, if you do not have .NET installed or 
you have an unsupported version of .NET installed, you will receive a 
message instructing you to check the .NET version. 

Browser 
 Internet Explorer 6 or later 

If you attempt to open AKC from a browser other than IE 6 or later, you 
will receive an error message instructing you to check your browser and 
to switch to Internet Explorer. 
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Raritan Multi-Platform Client (MPC) and Raritan Remote Console are 
graphical user interfaces for the Raritan product lines, providing remote 
access to target servers connected to Raritan KVM over IP devices. 
Non-Windows® users must use Raritan Multi-Platform Client and 
Windows users running Internet Explorer® must use Raritan Remote 
Client. 

In This Chapter 
Requirements and Installation.................................................................35 
Operation.................................................................................................52 
Administrative Functions .......................................................................120 
 
 

Requirements and Installation 

MPC Requirements and Installation Instructions 

Note to CC-SG Users 

If you are using Dominion KX II in a CC-SG configuration, do not use the 
CC-SG proxy mode if you are also planning to use the Multi-Platform 
Client (MPC).  
 

MPC Minimum System Requirements 

The minimum system requirements for the Multi-Platform Client are: 

• CPU Speed: 1.0 GHz 
• RAM: 512 Mbytes 

Note: Running the client software on system configurations below either 
of these specifications may impact performance and result in errors. 
 

Chapter 4 Multi-Platform Client and Raritan 
Remote Client 



Chapter 4: Multi-Platform Client and Raritan Remote Client 
 

36
 

 

MPC Supported Operating Systems and Browsers 

Operating Systems 

When launched as a web applet or as a standalone application, MPC 
allows you to reach target servers via different Raritan Dominion devices 
and IP Reach models. 

Raritan MPC is compatible with the following platforms: 

• Windows XP® operating system 
• Windows 2000® operating system SP4 
• Windows Vista® operation system 
• Red Hat Linux® 9.0 
• Red Hat Enterprise Workstation 3.0 and 4.0 
• SUSE Linux Professional 9.2 and 10 
• Fedora Core 5 and above 
• Mac® 

Important: Only Mac 10.5 and 10.6 with an Intel® processor can run 
JRE 1.6 and, therefore, be used as a client. Mac 10.4.11 and 10.5.8 
do not support MPC as a standalone client. 

• Solaris™ 

The JRE™ plug-in is available for the Windows® 32-bit and 64-bit 
operating systems. MPC and VKC can be launched only from a 32-bit 
browser, or 64-bit IE7 or IE8 browser.  

Following are the Java™ 32-bit and 64-bit Windows operating system 
requirements.  

Mode Operating system Browser 
Windows x64 
32-bit mode 

Windows XP® • Internet Explorer® 6.0 
SP1+ or 7.0, IE 8 

• Mozilla® 1.4.X or 1.7+ 
• Netscape® 7.X 
• Firefox® 1.06 - 3 
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Mode Operating system Browser 
Windows Server 2003® • Internet Explorer 6.0 

SP1++, IE 7, IE 8 
• Mozilla 1.4.X or 1.7+ 
• Netscape 7.X 
• Firefox 1.06 - 3 

Windows Vista® • Internet Explorer 7.0 or 
8.0 

Windows 7® • Internet Explorer 7.0 or 
8.0 

• Firefox 1.06 - 3 

Windows XP 

Windows XP 
Professional® 

Windows XP Tablet® 

Windows Vista 

Windows Server 2003 

Windows Server 2008 

 Windows x64 
64-bit mode 

Windows 7 

64bit OS, 32bit browsers: 

• Internet Explorer 6.0 
SP1+, 7.0 or 8.0 

• Mozilla 1.4.X or 1.7+ 
• Netscape 7.X 
• Firefox 1.06 - 3 

64bit mode, 64bit browsers: 

• Internet Explorer 7.0 or 
8.0 
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Browsers 

MPC supports the following browsers: 

• Internet Explorer 6, 7 and 8 
• Firefox® 1.5, 2.0 and 3.0 (up to build 3.0.10) 
• Mozilla® 1.7 
• Safari 2.0 

Note: If you are using IE 7, you may run into permission issues when 
trying to connect to a target server. To avoid this, do the following: 

1. In IE7, click Tools > Internet Options to open the Internet Options 
dialog. 

2. In the "Temporary Internet files" section, click the Settings button. The 
Settings dialog opens. 

3. In the "Check for newer versions of stored pages" section, select 
Automatically. 

4. Click OK to apply the settings. 

 

Note: If you are using IE 8 to access MPC and do not have Java installed 
on your machine, an alert bar or a dialog will open asking you to 
download the latest version of Java. However, in some instances, only a 
blank window will open and you will not be prompted to perform the 
download. If this occurs, set IE 8 to use Compatibility View. See 
Microsoft® Internet Explorer® help for information on change IE to this 
view. 
 

Note to IPv6 Users 

Due to a browser limitation, MPC cannot be downloaded via the KX IPv6 
address from Mozilla 1.7 if Pop-up Manager is enabled. Do one of the 
following to avoid this issue: 

• Use the hostname of the device for the MPC browser download. 
• Set Mozilla to not block Pop-up windows via edit\Preferences\Privacy 

and Security. 
• Use IPV4 address. 
• Use standalone MPC. 
• Use the latest version of Firefox®. 
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Special Characters in MPC 

The following table identifies the special characters that can be used in 
MPC: 

Character Description Character Description 
! Exclamation point : Colon 

" Double quote ; Semi-colon 

# Pound sign = Equal sign 

$ Dollar sign > Greater than sign 

% Percent sign ? Question mark 

& Ampersand @ At sign 

' Single quote [ Left bracket 

( Left parenthesis \ Backward slash 

) Right parenthesis ] Right bracket 

* Asterisk ^ Caret 

+ Plus sign _ Underscore 

, Comma ` Grave accent 

- Dash { Left brace 

. Period | Pipe sign 

/ Forward slash } Right brace 

< Less than sign ~ Tilde 

 
 

Invalid MPC Username Characters 

The following characters cannot be used in usernames for MPC. 

Character Description 
: Colon 

" Double quote 

& Ampersand 

' Single quote 
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Installing and Opening Standalone MPC 

Raritan recommends that you open only one standalone MPC session at 
a time. Opening more than one standalone MPC session on the same 
client at the same time may cause performance problems and system 
errors. 

Important: MPC modem connectivity is supported on the Windows® 
operating system. When working in Windows, use Standalone MPC. 

Important: Only Mac 10.5 and 10.6 with an Intel® processor can run 
JRE 1.6 and, therefore, be used as a client. Mac 10.4.11 and 10.5.8 
do not support MPC as a standalone client. 

You must have the MPC JAR file to install MPC for any of these 
operating systems. 

 To check for the MPC JAR file: 
1. Download the installation file, MPC-installer.jar from the Raritan 

website (www.raritan.com) on the Support > Firmware and 
Documentation page.  

2. Locate the Dominion product you are working with and click the 
Standalone Multi-Platform Client link. 

3. If copying MPC-installer.jar from a known location, double-click the 
file to start installation. 

Windows 

 To check the JRE version in Windows: 
1. Do one of the following to check the JRE version in Windows: 

 Determine your version of the JRE from the Java website: 
http://www.java.com/en/download/help/testvm.xml. 

 Click the Windows Start button at the bottom left of your page 
and click Control Panel.  

Tip: In the upper left corner of the page, you may see a panel named 
Control Panel with the option Switch to Classic View or Switch to 
Category View.  For easier viewing, opt for Classic View. 

a. Search the Control Panel files for a Java icon. When you locate 
the Java icon, double-click it to open the Java Control panel. 
Click the General tab and then click the About button to check 
the current Java Runtime Environment (JRE). 
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b. If the JRE is version 1.6 or later, proceed with the MPC 
Installation. If the Java icon does not exist in the Control Panel or 
if the JRE version is prior to 1.6, go to the Sun Microsystems 
website at http://java.sun.com/products/ to download the latest 
version of JRE. 

2. For future Java access and to automatically open it, set your path to 
the Java executable.  

a. Right-click the My Computer icon on your desktop and click 
Properties. 

b. Click the Advanced tab and then click "Environment variables". 

c. Edit the Path address so that it contains the path to the Java 
executable.   
For example, if Java is installed on C:\j2re1.6 and your path is 
currently set to C:\WINDOWS\SYSTEM32, then change the path 
to read C:\WINDOWS\SYSTEM32;C:\j2re1.6 

 To install MPC for Windows: 
1. Download the MPC-installer.jar installation file or copy the file from a 

known location.  

2. Double-click the jar file icon to open the installation dialog. 

3. After the initial dialog appears, click Next. 

4. Choose the directory where you want to install MPC and click Next. 
Click Browse to locate a non-default directory. 

Note: If you are using Windows 7, when User Access Control is 
turned on, you will need to manually create a folder to contain the 
MPC files. You will also need to assign the Admin user, at a 
minimum, Write permissions to the folder from Properties dialog > 
Security tab. Alternatively, you can turn off User Access Control. 

5. Click Next. 

6. In the Shortcut dialog, choose a shortcut location, determine who 
should have the shortcut, and determine whether you want the 
shortcut on the desktop. When finished, click Next. 

Once the installation is complete, the final dialog indicates where you 
will find an uninstaller program and provides an option for generating 
an automatic installation script. Click Done to close the Installation 
dialog. 

 To open MPC in Windows: 
1. Click the Windows Start menu and then choose All Programs > 

Raritan Multi-Platform Client. Alternatively, double-click the MPC 
desktop shortcut icon if you created one. 

2. Double-click the desired device in the Navigator to establish a 
connection. 
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3. Type your user name and password in the device dialog and then 
click OK to log on.  

Linux® 

Determine your version of the JRE from the Java website: 
http://www.java.com/en/download/help/testvm.xml. 

You may need some configuration depending on your OS and browser. 
Configuration instructions are provided with the JRE download.  

Important: When launching MPC from a browser, it is highly 
recommended that you disable the Java Applet caching. 

Although no actual problems have occurred when Java caching is turned 
on, some non-impacting Java exceptions have occurred. Generation of 
these Java-exceptions can appear in the Java Applet Console window 
and may degrade performance. 

For Linux/UNIX environments, the Java Control Panel is located in the 
JRE's bin directory; the location varies based on where JRE was 
installed by your Linux/UNIX administrator. 

Tip: It is also recommended that you clear the Java cache. 

 To disable Java caching and clear the cache (use these steps 
with Microsoft Windows XP and JRE 1.6.0): 

1. From the Start menu, click Control Panel. 

2. Double-click on the Java icon to launch it. The Java Control Panel 
dialog appears. 

3. To disable Java caching: 

a. From the General tab, click the Settings button. The Temporary 
Files Settings dialog appears. 

b. Click the View Applets button. The Java Applet Cache Viewer 
opens. 

c. Deselect the Enable Caching checkbox if it is already checked. 

d. Click OK. 

4. To clear the Java cache: 

a. From the Temporary Files Settings dialog, click the Delete Files 
button. The Delete Temporary Files dialog appears. 

b. Select the temporary files that you want to delete. 

5. Click OK. 

 To check the JRE version in Linux: 
1. In a graphical environment, open a terminal dialog. 
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2. Type java version in the command line and press Enter on your 
keyboard. The currently-installed version of Java Runtime 
Environment (JRE) is displayed. 

If your path variable is not set to where the java binaries have been 
installed, you may not be able to see the JRE version. 

3. Set your path:  

a. To set your path and assuming JRE 1.6 is installed in 
/usr/local/java: you must set your PATH variable. 

b. To set the path for bash shell, export 
PATH=$PATH:/usr/local/java/j2re1.6/bin. 

c. To set the path for tcsh or csh, set PATH = ($PATH 
/usr/local/java/j2re1.6/bin). 

These commands can be typed at the terminal each time you login. 
Alternatively, you can add it to your .bashrc for bash shell, .cshrc for 
csh, or tcsh so that each time you login the PATH is already set.  

See your shell documentation if you encounter problems.  

4. If the JRE is version 1.6 or higher, proceed with the MPC installation. 
If the version is prior to 1.6, go to the Java website at 
http://java.sun.com/products/ to download the latest Runtime 
Environment. 

 To install MPC for Linux: 

You must have Administrative privileges to install MPC. 

1. Download the MPC-installer.jar file or copy it from a known location. 

2. Open a terminal dialog and open the directory where the installer is 
saved. 

3. Type java -jar MPC-installer.jar and press Enter to run the installer. 

4. After the initial page loads, click Next. 

5. Use the Browse function to select a directory to install MPC if the 
directory is different from the default path displayed in the "Select the 
installation path" field.  

6. Click Next to open the Shortcut dialog. 

7. On the Shortcut dialog: 

 Choose a shortcut location from the "Select a Program Group for 
the Shortcuts:" field. 

 Select either "current user" or "all users" to define who should 
have access to the shortcut. 

 Check the "Create shortcut on the desktop" checkbox if you want 
the shortcut to appear on the desktop.  

8. When finished, click Next. 
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Note: Once MPC is installed successfully, a shortcut will be available 
on the desktop. However, for Linux users, you will need to log off of 
and then back into your session before the shortcut will be visible on 
the desktop.  

Once the installation is complete, the final page indicates where you 
will find an uninstaller program and provides you with the option to 
generate an automatic installation script.  

9. Click Done to close the Installation dialog. 

 To open MPC in Linux: 
1. Open a terminal window and change directories to the directory 

where you installed MPC (default location: /usr/local/Raritan/Raritan 
MPC/version number). 

2. Type ./start.sh and press Enter to open MPC. 

3. Double-click the desired device to establish a connection, type your 
user name and password, and click OK to log on.  

Solaris™ 

To check the JRE version for Sun Solaris: 

1. Launch a terminal window on the Sun Solaris desktop. 

2. Type java version in the command line and press Enter. The 
currently-installed version of Java Runtime Environment (JRE) 
appears. 

If your path variable is not set to where the java binaries have been 
installed, you may not be able to see the JRE version. 

a. To set your path and assuming JRE 1.6 is installed in 
/usr/local/java, you must set your PATH variable. 

b. To set path for bash shell, export 
PATH=$PATH:/usr/local/java/j2re1.6/bin. 

c. To set path for tcsh or csh, set PATH = ($PATH 
/usr/local/java/j2re1.6/bin). 

3. These commands can be typed at the terminal each time you login. 
Alternatively, you can add it to your .bashrc for bash shell, .cshrc for 
csh, or tcsh so that each time you login the PATH is already set. See 
your shell documentation if you encounter problems. 

4. If the JRE is version 1.6 or higher, proceed with the MPC installation. 
If the version is prior to 1.4.6, go to the Sun website at 
http://java.sun.com/products/ to download the latest Runtime 
Environment. 
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RRC Full Screen Mode 

Full screen mode removes the surrounding RRC graphical interface and 
your local desktop area, filling your screen with the video from the target 
server. Your screen's resolution will be adjusted to match the resolution 
of the target server (provided your graphics system supports it). If your 
graphics system does not support the resolution of the target system, 
you will be unable to activate full screen mode and a message will 
appear requesting that you change your video resolutions first. 

Note: To view the video resolutions your system supports in a Windows® 
operating system environment, access your computer's Control Panel 
from the Windows Start menu, double-click on Display, and click on the 
Settings tab. 

Activate full screen mode in one of the following ways once you are 
connected to a target: 

• Click the Full Screen icon  in the toolbar and then click OK in the 
confirmation message that appears. 

• Choose View > Full Screen and then click OK in the confirmation 
message that appears. 

• Press Ctrl+Left Alt+M to open the shortcut menu. Next, press the F 
key on your keyboard or use your mouse to choose Full/Normal 
Screen. Click OK in the confirmation message that appears.  
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MPC Scaling 

Scaling your target window size allows you to view the entire contents of 
the target server window. This feature increases or reduces the size of 
the target video to fit the window size and maintains the aspect ratio. 
This allows you to see the entire target server desktop while in standard 
view. 

 To activate Scaling, do one of the following: 
• Choose View > Scale Video. 

• Click the Scaling button  on the toolbar. 
• To exit this mode and return the target window to its previous size, 

deselect Scale Video on the View menu or click the Scaling button 
once again. 

Note: Enabling Scale Video will scale the complete target video image to 
fit the remote desktop area as it grows or shrinks. You can combine this 
setting with target screen resolution for a 'full page' effect on targets with 
a higher resolution than your desktop. 
 

RRC Scaling 

Scaling your target window size allows you to view the entire contents of 
the target server window. This feature increases or reduces the size of 
the target video to fit the window size and maintains the aspect ratio. 
This allows you to see the entire target server desktop while in standard 
view. 

To activate Scale Video mode, do one of the following: 

• Choose View > Scale. 

• Click the Scaling button  on the toolbar.  

To exit this mode and return the target window to its previous size, 
choose Scale on the View menu or click the Scaling button once again. 

Note: Enabling Scale Video will scale the complete target video image to 
fit the remote desktop area as it grows or shrinks. You can combine this 
setting with target screen resolution for a full page affect on targets with 
a higher resolution than your desktop. 
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Auto-Scroll 

The auto-scroll feature automatically scrolls the video display in the 
direction of the cursor as the cursor approaches the edge of the display. 
A thin border appears around the perimeter of the remote desktop area 
to indicate the function is on. When enabled, if you see scroll bars and 
then move the cursor onto the border, the page will automatically scroll in 
the appropriate direction. 

The scroll border is activated by selecting Show Scroll Borders in the 
Options dialog, which is accessed by choosing Tools > Options.  
 

Connection Profiles 

Connection profiles store important information about your Raritan 
device such as the IP address, custom TCP ports, preferred 
compression settings, and custom security keys. A profile is required to 
access devices outside your subnet and to access devices using a dial-
up connection. 

Through profiles, you can set up personalized connections. These 
profiles are not shared among other users. 

The information collected when creating a new connection profile will 
differ based on Generation 1 and Generation 2 devices.  

Tip: If your Raritan device is configured to use a custom TCP port or a 
group security key, first create a connection profile so that you can 
access the device. 
 

Managing Profiles in KX II-101, KSX II and KX G1 

Creating, Modifying and Deleting Profiles in MPC 

 To create a profile:  
1. There are two ways to create a profile: 

 For automatically discovered devices, right-click the device name 
in the Navigator and choose Add Profile from the shortcut menu. 

 For other devices, choose Connection > New Profile. 

The Add Connection dialog appears. Options are organized into 
three tabs. 

Note: The Connection and Security tabs are not available for 
Generation 2 devices. 

Connect Tab 
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2. On the Connect tab, type a meaningful description of the device in 
the Description field. This description identifies the Raritan device in 
the Navigator. 

3. From the Product drop-down, choose the Raritan product you are 
using. 

TCP/IP Connections 

4. Select the type of connection from the Connection Type drop-down.  

a. If TCP/IP Connection is selected for a LAN/WAN connection, 
complete the information in the "Find Raritan device By" section: 

 Type the IP address assigned to your Raritan device. 

 Type the name assigned to your Raritan device during initial 
setup. 

 Type the Domain Name Server (DNS) name in the Host Name 
field. Use this option if you use a DNS server to resolve a DNS 
name to the IP address assigned to your Raritan device. 

 
Dial-up Connections 

a. Select Dial Up Connection from the Connection Type drop-down 
for a direct analog modem connection to the Raritan device. 
Type the parameters that should be used to establish a 
connection.  

 Enter the phone number for the dial-up connection. Remember to 
include any additional codes that should be dialed to establish a 
connection, such as country codes, area codes, or outside line 
access codes. 

 Select the modem (as configured in Windows) from the drop-
down list that will be used to dial and connect to your Raritan 
device. 



Chapter 4: Multi-Platform Client and Raritan Remote Client 
 

72
 

 

Note: For security reasons, you must use the MPC standalone client 
if you require modem access. Further, one modem on a client PC 
can be used for only one device connection. 

 

Note: Dial-up is not support in KX II-101. 

5. Select the Use Default Port Number checkbox to use the default port 
number (5000). For TCP Ports, devices are automatically configured 
to use TCP Port 5000 when communicating with the client.   

If you do not want to use the default port number, deselect the 
checkbox and type the port number in the Port Number field. 

Compression Tab  

6. Set the Connection Speed. 

Use this setting to manually adjust the connection speed to 
accommodate bandwidth constraints. Devices can automatically 
detect available bandwidth and not limit bandwidth use. However, 
you can also adjust this usage according to your needs. Depending 
on the Raritan device in use, different options may be available: 

 Auto Detect 

 1G Ethernet 

 100mb Ethernet 

 10mb Ethernet 

 1.5mb (Max DSL/T1) 

 1mb (Fast DSL/T1) 

 512 kb (Medium DSL/T1) 

 384 kb (Slow DSL/T1) 
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 256 kb (Cable) 

 128 kb (Dual ISDN) 

 56 kb (ISP Modem) 

 33 kb (Fast Modem) 

 24 kb (Slow Modem) 

Note: Raritan recommends that if you are connecting to the device 
via modem, you set the connection speed to 33kb. 

7. Set the Color Depth. 

Devices can dynamically adapt the color depth transmitted to remote 
users in order to maximize usability in all bandwidths. Select from 
among the options in the drop-down list. Depending on the Raritan 
device in use, different options may be available: 

 15-bit RGB Color 

 8-bit RGB Color 

 4-bit Color 

 4-bit Gray 

 3-bit Gray 

 2-bit Gray 

 Black and White 

Important: For most administrative tasks (server monitoring, 
reconfiguring, and so forth), administrators do not require the full 24-
bit or 32-bit color spectrum made available by most video graphics 
cards. Attempting to transmit such high color depths wastes network 
bandwidth. 

Note: If you are connecting to the device via a modem, Raritan 
recommends setting the color depth to 4-bit gray. 

8. Select Progressive Update to increase the usability in constrained 
bandwidth environments. When Progressive Update is enabled, the 
device initially sends an image of the remote desktop at lower color 
depths. Higher color depth images are provided as the bandwidth 
allows. 

Note: When Color Depth is set to Auto Select Color (default), 
Progressive Update is automatic. The device will enable/disable 
Progressive Update as required, disabling it for fast connections and 
enabling it for slow connections. 
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9. Selecting the Internet Flow Control checkbox ensures that packets 
transmitted by the device are received and reconstructed by the 
client application in the correct order. This is useful when using a 
device over an unpredictable public WAN (particularly in international 
scenarios). 

10. Use the slider to select the desired level of video Smoothing (15-bit 
mode only). The level determines how aggressively to blend page 
regions with small color variation into a single, smooth color. 
Smoothing improves the appearance of the target video by reducing 
the video noise that is displayed. 

11. Select "Frames per second". This setting instructs MPC on how often 
to redraw the video display of the target. This only affects the client 
display behavior and has no bearing on the data rate of the video 
being sent to the client. Setting this option higher makes the video 
appear smoother but also requires more processing power. 

 
Security Tab  

12. Enter the private security key in the Private Key field if your device is 
configured to use a private security key. Entering a security key 
allows you to gain the authorization required to initiate a connection 
to that device. 

13. Retype the private security key in the Confirm Private Key field to 
ensure no typographical errors were made. 



 Chapter 4: Multi-Platform Client and Raritan Remote Client  

 
75

 

14. Click OK to create the connection profile. 

 

 To modify a profile:  
1. Select the device in the Navigator panel and right-click it. 

2. Choose Modify Profile. The Modify Connection dialog appears. 

3. Update the fields as appropriate. 

4. Click OK. 

 To delete a profile: 
1. Select the device with a profile in the Navigator and right-click it. 

2. Choose Delete Profile. 

3. When prompted to confirm the deletion, click Yes to delete the profile 
for this device or click No to return to the application without deleting. 

Note: The device only supports modem connections to the Administrative 
functions in MPC. Port functions are not supported via modem. 
 

Creating, Modifying and Deleting Profiles in RRC 

 To create a profile:  
1. There are two ways to create a profile: 

 For automatically discovered devices, right-click the device name 
in the Navigator and choose Add Profile from the shortcut menu. 

 For other devices, choose Connection > New Profile. 

The Add Connection dialog appears. Options are organized into 
three tabs. 
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Note: The Connection and Security tabs are not available for 
Generation 2 devices. 

 
Connect Tab 

2. On the Connect tab, type a meaningful description of the device in 
the Description field. This description identifies the Raritan device in 
the Navigator. 

3. Select Dial Up Connection from the Connection Type drop-down for 
a direct analog modem connection to the Raritan device. Type the 
parameters that MPC or RRC should use to establish a connection. 
Dial up connection does not apply to Generation 2 (G2) or KX101. 

 Enter the phone number for the dial-up connection. Remember to 
include any additional codes that should be dialed to establish a 
connection, such as country codes, area codes, or outside line 
access codes. 

 Select the modem (as configured in Windows) from the drop-
down list that will be used to dial and connect to your Raritan 
device. 

Note: For security reasons, you must use the MPC standalone client 
if you require modem access. Further, one modem on a client PC 
can be used for only one device connection. 
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4. Select the Use Default Port Number checkbox to use the default port 
number (5000). For TCP Ports, devices are automatically configured 
to use TCP Port 5000 when communicating with the client.   

If you do not want to use the default port number, deselect the 
checkbox and type the port number in the Port Number field. 

Compression Tab 

5. Set the Connection Speed. 

Use this setting to manually adjust the connection speed to 
accommodate bandwidth constraints. Devices can automatically 
detect available bandwidth and not limit bandwidth use. However, 
you can also adjust this usage according to your needs. Depending 
on the Raritan device in use, different options may be available: 

 Auto Detect 

 1G Ethernet 

 100mb Ethernet 

 10mb Ethernet 

 1.5mb (Max DSL/T1) 

 1mb (Fast DSL/T1) 

 512 kb (Medium DSL/T1) 

 384 kb (Slow DSL/T1) 

 256 kb (Cable) 

 128 kb (Dual ISDN) 

 56 kb (ISP Modem) 

 33 kb (Fast Modem) 

 24 kb (Slow Modem) 

6. Set the Color Depth. 

Devices can dynamically adapt the color depth transmitted to remote 
users in order to maximize usability in all bandwidths. Select from 
among the options in the drop-down list. Depending on the Raritan 
device in use, different options may be available: 

 15-bit RGB Color 

 8-bit RGB Color 

 4-bit Color 

 4-bit Gray 

 3-bit Gray 

 2-bit Gray 

 Black and White 
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Important: For most administrative tasks (server monitoring, 
reconfiguring, and so forth), administrators do not require the full 24-
bit or 32-bit color spectrum made available by most video graphics 
cards. Attempting to transmit such high color depths wastes network 
bandwidth. 

7. Select Progressive Update to increase the usability in constrained 
bandwidth environments. When Progressive Update is enabled, the 
device initially sends an image of the remote desktop at lower color 
depths. Higher color depth images are provided as the bandwidth 
allows. 

Note: When Color Depth is set to Auto Select Color (default), 
Progressive Update is automatic. The device will enable/disable 
Progressive Update as required, disabling it for fast connections and 
enabling it for slow connections. 

8. Selecting the Internet Flow Control checkbox ensures that packets 
transmitted by the device are received and reconstructed by the 
client application in the correct order. This is useful when using a 
device over an unpredictable public WAN (particularly in international 
scenarios). 
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9. Use the slider to select the desired level of video Smoothing (15-bit 
mode only). The level determines how aggressively to blend page 
regions with small color variation into a single, smooth color. 
Smoothing improves the appearance of the target video by reducing 
the video noise that is displayed. 

 
Security Tab 

10. Enter the private security key in the Private Key field if your device is 
configured to use a private security key. Entering a security key 
allows you to gain the authorization required to initiate a connection 
to that device. 

11. Retype the private security key in the Confirm Private Key field to 
ensure no typographical errors were made. 
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12. Click OK to create the connection profile. 

 
 

Managing Profiles in KX II 

Creating, Modifying and Deleting Profiles in MPC - Generation 2 Devices 

 To create a profile:  
1. There are two ways to create a profile: 

 For automatically discovered devices, right-click the device name 
in the Navigator and choose Add Profile from the shortcut menu. 

 For other devices, choose Connection > New Profile. 

The Add Connection dialog appears. Options are organized into 
three tabs. 

Note: The Connection and Security tabs are not available for 
Generation 2 devices. 

2. On the Connect tab, type a meaningful description of the device in 
the Description field. This description identifies the Raritan device in 
the Navigator. 

3. From the Product drop-down, choose the Raritan product you are 
using. 

4. Select the type of connection from the Connection Type drop-down.  
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TCP/IP Connections 

a. If TCP/IP Connection is selected for a LAN/WAN connection, 
complete the information in the "Find Raritan device By" section: 

 Type the IP address assigned to your Raritan device. 

 Type the name assigned to your Raritan device during initial 
setup. 

 Type the Domain Name Server (DNS) name in the Host Name 
field. Use this option if you use a DNS server to resolve a DNS 
name to the IP address assigned to your Raritan device. 

a. To use the default port settings for the HTTPS port (port 443) 
and the Discovery port (port 5000), leave their respective Use 
Default checkboxes selected. As long as the Use Default 
checkboxes are selected, the HTTPS Port and Discovery Port 
fields are not active. 

If you would like to change the default ports to other ports, 
deselect the respective Use Default checkbox and enter the port 
in the appropriate field. For example, to change the HTTPS port, 
deselect its Use Default checkbox and enter the port number in 
the HTTPS field.  

 
Dial-up Connection 

b. Select Dial Up Connection from the Connection Type drop-down 
for a direct analog modem connection to the Raritan device. 
Type the parameters that should be used to establish a 
connection.  

 Enter the phone number for the dial-up connection. Remember to 
include any additional codes that should be dialed to establish a 
connection, such as country codes, area codes, or outside line 
access codes. 
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 Select the modem (as configured in Windows) from the drop-
down list that will be used to dial and connect to your Raritan 
device. 

Note: For security reasons, you must use the MPC standalone client 
if you require modem access. Further, one modem on a client PC 
can be used for only one device connection. 

a. To use the default port settings for the HTTPS port (port 443) 
and the Discovery port (port 5000), leave their respective Use 
Default checkboxes selected. As long as the Use Default 
checkboxes are selected, the HTTPS Port and Discovery Port 
fields are not active. 

If you would like to change the default ports to other ports, 
deselect the respective Use Default checkbox and enter the port 
in the appropriate field. For example, to change the HTTPS port, 
deselect its Use Default checkbox and enter the port number in 
the HTTPS field. 

 

 To modify a profile:  
1. Select the device in the Navigator panel and right-click it. 

2. Choose Modify Profile. The Modify Connection dialog appears. 

3. Update the fields as appropriate. 

4. Click OK. 

 To delete a profile: 
1. Select the device with a profile in the Navigator and right-click it. 

2. Choose Delete Profile. 
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3. When prompted to confirm the deletion, click Yes to delete the profile 
for this device or click No to return to the application without deleting. 

 

Establishing a New Connection 

Note: Depending on your version of the JRE™, you might receive a 
certificate message when using the standalone application to access a 
Dominion device. You have to accept the certificate in order to establish 
the connection. 

To connect to a device, double-click the device's icon in the Navigator, 
then type your user name and password to connect. You can also right-
click the device name in the Navigator and select New Connection. 

Note: The default device login user name is admin and the default 
password is raritan. You have administrative privileges using these login 
credentials.  

If you do not see an icon for your device in the Navigator, follow the 
instructions on creating new profiles, which is available in this section. 

If you are having problems connecting to a device, be sure to check the 
following: 

• User name - Raritan usernames are not case-sensitive. 
• Password - Raritan passwords are case-sensitive. 
• TCP Port - If you have configured your device to use a non-default 

TCP Port, this information must be entered into its connection profile. 
• Firewall Settings - If you are accessing a device through a firewall, 

that firewall must be configured to allow two-way communication on 
TCP Port 5000 (or the custom TCP Port to which your device has 
been configured). 

• Security Key - If you have configured your device to require a group 
security key, that key must be entered into the device's connection 
profile. 

Note: If you are running MPC on Internet Explorer® with both a Microsoft® 
firewall and a non-Microsoft firewall utility installed, IE will display a 
message telling you that MPC is already running (even if it is not in fact 
running). To avoid this, deactivate one of your firewalls, or use a browser 
such as Mozilla® or Firefox®. 
 

Connection Information 

 To obtain information about your connection: 
• Choose Connection > Connection Info. The Connection Info dialog 

appears. 
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Generation 1 Devices 

The following information is displayed about a current connection to 
Generation 1 devices: 
 

Connection 
information 

Description 

Device name The name of your device. 

IP address The IP address of your device. 

Port The KVM Communication TCP/IP Port used to 
access the target device. 

Data in/second Data rate in. 

Data out/second Data rate out. 

FPS The frames per second transmitted for video. 

Connect time The duration of the connect time. 

Horizontal resolution The page resolution horizontally. 

Vertical resolution The page resolution vertically. 

Refresh rate How often the page is refreshed. 

Protocol version The RFB Protocol version. 

Oldest supported 
version 

The oldest supported version of the client 
software. 

Hardware version 0 - Obsolete 

Software version 3 (Software version) 

Post code Power on self-test error code. 0 = no error. 

Network flags A list of the various network options that have 
been enabled or disabled such as DHCP, dial-
in, autodetection, and so on. 

Security flags A list of the various security options that have 
been enabled or disabled such as SSL 
encryption, SNMP, and so on. 

Options RFP and TR support enabled or disabled. 

Frame grabber info 0 - not used 

KME info KME version number for systems that use the 
KME. 

Serial Info  Serial devices 

Video devices count Number of video devices detected. 
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3. To exit completely, click Exit on the Connection menu 
 

Shortcut Menu 

To access the shortcut menu, use either the default keyboard 
combination of Ctrl+Left Alt+M or the keyboard combination you assign. 
See Changing the Shortcut Menu Keyboard Combination (on page 
88) for more information.  

TIP: If at some point you forget the keyboard combination used to open 
the shortcut menu, press Ctrl+Left Alt at the same time. The keyboard 
combination will be displayed across the bottom of the page for five 
seconds.  
 

Shortcut Menu Key Options 

Execute any of the commands on the shortcut menu by either choosing 
the command in the menu or using a key combination. If you are using a 
key combination to execute a command, you will press Ctrl+Left Alt+M 
and then press the key on your keyboard that corresponds to the 
underlined letter in the shortcut menu. For example, press Ctrl+Left 
Alt+M+F to enter Full Screen mode. See the table below for information 
on invoking commands from the shortcut menu using keyboard 
combinations. 

Note: You must use the Left Alt key on your keyboard when using the 
Ctrl+Left Alt combination. 
 

To Press Ctrl+Left Alt+M+ 

Toggle between Full/Normal screen 
mode* 

F 

Display connection information* I 

Display or set connection properties* P 

Display or set video settings* V 

Refresh the page R 

Synchronize mouse Y 

Change to/from single/double cursor 
mode 

S 

Send Ctrl+Alt+Del to the target 
system 

D 

Connect Drive T 

Connect CD-ROM/ISO Image E 

Send Ctrl+Alt+M to the target system N 
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 Japanese 

 United Kingdom 

 Korean (Korea) 

 Belgian (Belgium) 

 Norwegian (Norway) 

 Danish (Denmark) 

 Swedish (Sweden) 

 German (Switzerland) 

 Hungarian (Hungary) 

 Spanish (Spain) 

 Italian (Italy) 

 Slovenian 

3. Click OK. 
 

Keyboard Limitations 

Japanese Kanji Keyboards 

For Kanji keyboards, when using DCIM-USBs and MPC, the remote 
client cannot enter EISU mode by pressing the Caps Lock key (key#30). 
Local port access is not affected. You can access the DCIM-USBs using 
RRC or using the keyboard macro Shift + Caps Lock in MPC. 

Slovenian Keyboards 

The < key does not work on Slovenian keyboards due to a JRE 
limitation. 

Language Configuration on Linux 

Because the Sun JRE on Linux has problems generating the correct Key 
Events for foreign-language keyboards configured using System 
Preferences, Raritan recommends that you configure foreign keyboards 
using the methods described in the following table. 
 

Language Configuration method 
US Intl Default 

French Keyboard Indicator 

German System Settings (Control Center) 

Japanese System Settings (Control Center) 

UK System Settings (Control Center) 

Korean System Settings (Control Center) 
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Language Configuration method 
Belgian Keyboard Indicator 

Norwegian Keyboard Indicator 

Danish Keyboard Indicator 

Swedish Keyboard Indicator 

Hungarian System Settings (Control Center)  

Spanish System Settings (Control Center)  

Italian System Settings (Control Center)  

Slovenian System Settings (Control Center)  

Portuguese  System Settings (Control Center) 

Note: The Keyboard Indicator should be used on Linux systems using 
Gnome as a desktop environment. 
 

Video Properties 

Refreshing the Screen 

The Refresh Screen command forces a refresh of the video screen. 
Video settings can be refreshed automatically in several ways: 

• The Refresh Screen command forces a refresh of the video screen. 
• The Auto-sense Video Settings command automatically detects the 

target server's video settings. 
• The Calibrate Color command calibrates the video to enhance the 

colors being displayed. 

In addition, you can manually adjust the settings using the Video Settings 
command. 

 To refresh the video settings, do one of the following: 
• Choose Video > Refresh Screen or click the Refresh Screen button 

 in the toolbar. 

If the video card you are using on the target uses custom software and 
you are accessing the target through MPC or VKC, you may need to 
change the maximum refresh rate of the monitor in order for the refresh 
rate to take affect on the target.  

 To adjust the monitor refresh rate: 
1. In Windows®, select Display Properties > Settings > Advanced to 

open the Plug and Play dialog. 
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2. Click on the Monitor tab. 

3. Set the 'Screen refresh rate' to any rate above 100Hz. 

4. Click OK and then OK again to apply the setting. 
 

Auto-Sense Video Settings 

The Auto-sense Video Settings command forces a re-sensing of the 
video settings (resolution, refresh rate) and redraws the video screen. 

 To automatically detect the video settings, do the following: 
• Choose Video > Auto-sense Video Settings or click the Auto-Sense 

Video Settings button  in the toolbar. A message stating that the 
auto adjustment is in progress appears. 

 

Calibrating Color 

Use the Calibrate Color command to optimize the color levels (hue, 
brightness, saturation) of the transmitted video images. The color 
settings are on a target server-basis. 

Note: The Calibrate Color command applies to the current connection 
only. 

 To calibrate the color, do the following: 
• Choose Video > Calibrate Color or click the Calibrate Color button 

 in the toolbar. The target device screen updates its color 
calibration. 

 

Adjusting Video Settings 

Use the Video Settings command to manually adjust the video settings.  

 To change the video settings: 
1. Choose Video > Video Settings or click the Video Settings button 

 in the toolbar to open the Video Settings dialog.  

2. Adjust the following settings as required. As you adjust the settings 
the effects are immediately visible:  

a. Noise Filter 
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The device can filter out the electrical interference of video output 
from graphics cards. This feature optimizes picture quality and 
reduces bandwidth. Higher settings transmit variant pixels only if 
a large color variation exists in comparison to the neighboring 
pixels. However, setting the threshold too high can result in the 
unintentional filtering of desired screen changes. 
Lower settings transmit most pixel changes. Setting this 
threshold too low can result in higher bandwidth use. 

b. PLL Settings 

Clock - Controls how quickly video pixels are displayed across 
the video screen. Changes made to clock settings cause the 
video image to stretch or shrink horizontally. Odd number 
settings are recommended. Under most circumstances this 
setting should not be changed because the autodetect is usually 
quite accurate. 

Phase - Phase values range from 0 to 31 and will wrap around. 
Stop at the phase value that produces the best video image for 
the active target server. 

c. Brightness: Use this setting to adjust the brightness of the target 
server display. 

d. Brightness Red - Controls the brightness of the target server 
display for the red signal. 

e. Brightness Green - Controls the brightness of the green signal. 

f. Brightness Blue - Controls the brightness of the blue signal. 

g. Contrast Red - Controls the red signal contrast. 

h. Contrast Green - Controls the green signal. 

i. Contrast Blue - Controls the blue signal. 

If the video image looks extremely blurry or unfocused, the 
settings for clock and phase can be adjusted until a better image 
appears on the active target server. 

Warning: Exercise caution when changing the Clock and Phase 
settings. Doing so may result in lost or distorted video and you may 
not be able to return to the previous state. Contact Raritan Technical 
Support before making any changes. 

j. Horizontal Offset - Controls the horizontal positioning of the 
target server display on your monitor. 

k. Vertical Offset - Controls the vertical positioning of the target 
server display on your monitor. 
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Using Screenshot from Target 

You are able to take a screenshot of a target server using the 
Screenshot from Target server command. You can then save this 
screenshot to a file location of your choosing as a bitmap, JPEG or PNG 
file. 

Note: The Screenshot from Target function is not available for the KX II-
101. 

 To take a screenshot of the target server:  
1. Select Video > Screenshot from Target or click the Screenshot from 

Target button  on the toolbar. 

2. In the Save dialog, choose the location to save the file, name the file, 
and select a file format from the 'Files of type' drop-down. 

3. Click Save to save the screenshot. 
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Changing the Maximum Refresh Rate 

If the video card you are using on the target uses custom software and 
you are accessing the target through MPC or VKC, you may need to 
change the maximum refresh rate of the monitor in order for the refresh 
rate to take affect on the target.  

 To adjust the monitor refresh rate: 
1. In Windows®, select Display Properties > Settings > Advanced to 

open the Plug and Play dialog. 

2. Click on the Monitor tab. 

3. Set the 'Screen refresh rate' to any rate above 100Hz. 

4. Click OK and then OK again to apply the setting. 
 

Mouse Options 

Single Cursor Mode/Dual Cursor Mode 

When remotely viewing a target server that uses a mouse, you will see 
two mouse cursors on the remote desktop. When your mouse pointer 
lies within the remote desktop area, mouse movements and clicks are 
directly transmitted to the connected target server. The pointer, 
generated by the operating system, slightly leads the target server's 
mouse pointer during movement. This is a result of digital delay. 

On fast LAN connections, you may want to disable the mouse pointer 
and view only the target server's pointer. To toggle between these two 
modes, choose Single/Double Cursor on the shortcut menu. 

Alternatively, click the Single Mouse Pointer button  in the toolbar or 
choose Mouse > Single Cursor Mode. 
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When in Dual Cursor mode, press Ctrl+Left Alt+M and execute the 
Synchronize Mouse shortcut to force realignment of the mouse cursors. 
If the mouse cursors still remain out of sync, click the Auto-Sense Video 

Settings button  on the toolbar. 

Note: When in Dual Cursor mode, if the dual mouse cursors are 
synchronized but left idle for five minutes or longer, the target mouse 
pointer will automatically align itself with the upper left corner of the 
target window. Execute the Synchronize Mouse command to ensure 
local and target mouse pointer alignment. 

Single Mouse Cursor mode for Apple® Mac® target servers is supported 
for MPC. Select Single Mouse Cursor on the Mouse menu in MPC to 
enter this mode.  While in this mode, the cursor will remain in the video 
window for the Mac Server.  To exit, open the shortcut menu and press S 
on the keyboard. 
 

Mouse Synchronization Options 

In addition to synchronizing mouse cursors or toggling between single 
and dual cursor mode, the Mouse menu provides three options for 
synching cursors when in dual cursor mode: 
 

Menu option Description 
Absolute When connected to selected Dominion devices and 

targets with USB ports, the application will use 
absolute coordinates to keep the cursors in sync. 
See Absolute Mouse Mode (on page 22) for more 
information. 

Intelligent Under certain conditions, the application can detect 
the target mouse settings and synchronize the 
mouse cursors accordingly, accelerating the mouse 
on the target device. See Intelligent Mouse Mode 
(on page 21) for more details. 

Standard This is the standard mouse synchronization 
algorithm. See Standard Mouse Mode (on page 20) 
for more information. 

Note: The Intelligent and Standard Mouse modes are available to all 
device targets. Absolute Mouse mode are only available to Mac® and 
Windows® operating system USB targets. 
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Automatic Mouse Synchronization 

For Generation 1, devices When in Dual Cursor mode, the system will 
automatically align the mouse cursors when the cursor is inactive for 15 
seconds. Enable this feature by clicking the Synchronize Mouse button 

 in the toolbar or selecting Tools > Options and selecting the "Auto-
Sync mouse in two-cursor mode" checkbox. 

Automatic Mouse Synchronization is available for Generation 2 devices 
when: 

• A new connection is established 
• Auto-sense is enabled 
• Color calibration is enabled 

Enable this feature in Generation 2 devices by clicking the Synchronize 

Mouse button  in the toolbar or selecting Mouse > Synchronize 
Mouse. 
 

Absolute Mouse Mode 

In this mode, absolute coordinates are used to keep the client and target 
cursors in sync, even when the target mouse is set to a different 
acceleration or speed. This mode is supported on servers with USB 
ports.  

 To enter absolute mouse mode: 
• Choose Mouse > Absolute. 

Note: The absolute mouse setting requires a USB target system and is 
the recommended mouse setting for KX II-101. 

Note: Absolute Mouse Synchronization is available for use with the 
virtual media-enabled USB CIM (D2CIM-VUSB and D2CIM-DVUSB) 
only. 
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Intelligent Mouse Mode 

In Intelligent Mouse mode, the device can detect the target mouse 
settings and synchronize the mouse cursors accordingly, allowing mouse 
acceleration on the target. In this mode, the mouse cursor does a 
“dance” in the top left corner of the screen and calculates the 
acceleration. For this mode to work properly, certain conditions must be 
met. 

 To enter intelligent mouse mode: 
• Choose Mouse > Intelligent. 
Intelligent Mouse Synchronization Conditions 

The Intelligent Mouse Synchronization command, available on the 
Mouse menu, automatically synchronizes mouse cursors during 
moments of inactivity. For this to work properly, however, the following 
conditions must be met: 

• The active desktop should be disabled on the target. 
• No windows should appear in the top left corner of the target page. 
• There should not be an animated background in the top left corner of 

the target page. 
• The target mouse cursor shape should be normal and not animated. 
• The target mouse speeds should not be set to very slow or very high 

values. 
• Advanced mouse properties such as “Enhanced pointer precision" or 

“Snap mouse to default button in dialogs” should be disabled. 
• Choose “Best Possible Video Mode” in the Video Settings window. 
• The edges of the target video should be clearly visible (that is, a 

black border should be visible between the target desktop and the 
remote KVM console window when you scroll to an edge of the 
target video image). 

• When using the intelligent mouse synchronization function, having a 
file icon or folder icon located in the upper left corner of your desktop 
may cause the function not to work properly. To be sure to avoid any 
problems with this function, Raritan recommends you do not have file 
icons or folder icons in the upper left corner of your desktop.  

After autosensing the target video, manually initiate mouse 
synchronization by clicking the Synchronize Mouse button on the toolbar. 
This also applies when the resolution of the target changes if the mouse 
cursors start to desync from each other. 

If intelligent mouse synchronization fails, this mode will revert to standard 
mouse synchronization behavior. 
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Please note that mouse configurations will vary on different target 
operating systems. Consult your OS guidelines for further details. Also 
note that intelligent mouse synchronization does not work with UNIX 
targets. 
 

Standard Mouse Mode 

Standard Mouse mode uses a standard mouse synchronization 
algorithm using relative mouse positions. Standard Mouse mode requires 
that mouse acceleration is disabled and other mouse parameters are set 
correctly in order for the client and server mouse to stay synchronized. 
Standard Mouse mode is the default. 

 To enter Standard Mouse mode: 
• Choose Mouse > Standard. 
 

Connection and Video Properties 

Dynamic video compression algorithms maintain KVM console usability 
under varying bandwidth constraints. The device optimizes KVM output 
not only for LAN use but also for WAN and dial-up use. These devices 
can also control color depth and limit video output, offering an optimal 
balance between video quality and system responsiveness for any 
bandwidth constraint. 

The parameters discussed in this section can be optimized in the 
Connection Properties dialog and Video Settings dialog. Connection 
properties are saved across subsequent connections to generation 2 
devices once they are set and saved.  
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MPC Connection Properties - Generation 1 Devices 

 To adjust connection properties: 
1. Choose Connection > Properties or click the Connection Properties 

button  in the toolbar. Update the settings in the Compression 
tab. 

 
2. Set the Connection Speed. 

Use this setting to manually adjust the connection speed to 
accommodate bandwidth constraints. Devices can automatically 
detect available bandwidth and not limit bandwidth use. However, 
you can also adjust this usage according to your needs. Depending 
on the Raritan device in use, different options may be available: 

 Auto Detect 

 1G Ethernet 

 100mb Ethernet 

 10mb Ethernet 

 1.5mb (Max DSL/T1) 

 1mb (Fast DSL/T1) 

 512 kb (Medium DSL/T1) 



Chapter 4: Multi-Platform Client and Raritan Remote Client 
 

106
 

 

 384 kb (Slow DSL/T1) 

 256 kb (Cable) 

 128 kb (Dual ISDN) 

 56 kb (ISP Modem) 

 33 kb (Fast Modem) 

 24 kb (Slow Modem) 

3. Set the Color Depth. 

Devices can dynamically adapt the color depth transmitted to remote 
users in order to maximize usability in all bandwidths. Select from 
among the options in the drop-down list. Depending on the Raritan 
device in use, different options may be available: 

 15-bit RGB Color 

 8-bit RGB Color 

 4-bit Color 

 4-bit Gray 

 3-bit Gray 

 2-bit Gray 

 Black and White 

Important: For most administrative tasks (server monitoring, 
reconfiguring, and so forth), administrators do not require the full 24-
bit or 32-bit color spectrum made available by most video graphics 
cards. Attempting to transmit such high color depths wastes network 
bandwidth. 

4. Selecting the Internet Flow Control checkbox ensures that packets 
transmitted by the device are received and reconstructed by the 
client application in the correct order. This is useful when using a 
device over an unpredictable public WAN (particularly in international 
scenarios). 

5. Use the slider to select the desired level of video Smoothing (15-bit 
mode only). The level determines how aggressively to blend page 
regions with small color variation into a single, smooth color. 
Smoothing improves the appearance of the target video by reducing 
the video noise that is displayed. 

6. Select "Frames per second". This setting instructs MPC on how often 
to redraw the video display of the target. This only affects the client 
display behavior and has no bearing on the data rate of the video 
being sent to the client. Setting this option higher makes the video 
appear smoother but also requires more processing power. 

7. Click OK to create the connection profile. 
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MPC Connection Properties - Generation 2 Devices 

 To adjust connection properties: 
1. Choose Connection > Properties or click the Connection Properties 

button  in the toolbar. Update the settings in the Compression 
tab. 

2. Set the Connection Speed. 

Use this setting to manually adjust the connection speed to 
accommodate bandwidth constraints. Devices can automatically 
detect available bandwidth and not limit bandwidth use. However, 
you can also adjust this usage according to your needs. Depending 
on the Raritan device in use, different options may be available: 

 Auto Detect 

 1G Ethernet 

 100mb Ethernet 

 10mb Ethernet 

 1.5mb (Max DSL/T1) 

 1mb (Fast DSL/T1) 

 512 kb (Medium DSL/T1) 

 384 kb (Slow DSL/T1) 

 256 kb (Cable) 

 128 kb (Dual ISDN) 

 56 kb (ISP Modem) 

 33 kb (Fast Modem) 

 24 kb (Slow Modem) 

Note: KX II-101 does not support 1G Ethernet. 

3. Set the Color Depth. 

Devices can dynamically adapt the color depth transmitted to remote 
users in order to maximize usability in all bandwidths. Select from 
among the options in the drop-down list. Depending on the Raritan 
device in use, different options may be available: 

 15-bit RGB Color 

 8-bit RGB Color 

 4-bit Color 

 4-bit Gray 

 3-bit Gray 
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 2-bit Gray 

 Black and White 

Important: For most administrative tasks (server monitoring, 
reconfiguring, and so forth), administrators do not require the full 24-
bit or 32-bit color spectrum made available by most video graphics 
cards. Attempting to transmit such high color depths wastes network 
bandwidth. 

4. Use the slider to select the desired level of video Smoothing (15-bit 
mode only). The level determines how aggressively to blend page 
regions with small color variation into a single, smooth color. 
Smoothing improves the appearance of the target video by reducing 
the video noise that is displayed. 

5. Click OK to create the connection profile. 
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RRC Connection Properties 

 To adjust connection properties: 
1. Choose Connection > Properties or click the Connection Properties 

button  in the toolbar. Update the settings in the Compression 
tab. 

 
2. Set the Connection Speed. 

Use this setting to manually adjust the connection speed to 
accommodate bandwidth constraints. Devices can automatically 
detect available bandwidth and not limit bandwidth use. However, 
you can also adjust this usage according to your needs. Depending 
on the Raritan device in use, different options may be available: 

 Auto Detect 

 1G Ethernet 

 100mb Ethernet 

 10mb Ethernet 

 1.5mb (Max DSL/T1) 

 1mb (Fast DSL/T1) 

 512 kb (Medium DSL/T1) 

 384 kb (Slow DSL/T1) 
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 256 kb (Cable) 

 128 kb (Dual ISDN) 

 56 kb (ISP Modem) 

 33 kb (Fast Modem) 

 24 kb (Slow Modem) 

3. Set the Color Depth. 

Devices can dynamically adapt the color depth transmitted to remote 
users in order to maximize usability in all bandwidths. Select from 
among the options in the drop-down list. Depending on the Raritan 
device in use, different options may be available: 

 15-bit RGB Color 

 8-bit RGB Color 

 4-bit Color 

 4-bit Gray 

 3-bit Gray 

 2-bit Gray 

 Black and White 

Important: For most administrative tasks (server monitoring, 
reconfiguring, and so forth), administrators do not require the full 24-
bit or 32-bit color spectrum made available by most video graphics 
cards. Attempting to transmit such high color depths wastes network 
bandwidth. 

4. Select Progressive Update to increase the usability in constrained 
bandwidth environments. When Progressive Update is enabled, the 
device initially sends an image of the remote desktop at lower color 
depths. Higher color depth images are provided as the bandwidth 
allows. 

Note: When Color Depth is set to Auto Select Color (default), 
Progressive Update is automatic. The device will enable/disable 
Progressive Update as required, disabling it for fast connections and 
enabling it for slow connections. 

5. Selecting the Internet Flow Control checkbox ensures that packets 
transmitted by the device are received and reconstructed by the 
client application in the correct order. This is useful when using a 
device over an unpredictable public WAN (particularly in international 
scenarios). 
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6. Use the slider to select the desired level of video Smoothing (15-bit 
mode only). The level determines how aggressively to blend page 
regions with small color variation into a single, smooth color. 
Smoothing improves the appearance of the target video by reducing 
the video noise that is displayed. 

7. Click OK to create the connection profile. 
 

Video Settings 

Video Settings - Generation 1 Devices 

Following are instructions on configuring video settings for Generation 1 
devices. These settings can be refreshed using the Color Calibration 
command by manually forcing a device to autodetect the video settings 
(on the Video menu, click Auto-sense Video Settings) or by changing the 
settings in this page. After you change a value, click Apply to test the 
setting. See Color Calibration (on page 116). 

 To configure Generation 1 devices: 
1. Choose Video > Video Settings or click the Video Settings button 

 in the toolbar to open the Settings dialog.  

2. Adjust the following settings as required: 

a. Noise Filter 

Devices can filter out the electrical interference of video output 
from graphics cards. This feature optimizes picture quality and 
reduces bandwidth. Higher settings transmit variant pixels only if 
a large color variation exists in comparison to the neighboring 
pixels. However, setting the threshold too high can result in the 
unintentional filtering of desired page changes. Lower settings 
transmit most pixel changes. Setting this threshold too low can 
result in higher bandwidth use. 

Note: The default Noise Filter is 4. Raritan recommends that you 
lower this value to 0 (zero). Although higher settings will stop the 
needless transmission of false color variations, true and intentional 
small changes to a video image may not be transmitted. 

b. PLL Settings 

If the video image looks extremely blurry or unfocused, the PLL 
settings for clock and phase can be adjusted until a better image 
appears on the active target server. 

Warning: Exercise caution when changing the clock and phase 
settings since doing so may result in lost or distorted video and you 
may not be able to return to the previous state. Contact Raritan 
Technical Support before making any changes. 
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 Clock - Controls how quickly video pixels are displayed across 
the video page. Changes made to clock settings cause the video 
image to stretch or shrink horizontally. Odd number settings are 
recommended. Under most circumstances this setting should not 
be changed because the autodetect is usually quite accurate. 

 Phase - Phase values range from 0 to 31 and will wrap around. 
Stop at the phase value that produces the best video image for 
the active target server. 

a. Color Settings -Gain control can be thought of as contrast 
adjustment. Offset control can be thought of as brightness 
adjustment. 

Select the Link Color Controls checkbox to make all slide 
adjusters move in unison when any one option is moved. 

 Red Gain - Controls the amplification of the red signal. 

 Red Offset - Controls the bias of the red signal. 

 Green Gain - Controls the amplification of the green signal. 

 Green Offset - Controls the bias of the green signal. 

 Blue Gain - Controls the amplification of the blue signal. 

 Blue Offset - Controls the bias of the blue signal. 

a. Color Settings - Gain control can be thought of as contrast 
adjustment. Offset control can be thought of as brightness 
adjustment. 

Select the Link Color Controls checkbox to make all slide 
adjusters move in unison when any one option is moved. 

 Red Gain - Controls the amplification of the red signal. 

 Red Offset - Controls the bias of the red signal. 

 Green Gain - Controls the amplification of the green signal. 

 Green Offset - Controls the bias of the green signal. 

 Blue Gain - Controls the amplification of the blue signal. 

 Blue Offset - Controls the bias of the blue signal. 

3. Select the video sensing mode: 

 Best possible video mode - Devices will perform the full Auto 
Sense process when switching targets or target resolutions. 
Selecting this option calibrates the video for the best image 
quality. 

 Quick sense video mode - Selecting this option will cause the 
device to use a quick video Auto Sense in order to show the 
target's video sooner. This option is especially useful for entering 
a target server's BIOS configuration right after a reboot. 
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4. Click OK to apply the settings and close the dialog. Click Apply to 
apply the settings without closing the dialog. 

Note: Some Sun background screens, such as screens with very dark 
borders, may not center precisely on certain Sun servers. Use a different 
background or place a lighter colored icon in the upper left corner of the 
page. 

 
 

Video Settings - Generation 2 Devices 

 To configure Generation 1 devices: 
1. Choose Video > Video Settings or click the Video Settings button 

 in the toolbar to open the Settings dialog.  

2. Adjust the following settings as required: 

a. Noise Filter 

Devices can filter out the electrical interference of video output 
from graphics cards. This feature optimizes picture quality and 
reduces bandwidth. Higher settings transmit variant pixels only if 
a large color variation exists in comparison to the neighboring 
pixels. However, setting the threshold too high can result in the 
unintentional filtering of desired page changes. Lower settings 
transmit most pixel changes. Setting this threshold too low can 
result in higher bandwidth use. 
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Note: The default Noise Filter is 4. Raritan recommends that you 
lower this value to 0 (zero). Although higher settings will stop the 
needless transmission of false color variations, true and intentional 
small changes to a video image may not be transmitted. 

b. PLL Settings 

If the video image looks extremely blurry or unfocused, the PLL 
settings for clock and phase can be adjusted until a better image 
appears on the active target server. 

Warning: Exercise caution when changing the clock and phase 
settings since doing so may result in lost or distorted video and you 
may not be able to return to the previous state. Contact Raritan 
Technical Support before making any changes. 

 Clock - Controls how quickly video pixels are displayed across 
the video page. Changes made to clock settings cause the video 
image to stretch or shrink horizontally. Odd number settings are 
recommended. Under most circumstances this setting should not 
be changed because the autodetect is usually quite accurate. 

 Phase - Phase values range from 0 to 31 and will wrap around. 
Stop at the phase value that produces the best video image for 
the active target server. 

a. Color Settings 

These settings control the brightness, contrast, and positioning of 
the target server display. Select the Link Color Controls checkbox 
to make all slide adjusters move in unison when any one option 
is moved. 

 Brightness Red - Controls the brightness of the red signal; range 
is 0 - 127. 

 Brightness Green - Controls the brightness of the green signal; 
range is 0 - 127. 

 Brightness Blue - Controls the brightness of the blue signal; 
range is 0 - 127. 

 Contrast Red - Controls the red signal contrast; range is 0 - 255. 

 Contrast Green - Controls the green signal contrast; range is 0 - 
255. 

 Contrast Blue - Controls the blue signal contrast; range is 0 - 
255. 

 Horizontal Offset - Controls the horizontal positioning of the 
target server display on your monitor; range is 0 - 512. 

 Vertical Offset - Controls the vertical positioning of the target 
server display on your monitor; range is 0 - 128. 
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8. Click OK to apply the settings and close the dialog. Click Apply to 
apply the settings without closing the dialog. 

 
 

Port Access Page Sort 

 To change the display sort order: 
• Click the column heading by which you want to sort. The list of KVM 

target servers is sorted by that column. 
 

Color Calibration 

Use the Color Calibration command if the color levels (hue, brightness, 
and saturation) of the transmitted video images do not seem accurate. 
The device color settings remain the same when switching from one 
target KVM server to another, so you can perform color calibration once 
to affect all connected target servers. 

1. Open a remote KVM connection to any server running a graphical 
user interface. 

2. Ensure that a solid white color covers approximately 15% or more of 
the target server's desktop. 
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Administrative Functions 

Although your device provides a remote interface to administrative 
functions through the device manager, the client provides an interface to 
frequently-used administrative functions directly from its own interface. 
When logged into a device as an administrator, you can perform the 
administrative tasks discussed here. 

Note: Most of the commands discussed here are available in both the 
Tools menu and in the shortcut menu that appears when you right-click 
the device in the Navigator panel. 
 

Note to MPC Users 

MPC assigns users one of two permissions: Administrator or User. You 
must belong to the Administrator group in order to receive administrative 
permissions. It is only when the user belongs to the Administrator group 
that they have access to backup, restore, and restart functions. This is 
true regardless of any device user group settings that may be applied to 
the user. 
 

General Options 

Configuring General Options in MPC for KSX II, KX II-101 and KX G1 

The Options available in the Tools menu allow you to customize scroll 
borders, mouse mode settings, Single Cursor mode, auto color 
calibration, hot key configuration, keyboard type, broadcast port, and 
logging.  

 To configure the general options in MPC: 
1. Choose Tools > Options. The Options dialog appears and displays 

the General tab by default. 

General Options 

2. Select the "Show scroll borders" checkbox to view the thin scroll 
borders designating the autoscroll area. 

3. Select the "Auto-Sync mouse in two-cursor mode" checkbox to 
enable automatic mouse synchronization. 

4. If you select the "Display single cursor mode instructions" checkbox, 
the Single Cursor Mode dialog will appear each time Single Cursor is 
enabled in the application. See Mouse Options (on page 100) for 
more information. 

5. Select the Automatic Color Calibration checkbox to enable automatic 
color calibration. This option is available for KX generation 1 (G1) 
only. 
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 Swedish (Sweden) 

 German (Switzerland) 

 Hungarian (Hungary) 

 Spanish (Spain) 

 Italian (Italy) 

 Slovenian 

6. From the Keyboard Shortcut Menu HotKey drop-down, select the key 
combination you would like to use to invoke the Shortcut Menu (on 
page 87).  

Advanced Options 

7. Select the Advanced tab to configure advanced options. 

8. From the KVM Switch OSUI Hot Key section, select the hot key to 
use when switching between target server displays. 

9. Enter the HTTPS port and Discovery Port.  

10. Select the Enable IPv6 Networking checkbox for IPv6 to enable IPv4 
and IPv6 dual-stack operation. 

11. Select the Enable Logging checkbox only if directed to by Technical 
Support. This option creates a log file in your home directory. 

Client Launch Settings 

12. Select the Client Launch Settings tab.  

a. To configure the target window settings: 

 Select 'Standard - sized to target Resolution' to open the window 
using the target's current resolution. If the target resolution is 
greater than the client resolution, the target window covers as 
much screen area as possible and scroll bars are added (if 
needed).  

 Select Full Screen to open the window in full screen mode. 

a. To configure the monitor on which the target viewer is launched:  

 Select 'Monitor Client Was Launched from' if you want the target 
viewer to be launched using the same display as the application 
that is being used on the client (for example, a web browser or 
applet).  

 Use Select From Detected Monitors to select from a list of target 
monitors that are currently detected by the application. If a 
previously selected monitor is no longer detected, 'Currently 
Selected Monitor Not Detected' is displayed. 

13. Click OK.  
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General Options in RRC 

The Options available in the Tools menu provide options that allow you 
to customize scroll borders, mouse mode settings, single cursor mode, 
auto color calibration, hot key configuration, keyboard type, broadcast 
port, and logging. 

 To configure the general options in RRC: 
1. In RRC, choose Tools > Options to open the Options dialog.  

 
2. Select the "Show scroll borders" checkbox to view the thin scroll 

borders that show the Auto-Scroll area. 

3. Select the "Auto-Sync mouse in two cursor mode" checkbox to 
enable Automatic Mouse Synchronization. 
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4. If you select the "Display single cursor mode instructions" checkbox 
the Single Cursor Mode dialog will open each time Single Cursor is 
enabled in the application (see Mouse Options (on page 100) for 
more information).  

5. Select Auto-Color Calibration to enable it. 

6. In the KVM Switch OSUI Hot Key panel, select the radio button next 
to the hot key combination you would like to use. 

7. In the Keyboard Type panel, click on the drop-down arrow and click 
on your keyboard choice. 

8. In the Broadcast Port panel, type the broadcast port number in the 
Port field. 

9. Click OK when finished. Click Apply any time during your selection to 
apply an option you have chosen. 

 
 

Upgrading Device Firmware 

 To update a device's firmware: 
1. Connect to the device by highlighting the device's icon in the 

Navigator. 

2. Click Tools > Update > Update Device to perform firmware 
upgrades. 

3. You will be prompted to locate a Raritan firmware distribution file 
(*.RFP format), which can be found on the Raritan website 
(www.raritan.com) on the Firmware Upgrades page.  

Ensure that you read all instructions included in Firmware Upgrade 
Guide carefully before upgrading a device. 

Note: Copy the firmware update file on the Raritan website to a local 
machine before uploading. Do not load the file from a network drive. 
 

Clearing ActiveX Controls 

After upgrading the device to a newer firmware version, if you still see 
the previous RRC version, please use the steps below to clear the 
ActiveX® cache. 

 To remove TeleControl class files: 
1. In Internet Explorer® 7, click Tools > Manage Addons > Enable or 

Disable Addons. 

2. Select "Download ActiveX control 32 bit" from the Show drop down. 
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3. Select TeleControl class and then click Delete. 

4. Close any open sessions of IE7.  

5. Open a new IE7 session and go to Raritan's website to download the 
newest version of RRC. 

 

Changing a Password 

 To update your password 
1. Connect to a target by selecting it in the Navigator.  

2. Highlight the target's icon in the Navigator and then choose Tools > 
Update > User Password. The Change Password dialog appears. 

 
3. Type your current password in the Old Password field. 

4. Type the new password in the New Password field.  

5. Retype the password in the Confirm New Password field. 

6. When finished, click OK. 
 

Restarting a Device 

 To restart a device: 
1. Select the device in the Navigator.  

2. On the Tools menu, choose Restart Device. 
 

Backup and Restore Functions 

In addition to using backup and restore for business continuity purposes, 
you can use this feature as a time-saving mechanism. For instance, you 
can quickly provide access from another Dominion device to your team 
by backing up the user configuration settings from the device in use and 
restoring those configurations to the new Dominion device. 
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Backing Up and Restoring an Entire System (Dominion KX II only) 

 To backup the entire system (both user and device 
configuration): 

1. Choose Tools > Backup All. The Backup All dialog appears. 

 
2. Navigate to the desired directory and give the backup file a name. 

(Backup files have an extension of .rfp). 

3. Click Save. A message is displayed confirming the successful 
backup. 

4. Click OK. 
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Note: Backups are always complete system backups. Restores can be 
complete or partial depending on your selection. 

 To restore: 
1. Choose Tools > Restore Configuration. The Restore Device 

Configuration dialog appears. 

 
2. Navigate to the appropriate directory and select the backup file. 

3. Click Open. The Restore Packages dialog appears. 

4. Select the type of restore you want to run: 

a. Full Restore - A complete restore of the entire system; generally 
used for traditional backup and restore purposes. 

b. Protected Restore - Everything is restored except device-specific 
information such as serial number, MAC Address, IP Address, 
name, port names, etc. With this option, you can setup one 
Dominion device and copy the configuration to multiple Dominion 
devices. 

c. Custom Restore - The following options are available: 

 User and Group Restore - This option includes only user and 
group information. Use this option to quickly setup users on a 
different Dominion device. This option restores the certificate and 
the private key file that were currently active when the backup 
occurred. 
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 Device Settings Restore - This option includes only device 
settings such as power associations, USB profiles, blade chassis 
related configuration parameters, and Port Group assignments. 
Use this option to quickly copy the device information. 

5. Click OK. 
 

Backing Up and Restoring a Device Configuration 

 To back up a device: 
1. Download the device configuration to your local computer by 

selecting the device in the Navigator.  

2. Click Tools > Save Device Configuration. 

 To restore a device configuration: 
1. Upload the archived device configuration by selecting the device in 

the Navigator.  

2. Click Tools > Restore Device Configuration. 

Note that device configuration is specific to a particular device and 
should not be restored to another device. 

 

Backing Up and Restoring a User Configuration 

 To back up a device's user configuration: 
1. Select the device in the Navigator.  

2. Click Tools > Save User Configuration. 

 To restore a user configuration: 
1. Upload a device's archived user configuration by selecting the device 

in the Navigator.  

2. Click Tools > Restore User Configuration. 

Note: Use these commands to easily transfer user and group information 
from one device to another. 
 

Log Files 

Activity Log 

 To download a detailed activity log for review or 
troubleshooting: 

1. Select the device in the Navigator.  
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2. On the Tools menu, choose Save Activity Log. 
 

Diagnostic Log (excluding KX II) 

 To download a detailed diagnostic log for reporting or analysis: 
1. Select the device in the Navigator.  

2. On the Tools menu, choose Save Diagnostic Log. 
 

Broadcast Port 

By default, all Raritan devices send data through Port 5000. This network 
traffic includes the autodiscovery broadcast. In the case of conflicts or to 
deal with firewall issues, you may want to use a different broadcast port.  
 

MPC Broadcast Port 

 To change the autodiscovery port from the default broadcast 
port of 5000:  

1. Select the device in the Navigator.  

2. Choose Tools > Options. The Options dialog appears. 

3. On the Advanced tab, type the new port number in the HTTPS Port 
or Discovery Port field.  

4. Click OK. 

Note: If you want the application to autodiscover Raritan devices on the 
new broadcast port you entered in the Options dialog, you must 
configure all Raritan devices to use the new port number. 
 

RRC Broadcast Port 

 To change the autodiscovery port from the default broadcast 
port of 5000:  

1. Select the device in the Navigator.  

2. On the Tools menu, choose Options. The Options dialog appears. 

3. In the Broadcast Port field, type the new port number in the Port field 
and then click OK. 
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Note: If you want the application to autodiscover Raritan devices on the 
new broadcast port you entered in the Options window, you must 
configure all Raritan devices to use the new port number. 

 

If you do not want to use the broadcasting function at all, it can be turned 
off. 

 To turn off broadcasting: 
1. In RRC, select View > Show. 

2. Deselect the Discovered Devices checkbox. 
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Broadcasting will be turned off and the devices will not be displayed 
in the navigator. 

 
 

Remote Power Management 

AC power to associated targets can be managed when used with a 
properly configured Raritan Remote Power Control Strip (RPC strip). 
Three options are available when performing remote target power 
management:  

• Power On 
• Power Off 
• Cycle Power 

 To change the power status of a target: 
1. Select the device in the Navigator.  

2. On the Tools menu, choose Power On, Power Off, or Cycle Power. 
 

Import/Export Keyboard Macro Definitions 

The functions contained in this section describe how to exchange 
keyboard macro definitions between users using import and export 
functions. The primary purpose of this function is to exchange data 
between copies of the client application. 
 

Import/Export MPC Keyboard Macros 

 To import MPC macros: 
1. Choose Tools > Import Macros to open the Import Macros dialog. By 

default, the macro will exist on the desktop. 

2. Click on the macro file and click Open to import the macro.  

a. If too many macros are found in the file, an error message will be 
displayed and the import will terminate once OK is selected. 

b. If the import fails, an error dialog will appear and will display a 
message regarding why the import failed. Select OK to continue 
the import without importing the macros that cannot be imported. 
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3. Select the macros to be imported by checking their corresponding 
checkbox or using the Select All or Deselect All options. 

4. Click OK and the import will begin. 

a. If a duplicate macro is found, the Import Macros dialog will 
appear. Do one of the following: 

 Click Yes to replace the existing macro with the imported 
version. 

 Click Yes to All to replace the currently selected and any 
other duplicate macros that are found. 

 Click No to keep the original macro and proceed to the next 
macro 

 Click No to All keep the original macro and proceed to the 
next macro. Any other duplicates that are found will be 
skipped as well. 

 Click Cancel to stop the import.  

 Alternatively, click Rename to rename the macro and import 
it. If Rename is selected, the Rename Macro dialog will 
appear. Enter a new name for the macro in the field and click 
OK. The dialog will close and the process will proceed. If the 
name that is entered is a duplicate of a macro, an alert will 
appear and you will be required to enter another name for 
the macro. 

b. If during the import process the number of allowed, imported 
macros is exceeded, a dialog will appear. Click OK to attempt to 
continue importing macros or click Cancel to stop the import 
process. 
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The macros will then be imported. If a macro is imported that contains a 
hot key that already exists, the hot key for the imported macro will be 
discarded.  

 To export MPC macros: 
1. Choose Tools > Export Macros to open the Select Keyboard Macros 

to Export dialog. 

 
2. Select the macros to be exported by checking their corresponding 

checkbox or using the Select All or Deselect All options.  

3. Click OK. The selected macro file(s) will be moved to your desktop 
(by default). 

A dialog from which you can locate and select the macro file will then 
appear. By default, the macro will exist on your desktop.  
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4. Locate the macro file, click it to select it and then click Save. If the 
macro already exists, you will receive an alert message. Select Yes 
to overwrite the existing macro or No to close the alert without 
overwriting the macro. 

 
 

Import/Export RRC Keyboard Macros 

 To export RRC macros: 
1. Choose Tools > Export Macros to open the Export Macros dialog. 

 
2. Select the macros to be exported by checking their corresponding 

checkbox or using the Select All or Unselect All options.  

3. Click OK. The selected macro file(s) will be moved to your desktop 
(by default). 

A select dialog from which you can locate and select the macro file 
will then appear. By default, the macro will exist on your desktop.  
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4. Locate the macro file, click on it to select it and then click Save. If the 
macro already exists, you will receive an alert message. Select Yes 
to overwrite the existing macro or No to close the alert without 
overwriting the macro. 

 

 To import RRC macros: 
1. Choose Tools > Import Macros to open the Import Macros dialog. By 

default, the macro will exist on the desktop. 

 
2. Click on the macro file and click Open to import the macro.  
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a. If too many macros are found in the file, an error message will be 
displayed and the import will terminate once OK is selected. 

 
b. If the import fails, an error dialog will open and will display a 

message regarding why the import failed. Select OK to continue 
the import without importing the macros that cannot be imported. 

 
3. Select the macros to be imported by checking their corresponding 

checkbox or using the Select All or Unselect All options.  

4. Click OK and the import will begin. 

 
a. If a duplicate macro is found, a dialog will appear. Do one of the 

following: 
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 Click Yes to replace the existing macro with the imported 
version. 

 Click Yes to All to replace the currently selected and any 
other duplicate macros that are found. 

 Click No to keep the original macro and proceed to the next 
macro 

 Click No to All keep the original macro and proceed to the 
next macro. Any other duplicates that are found will be 
skipped as well. 

 Click Cancel to stop the import.  

 
 Alternatively, click Rename to rename the macro and import 

it. If Rename is selected, Raritan Remote Client Rename 
Macro dialog will open. Enter a new name for the macro in 
the field and click OK. The dialog will close and the process 
will proceed. If the name that is entered is a duplicate of a 
macro, an alert will appear and you will be required to enter 
another name for the macro. 
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b. If during the import process the number of allowed, imported 
macros is exceeded, a message will appear. Click OK to attempt 
to continue importing macros or click Cancel to stop the import 
process. 

 
The macros will then be imported. If a macro is imported that 
contains a hot key that already exists, the hot key for the imported 
macro will be discarded.  
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Accessing the MPC Diagnostic Interface (excluding KX II) 

 To access a device's diagnostic console: 
• In the Navigator, scroll through the list of the targets associated with 

the device and then double-click the Diagnostic icon at the bottom of 
the target list. 
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Prerequisites for Using Virtual Media 

With the virtual media feature, you can mount up to two drives (of 
different types) that are supported by the USB profile currently applied to 
the target. These drives are accessible for the duration of the KVM 
session. 

For example, you can mount a specific CD-ROM, use it, and then 
disconnect it when you are done. The CD-ROM virtual media “channel” 
will remain open, however, so that you can virtually mount another CD-
ROM. These virtual media “channels” remain open until the KVM session 
is closed as long as the USB profile supports it. 

To use virtual media, connect/attach the media to the client or network 
file server that you want to access from the target server. This need not 
be the first step, but it must be done prior to attempting to access this 
media. 

The following conditions must be met in order to use virtual media:  

Dominion Device 
• For users requiring access to virtual media, the device permissions 

must be set to allow access to the relevant ports, as well as virtual 
media access (VM Access port permission) for those ports. Port 
permissions are set at the group-level. 

• A USB connection must exist between the device and the target 
server. 

• If you want to use PC-Share, Security Settings must also be enabled 
in the Security Settings page. Optional  

• You must choose the correct USB profile for the KVM target server 
you are connecting to.  

Client PC 
• Certain virtual media options require administrative privileges on the 

client PC (for example, drive redirection of complete drives). 

Note: If you are using Microsoft Vista or Windows 7, disable User 
Account Control or select Run as Administrator when starting 
Internet Explorer. To do this, click the Start Menu, locate IE, right-
click and select Run as Administrator. 

Target Server 
• KVM target servers must support USB connected drives. 
• KVM target servers running Windows 2000 must have all of the 

recent patches installed. 
• USB 2.0 ports are both faster and preferred. 
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Using Virtual Media via VKC and AKC in a Windows Environment 

Windows XP® operating system Administrator and standard user 
privileges vary from those of the Windows Vista® operating system and 
the  Windows 7® operating system.  

When enabled in Vista or Windows 7, User Access Control (UAC) will 
provide the lowest level of rights and privileges a user needs for an 
application. For example, a Run as Administrator option is provided for 
Internet Explorer® form Administrator level tasks, otherwise these will not 
be accessible even though the user has an Administrator login.   

Both of these features affect the types of virtual media that can be 
accessed by users via Virtual KVM Client (VKC) and Active KVM Client 
(AKC). See your Microsoft® help for additional information on these 
features and how to use them. 

Following is a list virtual media types users can access via VKC and AKC 
when running in a Windows environment. The features are broken down 
by client and the virtual media features that are accessible to each 
Windows user role. 

Windows XP 
• If you are running VKC and AKC in a Windows XP environment, 

users must have Administrator privileges to access any virtual media 
type other than CD-ROM connections, ISOs and ISO images. 

Windows Vista and Windows 7 
• If you are running VKC and AKC in a Windows Vista or Windows 7 

environment and UAC is enabled, the following virtual media types 
can be accessed depending on the Windows role of the user: 

Client Administrator Standard User 
AKC and 
VKC  

Access to: 

• Fixed drives and fixed 
drive partitions 

• Removable drives 
• CD/DVD drives 
• ISO images 
• Remote ISO images 

Access to: 

• Removable drives 
• CD/DVD drives 
• ISO images 
• Remote ISO images 
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Using Virtual Media 

See Prerequisites for Using Virtual Media (on page 143) before 
proceeding with using virtual media. 

 To use virtual media: 
1. If you plan to access file server ISO images, identify those file 

servers and images through the Remote Console File Server Setup 
page. See File Server Setup (File Server ISO Images Only) (on 
page 146). 

Note: ISO9660 format is the standard supported by Raritan. 
However, other CD-ROM extensions may also work. 

2. Open a KVM session with the appropriate target server. 

a. Open the Port Access page from the Remote Console. 

b. Connect to the target server from the Port Access page: 

 Click the Port Name for the appropriate server. 

 Choose the Connect command from the Port Action menu. The 
target server opens in a Virtual KVM Client window. 

3. Connect to the virtual media. 

For: Select this VM option: 
Local drives Local Drives 

Local CD/DVD drives CD-ROM/DVD-ROM/ISO Images 

ISO Images Connect CD-ROM/ISO Image 

File Server ISO Images Connect CD-ROM/ISO Image 

Upon completion of your tasks, disconnect the virtual media. See 
Disconnecting Virtual Media (on page 150). 
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File Server Setup (File Server ISO Images Only) 

Note: This feature is only required when using virtual media to access file 
server ISO images. 

ISO9660 format is the standard supported by Raritan. However, other 
CD-ROM extensions may also work. 

Use the Remote Console File Server Setup page to designate the files 
server(s) and image paths that you want to access using virtual media. 
File server ISO image(s) specified here will become available for 
selection in the Remote Server ISO Image Hostname and Image drop-
down lists in the Map Virtual Media CD/ISO Image dialog. See CD-
ROM/DVD-ROM/ISO Images (on page 148). 

 To designate file server ISO images for virtual media access: 
1. Choose Virtual Media from the Remote Console. The File Server 

Setup page opens. 

2. Check the Selected checkbox for all media that you want accessible 
as virtual media. 

3. Enter information about the file server ISO images that you want to 
access: 

 IP Address/Host Name - Host name or IP address of the file 
server. 

 Image Path - Full path name of the location of the ISO image. 

Note: The host name cannot exceed 232 characters in length. 

4. Click Save. All media specified here will now be available for 
selection in the Map Virtual Media CD/ISO Image dialog. 
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Connecting to Virtual Media 

Local Drives 

This option mounts an entire drive, which means the entire disk drive is 
mounted virtually onto the target server. Use this option for hard drives 
and external drives only. It does not include network drives, CD-ROM, or 
DVD-ROM drives. This is the only option for which Read/Write is 
available. 

Note: KVM target servers running certain versions of the Windows 
operating system may not accept new mass storage connections after an 
NTFS-formatted partition (for example, the local C drive) has been 
redirected to them.  

If this occurs, close the Remote Console and reconnect before 
redirecting another virtual media device. If other users are connected to 
the same target server, they must also close their connections to the 
target server. 

Note: In the Dominion KX II 2.1.0 and above, when you mount an 
external drive, such as a floppy drive, the LED light on the drive will 
remain on because the device is checking the drive every 500 
milliseconds to verify the drive is still mounted.  

 To access a drive on the client computer: 
1. From the Virtual KVM Client, choose Virtual Media > Connect Drive. 

The Map Virtual Media Drive dialog appears. 

 
2. Choose the drive from the Local Drive drop-down list. 

3. If you want Read and Write capabilities, select the Read-Write 
checkbox. This option is disabled for nonremovable drives. See the 
Conditions when Read/Write is Not Available (on page 148) for 
more information. When checked, you will be able to read or write to 
the connected USB disk. 
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WARNING: Enabling Read/Write access can be dangerous! 
Simultaneous access to the same drive from more than one entity 
can result in data corruption. If you do not require Write access, 
leave this option unselected. 

4. Click Connect. The media will be mounted on the target server 
virtually. You can access the media just like any other drive. 

 

Conditions when Read/Write is Not Available 

Virtual media Read/Write is not available in the following situations: 

• For all hard drives. 
• When the drive is write-protected. 
• When the user does not have Read/Write permission: 

 Port Permission Access is set to None or View. 

 Port Permission VM Access is set to Read-Only or Deny. 
 

CD-ROM/DVD-ROM/ISO Images 

This option mounts CD-ROM, DVD-ROM, and ISO images. 

Note: ISO9660 format is the standard supported by Raritan. However, 
other CD-ROM extensions may also work. 

 To access a CD-ROM, DVD-ROM, or ISO image: 
1. From the Virtual KVM Client, choose Virtual Media > Connect CD-

ROM/ISO Image. The Map Virtual Media CD/ISO Image dialog 
appears. 
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2. For internal and external CD-ROM or DVD-ROM drives: 

a. Choose the Local CD/DVD Drive option. 

b. Choose the drive from the Local CD/DVD Drive drop-down list. 
All available internal and external CD and DVD drive names will 
be populated in the drop-down list. 

c. Click Connect. 

3. For ISO images: 

a. Choose the ISO Image option. Use this option when you want to 
access a disk image of a CD, DVD, or hard drive. ISO format is 
the only format supported. 

b. Click the Browse button. 

c. Navigate to the path containing the disk image you want to use 
and click Open. The path is populated in the Image Path field. 

d. Click Connect. 

4. For remote ISO images on a file server: 

a. Choose the Remote Server ISO Image option. 

b. Choose Hostname and Image from the drop-down list. The file 
servers and image paths available are those that you configured 
using the File Server Setup page. Only items you configured 
using the File Server Setup page will be in the drop-down list.  

c. File Server Username - User name required for access to the file 
server. 

d. File Server Password - Password required for access to the file 
server (field is masked as you type). 

e. Click Connect. 

The media will be mounted on the target server virtually. You can 
access the media just like any other drive. 

Note: If you are working with files on a Linux target, use the Linux Sync 
command after the files are copied using virtual media in order to view 
the copied files. Files may not appear until a sync is performed.  

Note: If you are working with Windows 7, Removable Disk is not 
displayed by default in the Window's My Computer folder when you 
mount a Local CD/DVD Drive or Local or Remote ISO Image. To view 
the Local CD/DVD Drive or Local or Remote ISO Image in this folder, 
select Tools > Folder Options > View and deselect "Hide empty drives in 
the Computer folder". 

Note: You cannot access a remote ISO image via virtual media using an 
IPv6 address due to technical limitations of third-party software used by 
the KX2. 
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Disconnecting Virtual Media 

 To disconnect the virtual media drives: 
• For local drives, choose Virtual Media > Disconnect Drive. 
• For CD-ROM, DVD-ROM, and ISO images, choose Virtual Media > 

Disconnect CD-ROM/ISO Image. 

Note: In addition to disconnecting the virtual media using the Disconnect 
command, simply closing the KVM connection closes the virtual media 
as well. 
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The standalone Raritan Serial Console (RSC) is used to make direct 
connections to a serial target without going through the device. The user 
specifies the device address and the port number (target), and is then 
connected. 

In This Chapter 
RSC System Requirements...................................................................151 
Installing RSC on Windows ...................................................................156 
Installing RSC for Sun Solaris and Linux ..............................................158 
Opening RSC from the Remote Console ..............................................159 
Raritan Serial Console Interface ...........................................................161 
 
 

RSC System Requirements 

The following requirements must be met to support the Raritan Serial 
Console: 

• The RSC will function with JRE™ version 1.4.2_05 or later (except for 
JRE version 1.5.0_02). However, for optimum performance, Raritan 
recommends using JRE 1.5.0 (except for version 1.5.0_02). 

• Your system may require configuration adjustments depending on 
the operating system and browser. The JRE provides configuration 
instructions with the JRE download. Browse to the page at 
http://www.java.com/en/download/help/testvm.xml 
(http://www.java.com/en/download/help/testvm.xml \o 
http://www.java.com/en/download/help/testvm.xml) to determine 
the JRE version currently installed on your system. If you do not 
have a compatible version of the JRE, go to http://www.java.com 
(http://www.java.com) and click the Download Now button. 

Note: Raritan does not support JRE version 1.5.0_02 for use with the 
RSC. 

• Minimum 1 GHz PC with 512 MB RAM. 

Ensure that Java™ can be started from the command line. To do this, 
environment variables must be configured. Make a note of the exact path 
where Java was installed. (The path information will be used later.) 

IMPORTANT: When launching RSC from a browser, Raritan highly 
recommends that Java Applet Caching be disabled and that you 
perform the following steps to make sure that Java does not create 
problems for the system's memory. 
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Setting Windows OS Variables 
1. Choose Start > Control Panel > System. 

2. Click the Advanced tab and then click Environment Variables. 

 
3. In the System variables section, click New. 



 Chapter 6: Raritan Serial Console  

 
153

 

4. In the New System Variable dialog, add JAVA_HOME to the Variable 
name block and the path you wrote down earlier in the Variable 
value block. 

 
5. Click OK. 

6. Select the PATH variable and click Edit. 

7. Add %JAVA_HOME%\bin to the end of the current Variable value. 
Ensure a semicolon (;) separates the new value from the last value 
in the string. 
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8. Click OK. 

 
9. Select the CLASSPATH variable and click Edit. 

10. Ensure the CLASSPATH Variable value is configured properly; that 
is, its value must have a period (.) in it. If, for any reason, there is no 
CLASSPATH variable defined, create one. 
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Setting Linux OS Variables 

To set Java™ for a specific user, open and edit the .profile file located in 
the /home/Username folder. 

To set Java for all users, open the .profile file in your /etc folder: 

1. Find the line where you set your path: 

export  

PATH=$PATH:/home/username/somefolder 

2. Before that line you must set your JAVA_HOME and then modify 
your PATH to include it by adding the following lines: 

export  
JAVA_HOME=/home/username/j2sdk1.4.2/ 
export PATH=$PATH:$JAVA_HOME/bin 

3. Save the file. 
 

Setting UNIX OS Variables 

To check the latest JRE™ version on Sun Solaris™: 

1. Launch a terminal window on the Sun Solaris desktop. 

2. Type java -version in the command line and press Enter. The 
currently-installed version of Java™ Runtime Environment (JRE) 
appears. 

 If your path variable is not set to where the Java binaries have 
been installed, you may not be able to see the JRE version. 

 Assuming JRE 1.4.2_05 is installed in /usr/local/java: you must 
set your PATH variable. 

 To set a path for the bash shell: 

export  

PATH=$PATH:/usr/local/java/j2re1.4.2_05/bin 

 To set path for tcsh or csh: 

set  

PATH = ($PATH /usr/local/java/j2re1.4.2_05/bin) 
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 These commands can either be typed at the terminal each time 
you log in, or you can add them to your .bashrc for bash shell or 
.cshrc for csh and tcsh so that each time you log in, the path is 
already set. See your shell documentation if you encounter 
problems. 

 
3. If the JRE is version 1.4.2_05 or later, proceed with the RSC 

installation. If the JRE is version 1.5.0_02 or is an older version than 
1.4.2_05, go to the Sun website at (http://java.sun.com/products/) to 
download the latest Runtime Environment. 

 

Installing RSC on Windows 

You must have administrative privileges to install RSC. 

 To install RSC on a Windows® operating system: 
1. Log on to a Windows machine. 

2. Download, or copy from a known location, the RSC-installer.jar 
installation file. 

3. Double-click the executable file to start the installer program. The 
splash page appears. 

4. Click Next. The installation path page appears. 

5. Change the path, if desired. 

6. Click Next. The installation progress page appears. 
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Note: The standalone version of Raritan Serial Console (RSC) is 
available from the Raritan website (www.raritan.com) on the Support 
page. 
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7. Click Next. The Windows shortcut page appears. 

 
8. Specify the desired Program Group for the shortcut. 

9. Click Next. The installation finished page appears. 

10. Click Done. 
 

Installing RSC for Sun Solaris and Linux 

You must have administrative privileges to install RSC. 

1. Log in to your Sun Solaris™ machine. 

2. Download, or copy from a known location, the RSC-installer.jar 
installation file. 

3. Open a terminal window and change to the directory where the 
installer is saved. 

4. Type java -jar RSC-installer.jar and press Enter to run the installer. 

5. Click Next after the initial page loads. The Set Installation Path page 
opens. 

a. Select the directory where you want to install RSC and click 
Next. 

b. Click Browse to navigate to a non-default directory. 



 Chapter 6: Raritan Serial Console  

 
159

 

c. Click Next when the installation is complete. 

d. Click Next again. The installation is complete. The final page 
indicates where you will find an uninstaller program and provides 
the option to generate an automatic installation script. 

6. Click Done to close the Installation dialog. 
 

Opening RSC from the Remote Console 

 To open the Raritan Serial Console (RSC) from the Remote 
Console: 

1. Select the Port Access tab. 

 
2. Click the name of the serial port you want to access for the RSC. 

Note: A security pop-up screen appears only if you used https to 
connect to the RSC. 

3. If you're using Dominion DSX: 

 Click Yes. A Warning - Security pop-up screen appears. 

 Click Yes to access the Raritan Serial Console from the Port 
page. 

Note: If you click Always, you will not receive the security page for 
future access. 

 The Raritan Serial Console window appears.  

If you're using Dominion KSX or KX:  

 Click Connect to start connecting to the target port for RSC, and 
the Raritan Serial Console window appears. 

 The Raritan Serial Console window appears. 
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Note: You can download the standalone Raritan Serial Console from the 
Raritan website (www.raritan.com) on the Support page.  

 To open RSC from the Windows® desktop: 
1. Double-click the shortcut or use the Start menu to open the 

standalone RSC. The Raritan Serial Console Login connection 
properties window appears. 

2. Enter the device's IP address, account information, and the desired 
target (port). 

3. Click Start. RSC opens with a connection to the port. 

Note: If you experience unrecognized characters or blurry pages in the 
RSC window due to localization support, try changing the font to Courier 
New. Click Emulator > Settings > Display and select Courier New for 
Terminal Font Properties or GUI Font Properties. 

Note: When RSC connects to a serial target, hitting Ctrl + _ or Ctrl + ^ + 
_ does not cause information to be sent. However, hitting the Ctrl + Shift 
+ _ or the Ctrl + Shift + ^ will cause information to be sent.  

 To open RSC on Sun Solaris™: 
1. Open a terminal window and change to the directory where you 

installed the RSC. 

2. Type ./start.sh and press Enter to open RSC. 

3. Double-click the desired device to establish a connection. 

4. Type your user name and password. 

5. Click OK to log on. 
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Raritan Serial Console Interface 

Important: The Raritan Serial Console page usually opens in a 
separate window behind the Port page. With some versions of 
Java™ on the Windows® operating system, the page opens in front 
of the Port page. 

 
 

Default RSC Option Values 

The following default values apply to the GUI font properties, colors and 
fonts defined in RSC: 
 

Item Value 
Font properties Lucida Console 

GUI font properties Lucida Console 
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Item Value 
Colors Black foreground and white 

background 

 
 

Emulator 
1. Change the default user Idle Timeout setting before launching the 

RSC for the first time or it will timeout in 10 minutes and display a 
host termination message.  

2. Click the Emulator drop-down menu to display a list of topics. 
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Settings 
1. Choose Emulator > Settings. The Settings page displays the General 

tab with the default settings. 

 
2. Accept the Main Menu Shortcut default of None or choose one of the 

following from the Main Menu Shortcut drop-down menu: 

 F10 

 Alt 

3. Accept the Show Confirmation Dialog on Exit default or uncheck it. 

4. Accept the Terminal Size default or choose a size from the Terminal 
Size drop-down menu. 

5. Accept the Backspace Sends default of ASCII DEL or choose 
Control-H from the Backspace Sends drop-down menu. 

6. Accept the History Buffer Size default of 75 or use the arrows to 
change the buffer size. 
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7. Accept the Cursor type default of Block Cursor or select Line Cursor. 

8. Click OK. 

Display Settings 
1. Choose Emulator > Settings, and then click the Display tab. 

 
2. Click Default to accept the Default settings. Then click Ok to close 

the Display Settings dialog. However, if you want to change the 
settings, perform the following steps: 

3. Accept the Terminal Font Properties default of Lucida Console or 
choose a font from the scrolling list of Terminal Font Properties. 

4. If you want to change the size of the font, choose a font size by 
clicking the up or down arrows. The result of selected font and font 
size is displayed in the Preview box. 
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5. Click the GUI Font Properties tab and accept the default of Lucida 
Console or choose a font from the scrolling list of GUI Font 
Properties. 

 

Note: For Simplified Chinese characters, Raritan Serial Console 
supports EUC-CN encoding system.  

6. Choose the following from their drop-down menus: 

 Foreground Color 

 Background Color 

7. Choose one of the following from the Encoding drop-down menu: 

 US-ASCII 

 ISO-8859-1 

 ISO-8859-15 

 UTF-8 
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 Shift-JIS 

 EUC-JP 

 EUC-CN 

 EUC-KR 

8. Choose one of the following from the Language drop-down menu: 

 English 

 Bulgarian 

 Japanese 

 Korean 

 Chinese 

9. Click Ok to close the Display Settings dialog. If you changed the 
Language setting, the RSC changes to that language when the 
Display Settings dialog is closed. 
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Note: If you experience unrecognized characters or blurry pages in the 
RSC window due to localization support, try changing the font to Courier 
New.  

Get History 

History information can be useful when debugging, troubleshooting, or 
administering a target device. The Get History feature allows you to view 
the recent history of console sessions by displaying the console 
messages to and from the target device. 

When the size limit is reached, the text will wrap, overwriting the oldest 
data with the newest. 

Note: The history data is displayed only to the user who requested the 
history. 

• To view the session history, choose Emulator > Get History. 

Clear History 
• To clear the history, choose Emulator > Clear History. 

Get Write Access 

Only administrators and operators can get Write access. The user with 
Write access can send commands to the target device. Write access can 
be transferred among users working in the Raritan Serial Console via the 
Get Write Access command. 

To enable Write access, choose Emulator > Write Access. 

• You now have Write access to the target device. 
• When another user assumes Write access from you, 

 The RSC displays a red block before Write access in the status 
bar. 

 A message alerting the user who currently has Write access 
appears to tell that user that another user has taken over access 
to the console. 
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Get Write Lock 
• Choose Emulator > Get Write Lock. If the Get Write Lock is not 

available, a request rejected message appears. 

Write Unlock 
• Choose Emulator > Write Unlock. 

Send Break 

Some target systems, such as Sun Solaris™ servers, require the 
transmission of a null character (break) to generate the OK prompt. This 
is equivalent to issuing a STOP-A from the Sun keyboard. 

• Only users with Administrator privileges can send a break. 
• Users who are Operator or Observers cannot send a break. 

 To send an intentional break to a Sun Solaris server: 
1. Verify that you have Write access. If not, follow the instructions in the 

previous section to obtain Write access. 

2. Choose Emulator > Send Break. A Send Break Ack 
(Acknowledgement) pop-up appears. 

3. Click OK. 
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Connected Users 

The Connected Users command allows you to view a list of other users 
who are currently connected on the same port. 

1. Choose Emulator > Connected Users, a Connected Users page is 
displayed. 

 
2. A check mark appears in the Write access column after the name of 

the user who has Write access to the console. 

3. Click Close to close the Connected Users window. 

Exit 
1. Choose Emulator > Exit to close the Raritan Serial Console. The Exit 

Confirmation page appears. 

2. Click Yes. 
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Edit 

Use the Copy, Paste, and Select All text commands to relocate and/or 
re-use important text. 

 

 To copy and paste all text: 
1. Choose Edit > Select All. 

2. Choose Edit > Copy. 

3. Position the cursor at the location where you want to paste the text. 

4. Click once to make that location active. 

5. Choose Edit > Paste. 
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Note: The copy-paste limit of text in Raritan Serial Console is 9999 lines. 

Keyboard shortcuts that you can use to highlight, copy, and paste all or 
partial lines of text: 

• Click and drag your mouse over the text you wish to copy. 
• Use Ctrl+C to copy text. 
• Position the cursor where you want to paste the text and click in that 

location to make it active. 
• Use Ctrl+V to paste text. 
 

Tools 

Click the Tools menu to display a list of topics. 
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Start Logging 

The Start Logging function allows you to collect raw console data from 
the target device and save it to a file on your computer. When you start 
RSC, the Logging indicator on the status bar indicates whether logging is 
on or off. 

1. Choose Tools > Start Logging. 

2. Choose an existing file or provide a new file name in the Save RSC 
Log dialog. 

 When an existing file is selected for logging, data gets appended 
to the contents. 

 If you provide a new file name, a new file is created. 

 
3. Click Save after selecting or creating a file. 
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Stop Logging 

Choose Tools > Stop Logging. The logging stops. 

Send Keystroke 

1. Choose Tools > Send Keystroke. A Send Keystroke dialog appears: 

 
2. Enter the keystroke combinations that you want and select a Key 

Code name from the drop-down menu. 

3. Send the keystroke combinations. 

Send Text File 

1. Choose Tools > Send Text File. A Send Text File screen appears. 

2. Open the directory of the Text file. 

3. Click on or enter the File Name of the Text file. 

4. Click Open. 

 When you click Open, it sends whatever file you selected directly 
to the port. 

 If there is a loopback plug inserted, you will see the file displayed. 

 If there is currently no target connected, then nothing will be 
visible on the screen. 
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Toggle Power 

The Toggle Power function lets you power on or off the device that is 
connected to the associated outlet on a Power Distribution Unit (PDU). 
For example, if a router is connected to one of the outlets on the PDU, 
you can toggle the router’s power on or off.  

You must configure the association of outlets to the target port of the 
device before you can use the Toggle Power feature. Go to the Power 
Control tab on remote console's GUI to configure the outlets. If you have 
not done this, the system displays a message stating that the target is 
not associated with a power outlet. 

Note: If RSC is launched through CC-SG (version 4.x onwards) by users 
without the permission to toggle power, the option Toggle Power will 
appear as disabled. 

 

1. Select Toggle Power to turn the device (router) on or off. A prompt 
appears displaying the current status of the outlet(s). You can turn 
the device on or off depending on its current status. 

2. If you select No, the system returns you to the RSC screen. 

3. If you select Yes, the system sends the power command to either 
turn on or off the outlets associated to the target port of the device. 

If you receive a: 

• Hardware error message: this means that the PDU command failed. 

Software error message: this means that another user is controlling the 
power outlet and the power control command cannot be sent. 
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Chat 

When using browser access over SSL, an interactive chat feature called 
Chat allows you and other users on the same port to communicate. You 
can conduct an online dialog for training or collaborative diagnostic 
activities. The maximum length of a chat message is 300 characters. 

Note: When a chat is initiated, a chat window appears on the monitors of 
all SSL users logged on to the port. If a user is logged into a port multiple 
times, multiple chat messages will not appear to that user. 

 To open chat: 
• Choose Chat > Chat. 

 

 To clear text in a chat text box: 
• Click Clear to delete the typed text. 
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Help 

Help Topics include online assistance for operating the Raritan Serial 
Console and release information about Raritan Serial Console. 

Help Topics 

 To access help topics: 
• Choose Help > Help Topics. 

About Raritan Serial Console 

The About Raritan Serial Console dialog displays the copyright and 
version information (name and revision number) of the console terminal 
emulation software. When contacting Raritan for technical support or 
when performing a software upgrade, you may be asked for this 
information. 

 To access 'About' information: 
• Choose Help > About Raritan Serial Console. An About Raritan 

Serial Console message appears.  
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