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Introduction  Chapter 1 

This guide is intended for users who have been granted the Node In-Band 
Access, Node Out-of-Band Access, and Node Power Control privileges. 
With these privileges, you can connect to nodes, control power to nodes, 
create custom views, search for nodes, and use node chat to talk to other 
users who are connected to the same node.  

In This Chapter 
Prerequisites..............................................................................................1 
Terminology/Acronyms..............................................................................1 
 
 

Prerequisites 

Before connecting to a node, the nodes must be configured. The 
application that is used to connect to the node must also be configured. 
See Raritan's CommandCenter Secure Gateway Administrator Guide 
for additional information on nodes and applications. 
 

Terminology/Acronyms 
• iLO/RILOE - Hewlett Packard's Integrated Lights Out/Remote Insight 

Lights Out servers that can be managed by CC-SG. Targets of an 
iLO/RILOE device are powered on/off and recycled directly. 

• In-band Access - using the TCP/IP network to correct or troubleshoot 
a node in your network. You can access nodes connected to KVM and 
Serial devices via these in-band applications: RemoteDesktop Viewer, 
SSH Client, VNC Viewer. 

• IPMI Servers - Intelligent Platform Management Interface servers that 
can be controlled by CC-SG. 

• Out-of-band Access - using applications such as Raritan Remote 
Client (RRC), Raritan Console (RC), Multi-Platform Client (MPC), or 
Virtual KVM Client to correct or troubleshoot a node connected to 
KVM and Serial devices in your network. 

• Ports - connection points between a Raritan Device and a node. Ports 
exist only on Raritan devices and identify a pathway from that device 
to a node. 

• Nodes - the target systems such as servers, desktop PCs, or other 
networked equipment that CC-SG users can access. 
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Accessing CC-SG  Chapter 2 

You can access CC-SG in two ways: 

• Through a browser: CC-SG offers two browser-based access options, 
a Java-based CC-SG Admin Client and an HTML-based CC-SG 
Access Client. 
For a complete list of browsers and platforms, refer to the CC-SG 
Compatibility Matrix on the Raritan web site in the Support section 
under Firmware and Documentation.  

• Through a thick client: You can install a Java Web Start thick client on 
your client computer. The thick client functions exactly like the 
browser-based CC-SG Admin Client. 

Note: Multiple users can be connected simultaneously, using any client. 

In This Chapter 
Before You Begin ......................................................................................2 
Browser-Based Access via the CC-SG Access Client ..............................3 
Browser-Based Access via the CC-SG Admin Client ...............................5 
Thick Client Access ...................................................................................6 
Log Out from the Access Client.................................................................7 
 
 

Before You Begin 

CC-SG is accessed via a web browser from a user's PC. Verify that you 
have installed a supported Java Runtime Environment (JRE) version and 
disabled pop-up blockers. 
 

Install a Supported Java Runtime Environment (JRE) Version 

The browser must have the correct version of JRE installed before you can 
access the CC-SG Admin Client. Your administrator can recommend a 
JRE version that is different than the CC-SG minimum version. Check with 
your administrator to find out what JRE version is required. 

 To check the JRE version in a Windows OS: 
1. Open Control Panel. 

2. Click Add or Remove Programs. Check the list of currently installed 
programs for the J2SE or Java 2 Runtime Environment version 
number. 
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 To verify that the JRE version is compatible with your CC-SG 
release: 

Choose Administration > Compatibility Matrix. Look for Sun JRE in the 
Application list. 

 To upgrade JRE: 

Go to http://java.sun.com/products/archive 
(http://java.sun.com/products/archive). 
 

Disable Pop-up Blockers 

The client PC and the browser should have all pop-up blockers disabled. 

 To disable the pop-up blockers in a Windows XP OS: 
1. Open Control Panel. 

2. Click Internet Options. 

3. Click the Privacy tab. 

4. Deselect the Block Pop-ups checkbox. 

5. Click Apply, and then click OK. 
 

Browser-Based Access via the CC-SG Access Client 

The CC-SG Access client is an HTML-based client that provides a GUI for 
access tasks, based on your permissions. 

1. Using a supported Internet browser, type the URL of the CC-SG: 
https://IP address, for example, https://10.0.3.30 (https://10.0.3.30). 
The login screen appears. 

2. If the CC-SG Administrator has enabled the Restricted Service 
Agreement, read the agreement text, and then select the I Understand 
and Accept the Restricted Service Agreement checkbox. 

3. Type your Username and Password then click Log In. 

4. Upon valid login, the CC-SG Access Client's Home screen appears. 
 

http://java.sun.com/products/archive
https://10.0.3.30/
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Possible Error Messages 

If you have access to a large number of nodes, you may see the following 
error messages while CC-SG loads. 

Internet Explorer 

A script on this page is causing Internet Explorer to run slowly. If it 
continues to run, your computer may become unresponsive. Do you 
want to abort the script? 

FireFox 1.5 or 2.0 

A script on this page may be busy, or it may have stopped 
responding. You can stop the script now, or you can continue to see 
if the script will complete. 

These warning messages occur when a script is taking longer than the 
default time to run.  

 To resolve these errors: 
• When the message appears, select the option that allows the script to 

continue running. 
Depending on your particular client and server speeds and the amount 
of data loading, the message may recur. 

 To change the default time that scripts are allowed to run in 
Internet Explorer: 

Refer to Microsoft Knowledge Base article 175500 for instructions. 

 To change the default time that scripts are allowed to run in 
Firefox: 

Refer to the MozillaZine Knowledge Base article about 
dom.max_script_run_time for details on this configuration: 
http://kb.mozillazine.org/Dom.max_script_run_time 
http://kb.mozillazine.org/Dom.max_script_run_time 

1. Access the hidden configuration page in Firefox. 

a. Type about:config in the Firefox address bar. 

b. A list of hidden configurations appears. 

2. In the Filter field, type dom.max_script_run_time. The list 
refreshes to display only one item. 

3. Right-click the dom.max_script_run_time item, and choose 
Modify. 

4. In the Enter Integer value dialog that appears, type a higher value, 
such as 100. The default value is 10. 

http://kb.mozillazine.org/Dom.max_script_run_time
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Accessing Another CC-SG Unit in the Same Neighborhood 

Only the Access Client supports the drop-down list for the Neighborhood 
feature. The Neighborhood feature groups multiple CC-SG units and 
enables you to switch among these CC-SG units with single sign-on. 

After the CC-SG Administrator configures the Neighborhood feature in the 
CC-SG Admin Client, the Secure Gateway drop-down list displays at the 
top of the Access Client if the CC-SG you access is an activated member 
in a Neighborhood. 

When you switch to another CC-SG, you also need to have an account on 
that system. Otherwise, the authentication will fail. 

If you accept the Restricted Service Agreement once in any Neighborhood 
member, it is implicitly accepted for all members in the Neighborhood. 

 To access another CC-SG unit in the same Neighborhood 
1. Click the Secure Gateway drop-down arrow, and select the CC-SG 

unit you want to access from the list. 

2. Click Go. 

The node lists in the All Nodes, Favorites, and Recent tabs all change to 
display the nodes available in the new CC-SG if the access to the new 
CC-SG unit is successful. 
 

Browser-Based Access via the CC-SG Admin Client 

The CC-SG Admin client is a Java-based client that provides a GUI for 
both administrative and access tasks, depending on your permissions. 

1. Using a supported Internet browser, type the URL of the CC-SG and 
then type /admin: https://IP address/admin, for example, 
https://10.0.3.30/admin (https://10.0.3.30/admin). 

If you see the JRE Incompatibility Warning window, select the JRE 
version that is appropriate for your client computer and install it. Once 
JRE is installed, try this procedure again. See JRE Incompatibility 
(on page 6). 

Or, you can continue without installing a new JRE version.  

2. If you see a Restricted Service Agreement, read the agreement text 
and select the I Understand and Accept the Restricted Service 
Agreement checkbox. 

3. Type your Username and Password and click Log In. 

4. Upon valid login, the CC-SG Admin Client opens. 
 

https://10.0.3.30/admin
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JRE Incompatibility 

If you do not have the minimum required version of JRE installed on your 
client computer, you will see a warning message before you can access 
the CC-SG Admin Client. The JRE Incompatibility Warning window opens 
when CC-SG cannot find the required JRE file on your client computer.  

If you see the JRE Incompatibility Warning window, select the JRE version 
that is appropriate for your client computer and install it, or you can 
continue without installing a new JRE version. 

You must launch CC-SG again once JRE is installed. 

Administrators can configure the JRE minimum version that is 
recommended and the message that appears in the JRE Incompatibility 
Warning window. See Configuring Custom JRE Settings. 
 

Thick Client Access 

The CC-SG thick client allows you to connect to CC-SG by launching a 
Java Web Start application instead of running an applet through a web 
browser. The advantage of this is that the client can outperform the 
browser in terms of speed and efficiency. The CC-SG thick client provides 
the same functions as the Java-based Admin Client, a GUI for both 
administrative and access tasks, depending on your permissions. The 
minimum Java version required for running the thick client is 1.5.0.10. 
 

Install the Thick Client 
1. To download the thick client from CC-SG, launch a web browser and 

type this URL: http(s)://<IP_address>/install, where <IP_address> is 
the IP address of the CC-SG. 

2. If a security warning message appears, click Start to continue the 
download. 

3. When the download is complete, a new window in which you can 
specify the CC-SG IP address appears. 

4. Type the IP address of the CC-SG unit you want to access in the IP to 
Connect field. 

Once you have connected, this address will be available from the IP to 
Connect drop-down list. The IP addresses are stored in a properties 
file that is saved to your desktop. 

5. If the CC-SG is configured for secure browser connections, you must 
select the Secure Socket Layer (SSL) checkbox. If the CC-SG is not 
configured for secure browser connections, clear the Secure Socket 
Layer (SSL) checkbox. This setting must be correct or the thick client 
will not be able to connect to CC-SG. 
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 To check the setting in CC-SG: Choose Administration > Security. 
In the General tab, look at the Browser Connection Protocol field. 
If the HTTPS/SSL option is selected, then you must select the 
Secure Socket Layer SSL checkbox in the thick client's IP address 
specification window. If the HTTP option is selected, then you 
must deselect the Secure Socket Layer SSL checkbox in the thick 
client's IP address specification window. 

6. Click Start. 

A warning message appears if you are using an unsupported Java 
Runtime Environment version on your machine. Follow the prompts to 
either download a supported Java version or continue with the 
currently installed version. 

7. The login screen appears and the thick client looks and behaves just 
like the browser-based Java client. If the Restricted Service 
Agreement is enabled, read the agreement text, and then select the I 
Understand and Accept the Restricted Service Agreement checkbox. 

8. Type your Username and Password in the corresponding fields and 
click Login to continue. 

 

Access CC-SG with the Thick Client 

The minimum Java version required for running the thick client is 1.5.0.10. 
Java version 1.6.0 is also supported. 

Once the thick client is installed, there are different ways to access it on 
your client computer. 

 To access the thick client: 
• Launch the thick client from the Java Control Panel's Java Application 

Cache Viewer. 
• Use the Java Control Panel's Java Application Cache Viewer to install 

a shortcut icon on your desktop for the thick client. 
 

Log Out from the Access Client 

When you are finished using the Access Client, you should click one of the 
Logout links to log out. Closing the browser window without clicking a 
logout link first does not log you out of the Access Client. 

When you log out of a CC-SG that is an active member of the 
Neighborhood, it logs you out of all the CC-SG’s and terminates all node 
connections within the Neighborhood. 
 



Finding and Viewing Nodes  Chapter 3 

There are several ways to find and view nodes, depending on which client 
you are using.  

See Finding and Viewing Nodes in the Access Client (on page 8) and 
Finding and Viewing Nodes in the Admin Client (on page 12) to learn 
how to use each client's navigation and search features to find and view 
nodes. 

See Using Custom Views in the Access Client (on page 18) and Using 
Custom Views in the Admin Client (on page 20) to learn how to use 
each client's custom view feature to specify different ways to display the 
nodes in the left panel. 

In This Chapter 
Finding and Viewing Nodes in the Access Client ......................................8 
Finding and Viewing Nodes in the Admin Client .....................................12 
Custom Views..........................................................................................17 
Using Custom Views in the Access Client...............................................18 
Using Custom Views in the Admin Client ................................................20 
 
 

Finding and Viewing Nodes in the Access Client 

In the CC-SG Access Client, you can connect to nodes through their 
associated interfaces. Each node has a Node details screen, which lists all 
associated interfaces to which you have access. If a node has virtual 
media capabilities, the Node details screen displays whether virtual media 
is enabled or disabled for the node. 

Click a node in one of the node lists in the left panel (All Nodes, Favorites, 
and Recent) to open the Node details screen for the selected node. Click 
the Node tab at the top of the screen to return to the selected node's Node 
details screen after viewing other tabs. 
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CC-SG Access Client Screen Overview 

 

 
1. Secure Gateway drop-down list: The drop-down list appears at the top 

of the screen. It appears only if the CC-SG unit you are accessing is 
an activated member of a neighborhood. You can use the list to switch 
between multiple CC-SG units of the same neighborhood. 

2. Current CC-SG name: The name of the CC-SG unit you are accessing 
appears at the top of the left panel. 

3. User ID and Date: Your CC-SG system date and time and User ID 
appear at the top of the left panel. Click the User ID hyperlink to open 
the My Profile tab. 

4. Search: The Search function allows you to search for nodes in two 
ways. 

5. Node lists: Node lists appear below the search field. In each list, icons 
show the status of each node. The All Nodes list includes all nodes to 
which you have access. The Favorites list contains your personalized 
list of nodes. You can add nodes, delete nodes, and sort the list of 
Favorite nodes. The Recent list displays the ten nodes accessed most 
recently. Click a node to open the Node tab. The Node tab contains 
the Node profile, which displays details on the selected node. The 
Node tab also allows you to connect to an interface, chat with other 
users, and perform power control operations. 
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6. Helpful Links: Helpful Links contains a link to launch the CC-SG Admin 
Client - used to perform administrative functions - and a hyperlink to 
the CommandCenter Secure Gateway User Guide. 

7. On-screen Help: The Help section at the bottom of the screen can be 
expanded and collapsed by clicking the black arrow. 

8. Main Display area: The commands you select from the menu bar and 
the tool bar appear in this main area. 

9. Logout: Click Logout to log out of CC-SG. 

10. Navigation tabs: The Navigation tabs are located at the top of every 
screen. Click a tab to open the related screen. 

 

Node Lists 

The left panel of the CC-SG HTML Client contains several ways to locate 
nodes. Three lists offer different views of the nodes: All Nodes, Favorites, 
and Recent. In each list, icons display show the status of each node. You 
can click a node in one of the lists to open the Node Profile. 

You can also create Custom Views to specify different ways to display the 
nodes. See Using Custom Views in the Access Client (on page 18). 
 

All Nodes List 

The All Nodes list displays all nodes to which you have access. If you have 
applied a Custom View, the All Nodes list will display according to the 
specification of the Custom View. See Custom Views (on page 17). 
 

Sort Nodes by Name or Status 

You can sort the All Nodes list by node name or node status. 

 To sort nodes by Name: 
1. Open the All Nodes list. 

2. Choose Sort Nodes By > Name.  

 To sort nodes by Status: 
1. Open the All Nodes list. 

2. Choose Sort Nodes By > Status.  
 

Favorite Nodes List 

You can create a personalized list of the nodes you access most often in 
the Favorites list. You can add nodes, delete nodes, and sort the list of 
Favorite nodes. 
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Add a Node to Favorites 

1. Click the All Nodes or Recent list in the left panel. 

2. Click the node you want to add to Favorites. The Node details screen 
appears. 

3. In the Node details screen, click Add to Favorites. The status bar at 
the bottom of the browser window displays a confirmation message 
and the Add to Favorites link disappears from the Node details screen. 

 

Sort Nodes in Favorites 

1. Click the Favorites list in the left panel. 

2. Click Sort. The Sort Favorites window appears. 

3. Arrange the nodes in the Favorite Nodes list in the order in which you 
would like them to appear in the Favorites list. Select a node and click 
the up and down arrows to move the node into the desired sequence. 
Click Sort by Name to arrange the nodes in alphanumeric order. 

4. Click OK to save your changes. 
 

Delete a Node from Favorites 

1. Click the Favorites list in the left panel. 

2. Click the node you want to delete. The Node details screen for the 
selected node appears. 

3. Click Delete in the Favorites list to delete the node from the list. 
 

Recent Nodes List 

The Recent list displays the ten nodes you accessed most recently. Each 
node you click on is added to the top of the Recent list. 
 

Clear the Recent Nodes List 

1. Click the Recent list in the left panel. 

2. Click Clear All to clear the Recent list. 
 

Searching for Nodes 
1. Type the search terms, such as node name, in the Search for Nodes 

field at the top of the left panel. 

2. As you type, the node that most closely matches your search terms is 
highlighted in the selected node list. 

 Click Filter to load a list that includes only the nodes that match 
your search terms. 

 Click Clear to reload the complete node list and remove your 
search terms. 
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Finding and Viewing Nodes in the Admin Client 

When you log into the Admin Client as a user without administrative 
permissions, the Nodes tab on the left will be populated with all the nodes 
you can access. The menus will vary based on your other permissions. 
 

CC-SG Admin Client Screen Overview 

 
1. Nodes tab: Click the Nodes tab to display all nodes in a tree view. 

Interfaces are grouped under their parent nodes. Click + and - to 
expand or collapse the tree. Click a node to view the Node Profile. 
Right-click an interface and select Connect to connect to that interface. 
You can sort the nodes by Node Name (alphabetically) or Node Status 
(Available, Busy, Unavailable). Right-click the tree view, click Node 
Sorting Options, and then click By Node Name or By Node Status. 

2. Quick Commands toolbar: This toolbar offers shortcut buttons for 
executing common commands. 

3. Operation menu bar: These menus contain commands to operate 
CC-SG. You can access some of these commands by right-clicking on 
the icons in the Nodes selection tab. The menus and menu items you 
see are determined by your user access privileges. 

4. Main Display area: The commands you select from the menu bar and 
the tool bar display in this main area.  
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5. Server Time: The current time and time zone as configured on CC-SG. 
This time may be different than the time used by the client. 

 

Node Icons 

For easier identification of status, different-colored icons appear in the 
nodes tree.  

 

Icon Meaning 

 Node available - the node has at least one interface that is available.

 Node unavailable - all interfaces for the node are busy. 

 
 

Node Views 

All nodes to which you have access appear in the Nodes tab in the left 
panel of the CC-SG Admin Client.  

By default, nodes are arranged in a standard Tree View. The standard 
Tree View displays nodes in alphabetical order. If you want nodes to 
appear in a different order, you can create a Custom View. Custom Views 
allow you to specify different grouping of nodes, based on the categories 
they have been assigned to by the CC-SG Administrator. See Using 
Custom Views in the Admin Client (on page 20). 

In both the Tree View and the Custom Views, you can also sort nodes by 
name or by status. 
 

Tree View 

The standard Tree View displays nodes in alphabetical order. To apply the 
Tree View to the Nodes tab: 

• Choose Nodes > Change View > Tree View. The Tree View of the 
Nodes tree appears. 
 Nodes are arranged alphabetically by name. 

 Interfaces are grouped under their parent nodes. Click the + and - 
signs to expand or collapse each grouping. 

 Click the Expand  and Collapse  icons in the toolbar at the 
top of the screen to expand and collapse the entire tree. 
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Node Sorting Options 

In both Tree View or Custom View, you can sort nodes either 
alphabetically or by availability status. 

• Right-click in an empty area of the Nodes tab, click Node Sorting 
Options, and then click By Node Name or By Node Status. 
 By Node Name arranges nodes alphabetically by their names. 

 By Node Status arranges nodes by their availability status: 
Available, Busy, and Unavailable. 

 

Searching for Nodes 

The CC-SG Search function allows you to search for nodes that match 
your search terms. CC-SG offers two search types, Filter by Search 
Results and Find Matching String. 

• Filter by Search Results: type search terms and then click Search to 
display a list of nodes that match your search terms. You can use 
wildcards (*) with this search type. 

• Find Matching String: type search terms and as you type, the node in 
the list that best matches your search is highlighted. There is no 
Search button. You cannot use wildcards with this search type. 

You can set your search preference in your CC-SG profile. To access your 
profile, choose Secure Gateway > My Profile. See Set Search 
Preference (on page 47). 
 

Search for a Node 

1. Click the Nodes tab. 

2. Type a search string in the Search for Node field. 
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3. Depending on your search preference, the Nodes tree will either 
highlight the first node that matches your search terms, or you can 
click Search to filter the list of nodes to display only those nodes that 
match your search terms. 

 
 

Supported Wildcards for Node Search 

These wildcards are supported when you have Filter by Search Results 
set as your search preference in My Profile. See Set Search Preference 
(on page 47). 

 

Wildcard Description Sample Search Terms Sample Search Result 
? Indicates any character. Solaris? Locates Solaris1, and SolarisN, 

but not Solaris1Z 

[-] Indicates a character in 
range. 

Windows[0-9][0-9][0-9][0-
9] 

Locates Windows2000, and 
Windows2003 Server 

* Indicates zero or more 
characters. 

Windows* Locates Windows2000, but not 
Windows2003 Server 
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Bookmarking an Interface 

If you frequently access a node via a particular interface, you can 
bookmark it so that it is readily available from your browser. 

 To bookmark an interface in any browser: 
1. In the Nodes tab, select the interface you want to bookmark. You must 

expand the node to view the interfaces. 

2. Choose Nodes > Bookmark Node Interface. 

3. Select Copy URL to Clipboard.  

4. Click OK. The URL is copied to your clipboard. 

5. Open a new browser window and paste the URL into the address field. 

6. Press the Enter key to connect to the URL. 

7. Add the URL as a bookmark (also known as a Favorite) to your 
browser. 

 To bookmark an interface in Internet Explorer (add an interface 
to your Favorites): 

1. In the Nodes tab, select the interface you want to bookmark. You must 
expand the node to view the interfaces. 

2. Choose Nodes > Bookmark Node Interface. 

3. Select Add Bookmark (IE Only).  

4. A default name for the bookmark appears in the Bookmark Name field. 
You can change the name, which will appear in your Favorites list in 
Internet Explorer. 

5. Click OK. The Add Favorite window opens. 

6. Click OK to add the bookmark to your Favorites list. 

 To access a bookmarked interface: 
1. Open a browser window. 

2. Choose the bookmarked interface from the list of bookmarks in the 
browser. 

3. When the CC-SG Access Client appears, log in as a user who has 
access to the interface. The connection to the interface opens. 

 To get bookmark URLs for all nodes: 
• You can get bookmark URLs for all nodes in the Node Asset Report. 

See Node Asset Report. 
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Custom Views 

Custom Views enables you to specify different ways to display the nodes 
in the left panel, using Categories and Node Groups set up by the 
Administrator. 

CC-SG also includes a Tree View, which sorts the nodes in alphabetical 
order. You cannot change or delete the Tree View. 
 

Types of Custom Views 

There are two types of custom views: Filter by Node Group and View by 
Category.  
 

View by Category 

All nodes described by the categories you specify will appear in the nodes 
list when a View by Category custom view is applied. Nodes that do not 
have a category assigned will appear as "unassociated." 

 
 

What are Categories? 

CC-SG Administrators can set up Associations to help organize 
equipment. Each Association includes a Category, which is the top-level 
organizational group, and its related Elements, which are subsets of a 
Category. If the administrator has assigned Categories and Elements to 
nodes, you can set up custom views that display nodes according to the 
categories to which they belong. 

All Categories and Elements assigned to a node are listed in the node 
details screen. See CC-SG Access Client Screen Overview (on page 9). 

 
 

Filter by Node Group 

Only the node groups you specify will appear in the nodes list when a Filter 
by Node Group custom view is applied. The first level of organization is the 
node group name. A node may appear several times in the list if the node 
belongs to more than one node group defined in the custom view. Nodes 
that do not belong to a node group specified by the custom view will not 
appear in the list. 
 

What are Node Groups? 

CC-SG Administrators can set up Node Groups to help organize nodes. If 
the administrator has set up Node Groups, you can define custom views 
that specify which Node Groups you want to see in the nodes lists, and in 
what order the groups appear in the list.  
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Using Custom Views in the Access Client 

Add a Custom View 
1. Click the Custom View tab. 

2. Click Add to open the Add View window. 

3. Select Filter by Node Group to create a custom view that displays only 
the node groups you specify. Select View by Category to create a 
custom view that displays nodes according to the categories you 
specify.  

4. Type a name for the custom view in the View Name field, and then 
click OK. The new custom view name displays in the View Name field 
in the Custom View screen. 

5. In the Available list, select the item that you want to add to the custom 
view, and then click Add to move it to the Selected list. Repeat this 
step until you have added all necessary categories or node groups to 
the Selected list. 

6. Arrange the items in the Selected list in the order in which each 
grouping will appear in the All Nodes list. Select an item in the 
Selected list and click the up and down arrows to move the item into 
the desired sequence. 

7. If you have the Device, Port, and Node Management Privilege, you 
can select the System View checkbox to assign this custom view as a 
system-wide default view. Optional 

8. Click Save to save the new custom view. 
 

Apply a Custom View 
1. Click the Custom View tab. 

2. Click the View Name drop-down arrow and select from the list the 
custom view you want to apply to the All Nodes list. 

3. Click Apply View to sort the All Nodes list according to the selected 
custom view. 

 

Change a Custom View 

You cannot change the Tree View. 

1. Click the Custom View tab. 

2. The View Name field displays the name of the custom view whose 
categories are listed in the View by Category section of the screen. 

3. To change the sequence in which each category or node group 
appears in the All Nodes list, click an item in the Selected list and click 
the up and down arrows to move the item into the desired sequence. 
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4. To add an item to the custom view, select it in the Available list and 
click Add to move the item into the Selected list. 

5. To remove an item from the custom view, select it in the Selected list 
and click Remove. 

6. Click Save to save your changes.  
 

Change a Custom View's Name 
1. Click the Custom View tab. 

2. Click the View Name drop-down arrow and select the custom view 
whose name you want to change from the list. 

3. Click Edit to open the Edit View dialog. 

4. Type a new name for the custom view in the View Name field, and 
then click OK. 

 

Delete a Custom View 
1. Click the Custom View tab. 

2. Click the View Name drop-down arrow and select the custom view you 
want to delete from the list. 

3. Click Delete. You cannot delete the Tree View. 
 

Assign a Default Custom View 
1. Click the Custom View tab. 

2. Click the View Name drop-down arrow and select the custom view you 
want to assign as the default view from the list. 

3. Click Set as Default. 
 

Assign a Default Custom View for All Users 

If you have CC Setup and Control privileges, you can assign a default 
custom view for all users. 

1. Click the Custom View tab. 

2. Click the View Name drop-down arrow and select the custom view you 
want assign as a system-wide default view. 

3. Check the System View checkbox. 

4. Click Save. 

All users who log into CC-SG will see the All Nodes list sorted 
according to the Categories specified in the selected custom view. 
Users can still change the custom view. 
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Using Custom Views in the Admin Client 

Add a Custom View for Nodes 

 To add a custom view for nodes: 
1. Click the Nodes tab. 

2. Choose Nodes > Change View > Create Custom View. The Custom 
View screen appears. 

3. In the Custom View panel, click Add. The Add Custom View window 
opens. 

4. Type a name for the new custom view in the Custom View Name field. 

5. In the Custom View Type section: 

 Select Filter by Node Group to create a custom view that displays 
only the node groups you specify.  

 Select View by Category to create a custom view that displays 
nodes according to the categories you specify. 

6. Click OK. 

7. In the Custom View Details section:  

a. In the Available list, select the item you want to include in the 
custom view, and then click Add to add the item to the list. Repeat 
this step to add as many items as you want. 

b. Arrange the items in the Selected list in the order you would like 
each grouping to display in the Nodes tab. Select an item and click 
the up and down arrow buttons to move the item into the desired 
sequence. 

c. If you must remove an item from the list, select it and click 
Remove. 

8. Click Save. A message confirms that the custom view has been 
added. 

9. To apply the new custom view, click Set Current. 
 

Apply a Custom View for Nodes 

 To apply a custom view to the nodes list: 
1. Choose Nodes > Change View > Custom View. The Custom View 

screen appears. 

2. Click the Name drop-down arrow and select a custom view from the 
list.  

3. Click Apply View. 
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or 

• Choose Nodes > Change View. All defined custom views are options 
in the pop-up menu. Choose the custom view you want to apply. 

 

Change a Custom View for Nodes 
1. Click the Nodes tab. 

2. Choose Nodes > Change View > Create Custom View. The Custom 
View screen appears. 

3. Click the Name drop-down arrow and select a custom view from the 
list. Details of the items included and their order appear in the Custom 
View Details panel 

 To change a custom view's name: 
1. In the Custom View panel, click Edit. The Edit Custom View window 

opens. 

2. Type a new name for the custom view in the Enter new name for 
custom view field, and then click OK. The new view name appears in 
the Name field in the Custom View screen. 

 To change the custom view's contents: 
1. In the Custom View Details section:  

a. In the Available list, select the item you want to include in the 
custom view, and then click Add to add the item to the list. Repeat 
this step to add as many items as you want. 

b. Arrange the items in the Selected list in the order you would like 
each grouping to display in the Nodes tab. Select an item and click 
the up and down arrow buttons to move the item into the desired 
sequence. 

c. If you must remove an item from the list, select it and click 
Remove. 

2. Click Save. A message confirms that the custom view has been 
added. 

3. To apply the new custom view, click Set Current. 
 

Delete a Custom View for Nodes 

 To delete a custom view for nodes: 
1. Click the Nodes tab. 

2. Choose Nodes > Change View > Create Custom View. The Custom 
View screen appears. 
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3. Click the Name drop-down arrow, and select a custom view from the 
list. Details of the items included and their order appear in the Custom 
View Details panel 

4. In the Custom View panel, click Delete. The Delete Custom View 
confirmation message appears. 

5. Click Yes. 
 

Assign a Default Custom View for Nodes 

 To assign a default custom view for nodes: 
1. Click the Nodes tab. 

2. Choose Nodes > Change View > Create Custom View. The Custom 
View screen appears. 

3. Click the Name drop-down arrow, and select a custom view from the 
list.  

4. In the Custom View panel, click Set as Default. The next time you log 
in, the selected custom view will be used by default. 

 

Assign a Default Custom View of Nodes for All Users 

If you have the CC Setup and Control privilege, you can assign a default 
custom view for all users. 

 To assign a default custom view of nodes for all users: 
1. Click the Nodes tab. 

2. Choose Nodes > Change View > Create Custom View. 

3. Click the Name drop-down arrow, and select the custom view you 
want assign as a system-wide default view. 

4. Select the System View checkbox, and then click Save. 

All users who log into CC-SG will see the Nodes tab sorted according to 
the selected custom view. Users can change the custom view. 
 



Connecting to Nodes  Chapter 4 

There are several methods for connecting to nodes, depending on which 
client you are using. However, once you connect, the workflow for each 
interface type is the same with either client. See Understanding 
Interfaces (on page 28). 

See Connecting to Nodes using the Access Client (on page 24) and 
Connecting to Nodes using the Admin Client (on page 26) to learn 
each client's connection methods. 

Then review the following sections to learn the workflow and see the 
typical applications for each interface type. See Applications for 
Accessing Nodes (on page 27). 

• Connect to a Node via an Out-of-Band KVM Interface (on page 29) 
• Connect to a Node via an Out-of-Band Serial Interface (on page 

31) 
• Connect to an iLO Processor Enabled Node (on page 32) 
• Connect to a Node via an In-Band KVM Interface (on page 32) 
• Connect to a Node via a Web Browser Interface (on page 33) 

Power Control for nodes is handled differently, based on which client you 
are using. See Power Control for Nodes Using the Access Client (on 
page 37) and Power Control for Nodes Using the Admin Client (on 
page 40). 
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Connecting to Nodes using the Access Client 

There are two ways to connect to a node in the Access Client. Each of 
these options launches the associated application and connects to the 
node. 

• Double-click the node in one of the nodes lists in the left panel.  
• Click the Name hyperlink in the Interfaces section of the node details 

screen. 
 

Node Profile Screen Overview: Access Client 

In the Access Client, you can view all node details in the Node tab.  

Click a node in one of the node lists in the left panel (All Nodes, Favorites, 
and Recent) to open the Node profile screen. Click the Node tab at the top 
of the screen to return to the Node profile screen after viewing other tabs. 
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Displayed Information and Features 
• The selected node＇s name appears at the top of the Node profile 

screen. You can add the node to the Favorites list by clicking Add to 
Favorites. See Favorite Nodes List (on page 10). 

• If the selected node is a blade chassis, the name of the device 
managing the blade chassis appears below the node name. 

• If the selected node is a blade server, the name of the blade chassis 
where the server resides appears. A slot number may also appear 
based on the blade server model. 

• You can chat with other users who are connected to the same node as 
you. See Node Chat Using the Access Client (on page 43). 

• You can access help by expanding the Help section at the bottom of 
the node profile or by clicking the Help tab to view all help topics. 

Tabs 
• The Interfaces tab lists the connection Type, Name, Status, 

Availability, and Device/IP Address for interfaces associated with the 
selected node. The Device/IP Address column lists device names for 
out-of-band interfaces and embedded server IP address for in-band 
interfaces. If a node has virtual media capabilities, a Virtual Media 
column lists the status, Enabled or Disabled. If you want to connect to 
the node, click the Name hyperlink to open the associated application 
and connect to the node. The Power Control section lists all power 
sources for the selected node. When a node has two or more power 
interfaces, the Advanced link displays next to the Power Control 
section. See Power Control for Nodes Using the Access Client (on 
page 37). 

• The Associations tab lists the Categories and Elements associated 
with the selected node. CC-SG Administrators can set up 
Associations to help organize the equipment that CC-SG manages. 
Each Association includes a Category, which is the top-level 
organizational group, and its related Elements, which are subsets of a 
Category. You can use Associations to create Custom Views that help 
you organize the All Nodes list in different ways. See Custom Views 
(on page 17) for details. 

• The Location & Contacts tab contains information about a node's 
location and contact information, such as phone numbers, that you 
may need when working on a node. 

• The Notes tab contains a tool to add notes about a node for other 
users to read. All notes appear in the tab with the date, username, and 
IP address of the user who added the note.  

• The Audit tab contains a list of the reasons that a node was accessed. 
You must enter a reason for access before connecting to a node when 
the administrator has enabled node auditing for your user group. The 
Audit tab is hidden if the feature is disabled, or if no reasons for access 
have been entered. 
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• The Control System Data tab, Virtual Host Data tab, and Virtual 
Machine Data tabs appear on nodes in your virtual infrastructure with 
information about the virtual node. Each tab contains information 
specific to the Control System, Virtual Host, or Virtual Machine. 

• The Blades tab appears on blade chassis nodes and contains 
information about the blade servers residing in the blade chassis. 

 

Connecting to Nodes using the Admin Client 

There are several ways to connect to nodes in the Admin Client. Each of 
these options launches the associated application and connects to the 
node. 

• When a node is selected in the Nodes tab, press the Enter key to 
connect to the node using the default interface.  

• When an interface is selected in the Nodes tab, press Enter to connect 
to the node using the selected interface.  

• When a node's status is Available, double-click the node in the Nodes 
tab to connect to the node using the default interface. If the node's 
status is Unavailable, double-clicking the node has no effect. 

• When an interface is up and the availability is idle or connected, 
double-click the interface label in the Nodes tab to connect to the node 
using the selected interface. If the interface is down or the availability 
is busy, double-clicking the interface has no effect. 

• Click an interface hyperlink in the Node profile screen to connect to the 
node using the interface. 

• Right-click an interface in the Nodes tab, then choose Connect. 
 

Node Profile Screen Overview: Admin Client 

In the Admin Client, you can view all node details in the Node profile 
screen. Select a node in the Nodes tab to open the Node profile screen. 

• The selected node’s name displays at the top of the Node profile 
screen.  

• The Interfaces tab lists the connection Type, Name, Status, 
Availability, and Device/IP address for interfaces associated with the 
selected node. If a node has virtual media capabilities, a Virtual Media 
column lists the status, Enabled or Disabled. Interfaces for power 
control are also listed in the Interfaces section. See Power Control 
for Nodes Using the Admin Client (on page 40). 

Note: In-Band - iLO Processor KVM, In-Band - DRAC KVM and 
In-Band - RSA KVM will not display any Availability. 
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• The Associations tab lists the Categories and Elements associated 
with the selected node. CC-SG Administrators can set up 
Associations to help organize the equipment that CC-SG manages. 
Each Association includes a Category, which is the top-level 
organizational group, and its related Elements, which are subsets of a 
Category. You can use Associations to create Custom Views that help 
you organize the All Nodes list in different ways. See Custom Views 
(on page 17) for details. 

• The Location & Contacts tab contains information about a node's 
location and contact information, such as phone numbers, that you 
may need when working on a node. 

• The Notes tab contains a tool to add notes about a node for other 
users to read. All notes appear in the tab with the date, username, and 
IP address of the user who added the note.  

• The Audit tab contains a list of the reasons that a node was accessed. 
You must enter a reason for access before connecting to a node when 
the administrator has enabled node auditing for your user group. The 
Audit tab is hidden if the feature is disabled, or if no reasons for access 
have been entered. 

• The Control System Data tab, Virtual Host Data tab, and Virtual 
Machine Data tabs appear on nodes in your virtual infrastructure with 
information about the virtual node. Each tab contains information 
specific to the Control System, Virtual Host, or Virtual Machine. 

• The Blades tab appears on blade chassis nodes and contains 
information about the blade servers residing in the blade chassis. 

 

Applications for Accessing Nodes 

When you connect to an out-of-band node, the default Raritan application 
for the node opens. 

Applications include: 

• Raritan Console (RC) 
• Raritan Serial Console (RSC) 
• Raritan Remote Client (RRC) 
• Multi-Platform Client (MPC) 
• Virtual KVM Client 

See Raritan's KVM and Serial Access Clients User Guide for detailed 
instructions each client. 

You can find these guides on the Raritan web site in the Support section 
under Firmware and Documentation. 

When you connect to an in-band or virtual node, the vendor's application 
for the node opens. 
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Understanding Interfaces 

Each node has one or more interfaces through which you can connect to 
it. 

There are many interface types, each providing different types of access 
to nodes. The abbreviations in this table are used in the Admin Client's 
Nodes tab as a prefix to the interface name. 

Interface Type Interface Abbreviation 
Out-of-Band KVM OOB-KVM   

Out-of-Band Serial OOB-Serial  

In-Band DRAC KVM  IB-DRAC 

In-Band RSA KVM IB-RSA    

In-Band iLO Processor KVM  IB-ILO Processor 

In-Band SSH    IB-SSH 

In-Band VNC   IB-VNC 

In-Band RDP   IB-RDP   

In-Band Telnet IB-TELNET 

Power Control: iLO Processor   PWR-ILO Processor 

Power Control: DRAC    PWR-DRAC 

Power Control: IPMI PWR-IPMI 

Power Control: Managed Power 
Strip 

PWR-PDU 

Power Control: RSA   PWR-RSA  

Web Browser WEB  

VI Client VIC 

VMware Viewer VMV 

Virtual Power Virtual PWR 



 Chapter 4: Connecting to Nodes 
 

 
29

 

 To view the interfaces associated with a node 

Select a node to open the Node Profile screen. All interfaces associated 
with the node are listed in the Interfaces section. 

In the Access Client, power control interfaces are listed in the Interfaces 
section. 

 To check an interface's Availability 

You can see whether an interface is available by checking the Availability 
column in the Node Profile's Interface section. 

 

Availability Meaning 
Idle The interface is not in use. 

Connected The interface is in use, but it is available to additional 
users. 

Busy The interface is busy and cannot accept any additional 
users. 

Inaccessible There are no available paths to the Blade Server node as 
they are all in use. 

Note: Nodes connected to KX 1.4 devices do not use the “Busy” 
Availability category described above. If an interface to a node connected 
to a KX 1.4 displays the “Connected” Availability category, the interface 
may be either Connected or Busy. 
 

Connect to a Node via an Out-of-Band KVM Interface 

1. Select the node to which you want to connect. The Node profile screen 
appears. 

In the Node profile screen, all configured interfaces appear in the 
Interface section. 

2. In the Name column, click the hyperlink of the Out-of-Band KVM 
interface you want to use to connect to the node. 

3. If node auditing is enabled for your user group, the Access Information 
dialog appears. Enter your reason for accessing the node and then 
click OK. 

4. The RRC, MPC, or Virtual KVM Client application opens in a new 
window. 

Note: If you are using FireFox 3.0.3, you may experience problems 
launching the application. If this occurs, clear the browser cache and 
launch the application again. 
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5. A Connection Status window opens. Once a connection is established, 
RRC, MPC, or Virtual KVM Client opens. 
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Note: If using the MPC application, saving the user profile from MPC 
also saves it to CC-SG. Thereafter, when connecting to a node using 
MPC, the saved settings are applied to the MPC session. 

 
6. To disconnect from RRC or Virtual KVM Client, choose Connection > 

Exit. To disconnect from MPC, click the close button in the top right 
corner of the window. 

Note: If the KVM node is on sleep mode and indicates “no video 
signal,” press the space bar on your keyboard until the node exits 
sleep mode. 

 

Connect to a Node via an Out-of-Band Serial Interface 

1. Select the node to which you want to connect. The Node profile screen 
appears. 

In the Node profile screen, all configured interfaces appear in the 
Interface section. 

2. In the Name column, click the hyperlink of the serial interface you want 
to use to connect to the node. 

3. If node auditing is enabled for your user group, the Access Information 
dialog appears. Enter your reason for accessing the node and then 
click OK. 
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4. The RSC application opens in a new window. Use the application to 
manage the node. 

5. When you are finished using RSC to manage the port, choose 
Emulator > Exit. 

 

Accessing a Serial Interface for the First Time 

If the node is configured for a console application, a Security Warning 
appears, indicating that the console applet is a signed applet from Raritan 
Systems. Click Yes and the console appears. 

Important: The security warning (appearing in IE only) appears the 
first time the user connects to a serial interface. Click Yes when this 
display appears; if you click No, the console application does not 
launch and you must exit CC-SG, close the browser, re-launch the 
browser, and connect to CC-SG again. 
 

Connect to an iLO Processor Enabled Node 

1. In the Nodes tree, select the iLO/RILOE node you want to connect to 
and manage. The Node details screen appears. 

2. In the Node details screen, all configured interfaces appear in the 
Interface section. 

3. In the Name column, click the hyperlink of the KVM interface you want 
to use to connect to the node. 

4. If node auditing is enabled for your user group, the Access Information 
dialog appears. Enter your reason for accessing the node and then 
click OK. 

5. The HP Remote Console applet launches. When the applet loads, you 
have KVM access to the iLO/RILOE-enabled server. 

6. When you are finished using Remote Console, close the browser 
window. 

 

Connect to a Node via an In-Band KVM Interface 

CC-SG supports SSH Keyboard Interactive Authentication, so this 
authentication mechanism can be enabled in a SSH server. 

1. In the Nodes tree, select the node you want to connect to and manage. 
The Node Profile page opens. 

2. In the Node Profile screen, all configured interfaces display in the 
Interfaces section. 

3. In the Name column, click the hyperlink of the In-Band KVM interface 
you want to use to connect to the node. 

4. Depending on the interfaces, this step varies. 
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 For SSH, TELNET, and VNC interfaces, the Application Startup 
Parameters dialog appears if CC-SG Administrators have not 
configured the username and password in the interfaces. Type 
the Username and Password, and click OK. 

 For RDP interfaces, the Application Startup Parameters dialog 
appears. If CC-SG Administrators have not configured the 
username and password in the interfaces, you must type the 
Username and Password in the dialog. Select the Screen Size 
and Color Depth you want to use for this session and click OK. 

5. If node auditing is enabled for your user group, the Access Information 
dialog appears. Enter your reason for accessing the node and then 
click OK. 

6. The Remote Console applet launches in a new window. When the 
applet loads, you have KVM access to the node. 

Note: If you cannot connect to an in-band KVM interface, it may 
already be occupied by another user. 

7. When you are finished using Remote Console, close the browser 
window. 

 

Connect to a Node via a Web Browser Interface 

A web browser interface allows you to launch a browser and connect to 
web applications associated with a node. Some examples of web-enabled 
nodes include the Raritan Dominion PX or nodes that contain RSA, DRAC, 
or ILO Processor cards. 

 To connect to a node via a web browser interface: 
1. Select the node whose web application you want to use in one of the 

node lists in the left panel. The Node details screen appears. 

In the Node details screen, all configured interfaces appear in the 
Interface section. 

2. In the Name column, click the hyperlink of the web browser interface 
you want to use to connect to the node. 

3. If node auditing is enabled for your user group, the Access Information 
dialog appears. Enter your reason for accessing the node and then 
click OK. 

4. Your default browser launches and opens the URL associated with 
the Web Browser interface. You may have to log in to gain access.  

5. When you are finished using the web application, close the browser 
window to end the connection. 
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Connect to a Control System or Virtual Host Node via a VI Client Interface 

If you are using Internet Explorer, you must enable the following options 
for cookie handling. In the browser, choose Tools > Internet Options. In 
the Privacy tab, click Advanced. Select "Override automatic cookie 
handling." Select Accept for First-party Cookies and Third-party Cookies. 
Select "Always allow session cookies." 

1. Select the control system or virtual host node you want to connect to in 
one of the node lists in the left panel. 

2. In the Interfaces tab, click the VI Client interface. 

3. If node auditing is enabled for your user group, the Access Information 
dialog appears. Enter your reason for accessing the node and then 
click OK. 

4. Enter your username and password if requested. If single sign-on is 
enabled, you are connected directly to the VMware Virtual 
Infrastructure Web Access client.  

 

Connect to a Virtual Machine Node via a VMW Viewer Interface 

If you are using Firefox on Windows, you must add the IP address of the 
CC-SG to the Allowed Sites for Add-ons list and the Allowed Sites for 
Pop-ups list in the browser before connecting to a VMW Viewer interface.  

The first time you connect to a virtual machine, using any supported 
browser, you may be asked to download an add-on from VMware. Once 
the add-on is installed, restart your browser. 

1. Select the virtual machine node you want to connect to in one of the 
node lists in the left panel. 

2. In the Interfaces tab, click the VMW Viewer interface. 

3. If node auditing is enabled for your user group, the Access Information 
dialog appears. Enter your reason for accessing the node and then 
click OK. 

4. The Virtual Machine Remote Console window opens. 
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Disconnect from a Node 

There are several ways to disconnect from a node. Please follow the 
instructions for the client you are using. 

 To disconnect from a node using the Access Client: 

Close the application that you are using to manage the node. 

 To disconnect from a node using the Admin Client: 
• In the Nodes tab, select the active node you want to disconnect from. 

Choose Nodes > Disconnect. 
• In the Nodes tab, right-click the active node you want to disconnect 

from, and choose Disconnect. 
• In the Nodes tab, right-click the active interface through which you are 

connected to the node, and choose Disconnect. 
• Close the application that you are using to manage the node. 

Note 1: As a normal user, you cannot disconnect from nodes whose 
connections you did not initiate. 

Note 2: As a CC Super-User, you can terminate any user's node 
connection sessions, including those initiated by another CC Super-User, 
in the Admin Client. 

Note 3: As a CC-SG Administrator, you can terminate any user's node 
connection sessions, except those initiated by a CC Super-User, in the 
Admin Client. 

 
 



Power Control  Chapter 5 

CC-SG enables you to control power for single nodes or node groups that 
have power interfaces associated with them.  

You can perform power on, power off, cycle power, and graceful shutdown 
operations. You can also perform suspend operations for virtual nodes.  

Graceful shutdown allows the node to complete any processes it is 
currently running, while not allowing any new processes to begin, so that 
the node can shutdown without interrupting anything. Graceful shutdown 
is not available for all node types. 

 

In This Chapter 
What are Power Control Interfaces? .......................................................36 
Tips on Controlling Power to Nodes with Multiple Interfaces ..................36 
Power Status Messages..........................................................................37 
Power Control for Nodes Using the Access Client..................................37 
Power Control for Nodes Using the Admin Client ...................................40 
 
 

What are Power Control Interfaces? 

Power control interfaces provide control of each power supply to the node. 

Power control interfaces include: 

• In-band power control interfaces, such as IPMI, iLO, DRAC, and RSA, 
which control the node power directly.  

• Managed powerstrip interfaces, which control node power via an 
outlet on a powerstrip or Dominion PX device. 

• Virtual power interfaces, which control power to virtual machines. 
 

Tips on Controlling Power to Nodes with Multiple Interfaces 

Follow these tips when cycling power to: 

• servers with dual power supplies  
• servers with embedded management cards that are also connected to 

outlets of managed powerstrips 
1. When you must Cycle the power of a server with dual power supplies, 

make sure that both managed powerstrip interfaces are selected, and 
that these interfaces appear close to each other in the list of selected 
interfaces, as the order of execution is based on their order in the 
group. 
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2. When you must Cycle the power of a server with an embedded 
management card that is also connected to a Raritan managed 
powerstrip, select either the managed powerstrip interface, or the 
embedded power interface, but not both, to perform the power control 
operation. If both interfaces are selected, the timing of the commands 
may not allow the server's power to cycle. 

3. It takes approximately one second to issue a power control command 
to a managed powerstrip or an embedded server management card.  

See Power Control for Nodes Using the Access Client (on page 37) 
and Power Control for Nodes Using the Admin Client (on page 40). 
 

Power Status Messages 

The Power Status Messages window opens when you begin a power 
control operation. You should keep this window open until all power 
control operations are completed. 

You can resize, minimize, or maximize the Power Status Messages 
window. You can select and then copy and paste the text in the window. 

The messages in the Power Status Messages window are updated as new 
information is received about the status of the power control operation.  

A new message appears in the Power Status Messages window when: 

 Power control operation request is sent 

 Power control operation fails 

 Power control operation completes successfully 

 All power control operations requested complete successfully 

 How to get status updates if you close the Power Status 
Messages window: 

• When a power control operation fails, an alert message containing 
information about the failed operation appears.  

• The status bar at the bottom of your browser window displays an alert 
message when the entire operation completes successfully.  

• Alert messages appear only for failed operations. Alert messages do 
not appear for successful operations. 

 

Power Control for Nodes Using the Access Client 

The Access Client offers several methods for controlling power to nodes 
and node groups. 
 



Chapter 5: Power Control 
 

38
 

 

Single Node Power Control 

Single node power control allows you to control power for all or selected 
interfaces within a single node.  

See Tips on Controlling Power to Nodes with Multiple Interfaces (on 
page 36) for details on setting up power control operations for nodes with 
more than one power control interface. 

 Control power for all interfaces of a single node: 
1. Click the node for which you want to control power in one of the node 

lists in the left panel. The Node details screen appears. 

2. In the Power Control section, click On, Off, Cycle, Graceful Shutdown, 
or Suspend to perform the corresponding power control operation for 
all interfaces associated with the node. 

3. A Power Status Messages window opens to show you the status of 
the power control operation. Messages populate the window as new 
information is received about the power control operation. Keep this 
window open until all power control operations are complete, so that 
you can monitor progress. 

4. See Power Status Messages (on page 37) for details on how CC-SG 
alerts you to successful and failed power control operations. 

 Control power for multiple interfaces of a single node: 

If a node has dual power supplies, you should have a power control 
interface for each power supply. Single Node Power Control enables you 
to perform a power control operation on only one or multiple interfaces. 

1. There are two ways to access Single Node Power Control for multiple 
interfaces: 

a. Click the Power Control tab at the top of the screen, and then click 
Single Node Power Control to open the Single Node Power 
Control screen. 

b. Click the node for which you want to control power in one of the 
node lists in the left panel, and then click Advanced in the Power 
Control section of the Node details screen for the selected node. 

2. Click the Node drop-down arrow and select the node for which you 
want to control power from the list. The Available list displays all 
interfaces in the selected node. 

3. In the Available list, select the specific interface upon which you want 
to perform power control and click Add to move the interface to the 
Selected list. Repeat this step until you have added all necessary 
interfaces to the Selected list. 
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4. Arrange the interfaces in the Selected list in the order you would like 
CC-SG to perform the power operation. Select an interface in the 
Selected list and click the up and down arrows to move the interface 
into the desired sequence. 

5. Click the Operations drop-down arrow, and select On, Off, Cycle, 
Graceful Shutdown, or Suspend from the list. 

6. If you selected multiple interfaces, type the number of seconds (from 
0-120) that should elapse between interfaces in the Sequence Interval 
(seconds) field. 

7. Click OK to begin the power control operation. Click OK in the 
confirmation message to start the operation. 

8. A Power Status Messages window opens to show you the status of 
the power control operation. Messages populate the window as new 
information is received about the power control operation. Keep this 
window open until all power control operations are complete, so that 
you can monitor progress. 

See Power Status Messages (on page 37) for details on how CC-SG 
alerts you to successful and failed power control operations. 

 

Node Group Power Control 

Node Group Power Control allows you to control power for all or selected 
interfaces associated with nodes in a node group. For power on and power 
off operations, you can select the order in which interfaces are powered on 
and off. 

See Tips on Controlling Power to Nodes with Multiple Interfaces (on 
page 36) for details on setting up power control operations for nodes with 
more than one power control interface. 

 Control power for all or selected interfaces in a node group: 
1. Click the Power Control tab at the top of the screen, and then click 

Node Group Power Control to open the Node Group Power Control 
screen. 

2. Click the Node Group drop-down arrow and select the node group for 
which you want to control power from the list. The Interfaces for Power 
Control table lists all interfaces in the selected node group. 

3. Select options from the Node, Interface Type, and Device drop-down 
menus if you want to filter the list of available interfaces. As you make 
selections, the Interfaces for Power Control table updates the list of 
interfaces that will be included in the power operation. Optional 

4. Deselect the checkboxes next to power interfaces you want to exclude 
from the power operation. Optional 

5. Click the Operations drop-down arrow, and select On, Off, Cycle, 
Graceful Shutdown, or Suspend from the list. 
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6. If you selected multiple interfaces, type the number of seconds (from 
0-120) that should elapse between interfaces in the Sequence Interval 
(seconds) field. 

7. Click OK to begin the power control operation.  

8. A Power Status Messages window opens to show you the status of 
the power control operation. Messages populate the window as new 
information is received about the power control operation. Keep this 
window open until all power control operations are complete, so that 
you can monitor progress. 

See Power Status Messages (on page 37) for details on how CC-SG 
alerts you to successful and failed power control operations. 

 

Power Control for Nodes Using the Admin Client 

The Admin Client offers several methods for controlling power to nodes 
and node groups. 
 

Single Interface Power Control 

In the CC-SG Admin Client, you can select the power operation you want 
to perform on a specific power control interface using the interface's 
right-click menu. 

1. In the Nodes tab, right-click the power control interface, and then click 
the power operation you want to perform. The Power Control screen 
opens. 

2. The selected interface name displays in the Selected list. The power 
operation you selected on the right-click menu is populated in the 
Operation field. 

3. Click OK to send the power operation request to the node. A 
confirmation message appears in the screen.  

4. A Power Status Messages window opens to show you the status of 
the power control operation. Messages populate the window as new 
information is received about the power control operation. Keep this 
window open until all power control operations are complete, so that 
you can monitor progress. 

5. See Power Status Messages (on page 37) for details on how CC-SG 
alerts you to successful and failed power control operations. 
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Single Node Power Control 

You can power on, power off, cycle power, and perform graceful shutdown 
to a single node that has an associated power interface. If a node has 
more than one power interface, you can select which interfaces you want 
to use in the power control operation. 

See Tips on Controlling Power to Nodes with Multiple Interfaces (on 
page 36) for details on setting up power control operations for nodes with 
more than one power control interface. 

1. Click the Nodes tab. 

2. Select the node upon which you want to perform power control. 

3. Choose Nodes > Power Control. The Power Control screen opens. 

4. The selected node's name appears in the Node field. 

5. The node's power interfaces appear in the Selected list. 

6. Arrange the interfaces in the Selected list in the order you would like 
CC-SG to perform the power operation. Select an interface in the 
Selected list and click the up and down arrows to move the interface 
into the desired sequence. 

7. Click the Operation drop-down arrow, and select Power On, Power Off, 
Power Cycle, Graceful Shutdown, or Suspend from the list. 

8. If you selected Power On, Power Off, Graceful Shutdown, or Suspend 
in the Operation field, and more than one interface in the Selected list, 
type the number of seconds (from 0-120) that should elapse between 
interfaces in the Sequence Interval (seconds) field. 

9. Click OK to send the power operation request through the interface. A 
confirmation message appears. 

10. A Power Status Messages window opens to show you the status of 
the power control operation. Messages populate the window as new 
information is received about the power control operation. Keep this 
window open until all power control operations are complete, so that 
you can monitor progress. 

11. See Power Status Messages (on page 37) for details on how CC-SG 
alerts you to successful and failed power control operations. 
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Node Group Power Control 

You can power on, power off, cycle power, and perform graceful shutdown 
for all nodes that have associated power interfaces in a node group.  

This is useful if you need to power down all nodes in a node group so that 
you can rewire the rack on which they are mounted or if you need to 
perform other types of maintenance on a node group. 

See Tips on Controlling Power to Nodes with Multiple Interfaces (on 
page 36) (in the CC-SG User Guide) for details on setting up power 
control operations for nodes with more than one power control interface. 

1. Click the Nodes tab. 

2. Choose Nodes > Group Power Control. The Group Power Control 
screen appears. 

3. Click the Node Group drop-down arrow and select the node group 
whose power you want to control from the list. 

4. In the Available list, select the specific interface on which you want to 
perform power control, and then click Add to move the interface to the 
Selected list. Repeat this step until you have added all necessary 
interfaces to the Selected list. If you must remove an interface, select 
the interface in the Selected list, and then click Remove. 

5. Arrange the interfaces in the Selected list in the order you would like 
CC-SG to perform the power operation. Select an interface in the 
Selected list and click the up and down arrows to move the interface 
into the desired sequence. 

6. Click the Operation drop-down arrow, and select Power On, Power Off, 
Power Cycle, Graceful Shutdown, or Suspend from the list. 

7. If you selected Power On, Power Off, Graceful Shutdown, or Suspend 
in the Operation field, type the number of seconds (from 0-120) that 
should elapse between interfaces in the Sequence Interval (seconds) 
field. 

8. Click OK to send the power operation request through the selected 
interfaces. A confirmation message appears. 

9. A Power Status Messages window opens to show you the status of 
the power control operation. Messages populate the window as new 
information is received about the power control operation. Keep this 
window open until all power control operations are complete, so that 
you can monitor progress. 

See Power Status Messages (on page 37) for details on how CC-SG 
alerts you to successful and failed power control operations. 
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In This Chapter 
Node Chat Using the Access Client ........................................................43 
Node Chat Using the Admin Client..........................................................43 
 
 

Node Chat Using the Access Client 

You can chat with other users who are connected to the same node as you. 
Any participant can end a chat session. However, if the user who initiated 
the chat ends the session, then the entire chat session is terminated and 
all chat windows are closed. If you end a chat session and you are not the 
initiator, then you can rejoin the session later if it is still active. 

1. Click the connected node whose other users you want to chat with in 
one of the node lists in the left panel. The Node details screen opens. 

2. Click Open Chat beneath the Interface section. The Chat dialog 
appears. 

3. Type your message in the bottom box and click Send. 

4. To end the chat session, click Close.  
 

Node Chat Using the Admin Client 

Chat provides a way for users connected to the same node to 
communicate with each other. You must be connected to a node to start a 
chat session for that node. Only users on the same node will be able to 
chat with each other. 

 To participate in a chat session: 
1. Click the Nodes tab. 

2. Right-click on a node to which you are currently connected and select 
Chat. Click Start Chat Session if no session has been created yet. A 
Chat session will be created. 

If a chat session is in progress, right-click on the node, select Chat, 
then Show Chat Session to join the chat session. 

The chat session window will appear with the message fields on the 
left and a list of users in the chat session on the right. 

3. Type a message in the new message (lower left) field and either press 
the Enter key or click Send. The message will appear in the chat 
(upper left) field for all users to see. 

4. Click Clear to clear any message you have typed in the new message 
field but have not sent. Clear will not clear the chat field. 
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5. Click Close to leave or end the chat session. 

6. You will be prompted if you want to close the chat session. Click Yes 
to close the chat session for all participants, click No to exit the chat 
session but leave it running for others. 

You can also close a chat session for all participants from the nodes 
tab. Right click on the node with the chat session, select Chat, then 
End Chat Session. 
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In This Chapter 
My Profile in the Access Client ................................................................45 
My Profile in the Admin Client .................................................................46 
 
 

My Profile in the Access Client 

The My Profile tab allows you to change your password, email address, 
and default node list. 
 

Change Your Password 

You can change your password if your account is locally authenticated. If 
your account uses remote authentication, contact the administrator to 
change your password. 

 To change your password: 
1. Click the My Profile tab. The My Profile screen opens 

2. Select the Change Password (For Local Authentication Only) 
checkbox to activate the change password fields. 

3. Type your current password in the Old Password field. 

4. Type your new password in the New Password and Retype New 
Password fields. 

5. Click OK. 

Note: If you see a Strong passwords are required text label next to the 
New Password field, the Administrator has enabled strong passwords. 
Strong passwords must contain a minimum of 8 characters and satisfy 
other requirements as defined by the Administrator. 

If you see a Strong passwords are not required text label next to the New 
Password field, the Administrator has not enabled strong passwords. Your 
password must contain 6-16 characters. 
 

Change Your Email Address 

The Email Address field in the My Profile screen displays the email 
address currently associated with your CC-SG User ID. 

1. Click the My Profile tab. The My Profile screen opens 

2. Type your new email address in the Email Address field. 

3. Click OK. 
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Set Default Node List 

The Default Node List field in My Profile allows you to define which node 
list appears in the left panel upon login. 

1. Click the My Profile tab. The My Profile screen opens 

2. Click the Default Node List drop-down arrow, and then select All 
Nodes, Favorite Nodes, or Recent Nodes from the list. 

3. Click OK to save your default node list selection. 
 

My Profile in the Admin Client 

My Profile allows you to change your CC-SG password and email address, 
adjust the CC-SG display's font size, and set your default search type 
preference. You can also view information about how long you can use 
your password before you are forced to change it. 
 

Change Your Password 

You can change your CC-SG password whenever you want, provided 
your account is locally authenticated. If your account uses remote 
authentication, contact the administrator to change your password. 

The CC-SG Administrator can configure CC-SG to force you to change 
your password periodically. 

 To change your password: 
1. Choose Secure Gateway > My Profile. The Change My Profile screen 

appears. 

2. Select the Change Password (For Local Authentication Only) 
checkbox to activate the change password fields. 

3. Type your current password in the Old Password field. 

4. Type your new password in the New Password and Retype New 
Password fields. 

Note: If you see a Strong passwords are required text label next to the 
New Password field, the Administrator has enabled strong passwords. 
Strong passwords must contain a minimum of 8 characters, and 
satisfy other requirements as defined by the Administrator. If you see 
a Strong passwords are not required text label next to the New 
Password field, the Administrator has not enabled strong passwords. 
Your password must contain 6-16 characters. 

5. Click OK to set your new password. 
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Change Your Email Address 
1. Choose Secure Gateway > My Profile. The Change My Profile screen 

appears. 

2. Type your new email address in the Email address field. 

3. Click OK. 
 

Change the CC-SG Font Size 

CC-SG will use the font size you select for all text in its screens. 

1. Choose Secure Gateway > My Profile. The Change My Profile screen 
appears. 

2. Click the Font Size drop-down arrow and select the font size that you 
want CC-SG to use in its screens. 

3. Click OK. 
 

Set Search Preference 

CC-SG offers two search types, Filter by Search Results and Find 
Matching String. You can set your search preference in My Profile. 

• Filter by Search Results: type search terms and then click Search to 
display a list of nodes that match your search terms. You can use 
wildcards (*) with this search type. 

• Find Matching String: type search terms and as you type, the node in 
the list that best matches your search is highlighted. There is no 
Search button. You cannot use wildcards with this search type. 

 To set your search preference: 
1. Choose Secure Gateway > My Profile. The Change My Profile screen 

appears. 

2. In the Search Preference panel, click the radio button that 
corresponds to the search type you want to use. 

3. Click OK. 
 



Keyboard Shortcuts  Appendix A 

The following keyboard shortcuts can be used in the Admin Client. 

 

Operation Keyboard Shortcut 
Refresh F5 

Print panel Ctrl + P 

Help F1 
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